summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2020-01-31 21:21:54 +0300
committerMiroslav Šulc <fordfrog@gentoo.org>2020-02-08 11:26:15 +0100
commitc011df2ba115c9b79d4e8e4e8e5a214631bfc369 (patch)
treeba4f8d08bd023493648aa0cea7333ca5f8d1e5a7 /media-sound
parentsci-calculators/qalculate-gtk: fix libqalculate minimum dep (diff)
downloadgentoo-c011df2ba115c9b79d4e8e4e8e5a214631bfc369.tar.gz
gentoo-c011df2ba115c9b79d4e8e4e8e5a214631bfc369.tar.bz2
gentoo-c011df2ba115c9b79d4e8e4e8e5a214631bfc369.zip
media-sound/audacity: Version bump to 2.3.3
Also switch to wxGTK "3.0-gtk3" slot. Closes: https://bugs.gentoo.org/700942 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://github.com/gentoo/gentoo/pull/14517 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacity/Manifest2
-rw-r--r--media-sound/audacity/audacity-2.3.3.ebuild139
-rw-r--r--media-sound/audacity/files/audacity-2.3.3-Fix-building-against-system-portaudio.patch56
3 files changed, 197 insertions, 0 deletions
diff --git a/media-sound/audacity/Manifest b/media-sound/audacity/Manifest
index 252b82de0a30..910df0fff27f 100644
--- a/media-sound/audacity/Manifest
+++ b/media-sound/audacity/Manifest
@@ -1,4 +1,6 @@
DIST Audacity-2.3.2.tar.gz 61972597 BLAKE2B 968c3d877392af92e2a23d8357fe65c3eb608122185d037e741ed6165d1acb3af70fc15dce63140eff14cd032fb3e3dc1b8b4f7bca9016f8e0e56aaef8a27802 SHA512 a59d6e9e974d5f78f5ca561e3bea31fc1b3e88f9ea60b2df7ce8bcec264d886f3fdc8f20030e11a86daff8ffeb735850b5e5f73c45fbef0bfcc58692423e7cd0
+DIST Audacity-2.3.3.tar.gz 62073352 BLAKE2B a87f9ada8dd2ffeda86fecd194333dc53b5f1fe086c179dd904cebc912f5bff5a7d4be0c2584a6633a7dc4dadabc3ad438b45ab5fbbee573cc39ee91dfd62846 SHA512 0789d5bc27933c688b8c99e0d9d9ca65f3b0c59cf74a235feee094a1815bdb59a32a4f50d2938b8fb9d72b0c5ba88451d02f90c5163931774a2088463562c5ef
DIST audacity-manual-2.2.2.zip 13501474 BLAKE2B f0289f22dc4134b31f38d4acee3bda9f915829842030f8454cce1801377d177c32a7f35077673ce7db0a0f059a644d8146457e6a6377c5f6abc01c11da6a4f53 SHA512 a34ded796157d763fa024e0a235ecce7c67a68bcce86b487f8c022d45d8337fe550e40f56df4155a16293b974511d0bcf130cb086b3594bc0c42d9d0f84f1e86
DIST audacity-manual-2.3.2.zip 21163508 BLAKE2B 6a0ec89567db63164e897aad21af6fb31557e2519640788c781b21e885c0f704174529d9abf3e8645ccb3bca0f7b987fa708b1ce64597b282357b823e8addd44 SHA512 5e541065236badfdc2331681e43dee2564f933c33a3a588806f189acc8d8285a2c60bf9bc0c7052c6cb23fa1ee29a9f5e0428540cd556901dcf896def1c7c0ac
+DIST audacity-manual-2.3.3.zip 15135177 BLAKE2B f281fea3344513152f0841e11e5dcdfea591d7dced046028fd67954e6a34a0f7bad41cb37215d4b784d92c6ee64038918e521e1117dc0ccbc0101404d1388c84 SHA512 2612396ef61aa6e07e0ff1cc5f473dcdc34d8a166f95a9e4986bf491e8b0502c08641d9ef4c64adc19c1b22fe21514afcc5c3bed585b49e7e7c3c851fe532cd4
DIST audacity-minsrc-2.2.2.tar.xz 8210700 BLAKE2B b887cff6994f2d5315b5d22b47d460a6b7c7b7af4f212585740a7534dc1345a8b3cda701a8541fabeef1aedf30cd336466798b2da4ef62ed010152540ee02d26 SHA512 8e52b4456a3a328a9933961746722ab5c545d17f7c05f3ae4aa83ba5d4f8323590ffa070de9462163362032b372aa48bc61fc96459e5565eec29a146b7a0351c
diff --git a/media-sound/audacity/audacity-2.3.3.ebuild b/media-sound/audacity/audacity-2.3.3.ebuild
new file mode 100644
index 000000000000..ceb9bb0503ac
--- /dev/null
+++ b/media-sound/audacity/audacity-2.3.3.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+WX_GTK_VER="3.0-gtk3"
+
+inherit flag-o-matic wxwidgets xdg
+
+MY_P="Audacity-${PV}"
+DOC_PV="${PV}"
+DESCRIPTION="Free crossplatform audio editor"
+HOMEPAGE="https://web.audacityteam.org/"
+# wget doesn't seem to work on FossHub links, so we mirror
+SRC_URI="https://github.com/audacity/audacity/archive/${MY_P}.tar.gz
+ doc? ( https://dev.gentoo.org/~polynomial-c/dist/${PN}-manual-${DOC_PV}.zip )"
+S="${WORKDIR}/${PN}-${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="alsa cpu_flags_x86_sse doc ffmpeg +flac id3tag jack +ladspa +lame libav
+ +lv2 mad midi nls +portmixer sbsms +soundtouch twolame vamp +vorbis +vst"
+
+RESTRICT="test"
+
+RDEPEND="dev-libs/expat
+ >=media-libs/libsndfile-1.0.0
+ >=media-libs/portaudio-19.06.00-r2[alsa?]
+ <media-libs/portaudio-20
+ media-libs/soxr
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ alsa? ( media-libs/alsa-lib )
+ ffmpeg? (
+ libav? ( media-video/libav:= )
+ !libav? ( >=media-video/ffmpeg-1.2:= )
+ )
+ flac? ( >=media-libs/flac-1.3.1[cxx] )
+ id3tag? ( media-libs/libid3tag )
+ jack? ( virtual/jack )
+ lame? ( >=media-sound/lame-3.70 )
+ lv2? (
+ media-libs/lilv
+ media-libs/lv2
+ media-libs/suil
+ )
+ mad? ( >=media-libs/libmad-0.14.2b )
+ sbsms? ( media-libs/libsbsms )
+ soundtouch? ( >=media-libs/libsoundtouch-1.3.1 )
+ twolame? ( media-sound/twolame )
+ vamp? ( >=media-libs/vamp-plugin-sdk-2.0 )
+ vorbis? ( >=media-libs/libvorbis-1.0 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.3-Fix-building-against-system-portaudio.patch
+)
+
+src_prepare() {
+ default
+
+ use midi || sed -i \
+ -e 's:^\(#define EXPERIMENTAL_MIDI_OUT\):// \1:' \
+ src/Experimental.h || die
+}
+
+src_configure() {
+ setup-wxwidgets
+ append-cxxflags -std=gnu++14
+
+ # * always use system libraries if possible
+ # * options listed in the order that configure --help lists them
+ local myeconfargs=(
+ --disable-dynamic-loading
+ --enable-nyquist=local
+ --enable-unicode
+ --with-expat
+ --with-lib-preference=system
+ --with-libsndfile
+ --with-libsoxr
+ --with-mod-script-pipe
+ --with-mod-nyq-bench
+ --with-portaudio
+ --with-widgetextra=local
+ --with-wx-version=${WX_GTK_VER}
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable ladspa)
+ $(use_enable nls)
+ $(use_enable vst)
+ $(use_with ffmpeg)
+ $(use_with flac libflac)
+ $(use_with id3tag libid3tag)
+ $(use_with lame)
+ $(use_with lv2)
+ $(use_with mad libmad)
+ $(use_with midi portmidi local)
+ $(use_with midi "" local)
+ $(use_with portmixer)
+ $(use_with sbsms)
+ $(use_with soundtouch)
+ $(use_with twolame libtwolame)
+ $(use_with vamp libvamp)
+ $(use_with vorbis libvorbis)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Remove bad doc install
+ rm -r "${ED}"/usr/share/doc || die
+
+ # Install our docs
+ einstalldocs
+
+ if use doc ; then
+ docinto html
+ dodoc -r "${WORKDIR}"/help/manual/{m,man,manual}
+ dodoc "${WORKDIR}"/help/manual/{favicon.ico,index.html,quick_help.html}
+ dosym ../../doc/${PF}/html /usr/share/${PN}/help/manual
+ fi
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}
diff --git a/media-sound/audacity/files/audacity-2.3.3-Fix-building-against-system-portaudio.patch b/media-sound/audacity/files/audacity-2.3.3-Fix-building-against-system-portaudio.patch
new file mode 100644
index 000000000000..b44517fca80e
--- /dev/null
+++ b/media-sound/audacity/files/audacity-2.3.3-Fix-building-against-system-portaudio.patch
@@ -0,0 +1,56 @@
+From 5f9482a191359f2c477763a36d2c865c5f186602 Mon Sep 17 00:00:00 2001
+From: Antonio Ospite <ao2@ao2.it>
+Date: Tue, 7 Nov 2017 13:06:33 +0100
+Subject: [PATCH] Fix building against the system portaudio library
+
+Building against the system portaudio results in this error:
+
+./src/AudioIO.cpp:983: undefined reference to `PaUtil_GetTime'
+audacity-AudioIO.o: In function `audacityAudioCallback(void const*, void*,
+unsigned long, PaStreamCallbackTimeInfo const*, unsigned long, void*)':
+./src/AudioIO.cpp:4630: undefined reference to `PaUtil_GetTime'
+collect2: error: ld returned 1 exit status
+Makefile:2349: recipe for target 'audacity' failed
+make[3]: *** [audacity] Error 1
+
+This is because PaUtil_GetTime is declared as a C symbol in pa_util.h
+but is resolved as a C++ symbol at link time.
+
+Audacity fixes this in the local tree with this change:
+https://github.com/audacity/audacity/commit/38fd97b8e26060332ab3e9e000a8882326a70ba7
+
+However this is not general enough for the portaudio debian package.
+
+Since PaUtil_GetTime() is the only function causing problems, just copy
+over the code where it's used.
+---
+ src/AudioIO.cpp | 17 ++++++++++++++++-
+ 1 file changed, 16 insertions(+), 1 deletion(-)
+
+--- a/src/AudioIO.cpp
++++ b/src/AudioIO.cpp
+@@ -480,8 +480,23 @@
+ #define ROUND(x) (int) ((x)+0.5)
+ //#include <string.h>
+ // #include "../lib-src/portmidi/pm_common/portmidi.h"
+- #include "../lib-src/portaudio-v19/src/common/pa_util.h"
+ #include "NoteTrack.h"
++
++PaTime PaUtil_GetTime( void )
++{
++#ifdef HAVE_MACH_ABSOLUTE_TIME
++ return mach_absolute_time() * machSecondsConversionScaler_;
++#elif defined(HAVE_CLOCK_GETTIME)
++ struct timespec tp;
++ clock_gettime(CLOCK_REALTIME, &tp);
++ return (PaTime)(tp.tv_sec + tp.tv_nsec * 1e-9);
++#else
++ struct timeval tv;
++ gettimeofday( &tv, NULL );
++ return (PaTime) tv.tv_usec * 1e-6 + tv.tv_sec;
++#endif
++}
++
+ #endif
+
+ #ifdef EXPERIMENTAL_AUTOMATED_INPUT_LEVEL_ADJUSTMENT