summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-09-05 09:13:35 +0200
committerDavid Seifert <soap@gentoo.org>2017-09-05 09:13:35 +0200
commitc019d4cfa38def2e90a8c5707d73c11d532b240d (patch)
treedc92d68d0bc38f9a037877eff8734892b3f62604 /media-sound
parentmedia-sound/snd: Remove old (diff)
downloadgentoo-c019d4cfa38def2e90a8c5707d73c11d532b240d.tar.gz
gentoo-c019d4cfa38def2e90a8c5707d73c11d532b240d.tar.bz2
gentoo-c019d4cfa38def2e90a8c5707d73c11d532b240d.zip
media-sound/snd: Unconditionally compile `oss_sample_types` function
Closes: https://bugs.gentoo.org/show_bug.cgi?id=621758 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/snd/files/snd-17.4-undefined-oss_sample_types.patch21
-rw-r--r--media-sound/snd/snd-17.4.ebuild3
2 files changed, 23 insertions, 1 deletions
diff --git a/media-sound/snd/files/snd-17.4-undefined-oss_sample_types.patch b/media-sound/snd/files/snd-17.4-undefined-oss_sample_types.patch
new file mode 100644
index 000000000000..6199a7b183fd
--- /dev/null
+++ b/media-sound/snd/files/snd-17.4-undefined-oss_sample_types.patch
@@ -0,0 +1,21 @@
+Always compile the `oss_sample_types` function
+Bug: https://bugs.gentoo.org/show_bug.cgi?id=621758
+
+--- a/audio.c
++++ b/audio.c
+@@ -743,7 +743,6 @@
+ }
+
+
+-#if (!HAVE_ALSA)
+ static int oss_sample_types(int ur_dev, mus_sample_t *val)
+ {
+ int fd, samp_types = 0, sys, ind;
+@@ -774,7 +773,6 @@
+ val[0] = (mus_sample_t)(ind - 1);
+ return(MUS_NO_ERROR);
+ }
+-#endif
+
+
+
diff --git a/media-sound/snd/snd-17.4.ebuild b/media-sound/snd/snd-17.4.ebuild
index 3a2a2027b8f4..5b746a352c8a 100644
--- a/media-sound/snd/snd-17.4.ebuild
+++ b/media-sound/snd/snd-17.4.ebuild
@@ -44,7 +44,8 @@ REQUIRED_USE="
?? ( ruby s7 )"
PATCHES=(
- "${FILESDIR}/${PN}-17.4-portaudio.patch"
+ "${FILESDIR}"/${PN}-17.4-portaudio.patch
+ "${FILESDIR}"/${PN}-17.4-undefined-oss_sample_types.patch
)
pkg_setup() {