summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-12 20:23:16 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-12 21:34:45 +0100
commitc839534fce5c254d5309e56bd48db0f209773114 (patch)
tree5532a8d118b4990fbc766051389c7dc96f70db83 /media-sound
parentnet-fs/samba: Bump to version 4.3.4 (diff)
downloadgentoo-c839534fce5c254d5309e56bd48db0f209773114.tar.gz
gentoo-c839534fce5c254d5309e56bd48db0f209773114.tar.bz2
gentoo-c839534fce5c254d5309e56bd48db0f209773114.zip
media-sound/timemachine: Modernize to EAPI=6, fix #508132
Package-Manager: portage-2.2.26
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/timemachine/files/timemachine-0.3.3-underlinking.patch25
-rw-r--r--media-sound/timemachine/timemachine-0.3.3-r1.ebuild42
2 files changed, 67 insertions, 0 deletions
diff --git a/media-sound/timemachine/files/timemachine-0.3.3-underlinking.patch b/media-sound/timemachine/files/timemachine-0.3.3-underlinking.patch
new file mode 100644
index 000000000000..033484e593d0
--- /dev/null
+++ b/media-sound/timemachine/files/timemachine-0.3.3-underlinking.patch
@@ -0,0 +1,25 @@
+Fix libm underlinking.
+Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=508132
+
+--- timemachine-0.3.3/configure.ac
++++ timemachine-0.3.3/configure.ac
+@@ -1,6 +1,6 @@
+ dnl Process this file with autoconf to produce a configure script.
+
+-AC_INIT(configure.in)
++AC_INIT(configure.ac)
+ AM_INIT_AUTOMAKE(timemachine, 0.3.3)
+ AM_CONFIG_HEADER(config.h)
+ AM_MAINTAINER_MODE
+@@ -10,6 +10,11 @@
+ AM_PROG_CC_STDC
+ AC_HEADER_STDC
+
++dnl Check for libm for log10()
++AC_SEARCH_LIBS([log10], [m], [], [
++ AC_MSG_ERROR([unable to find the log10() function])
++])
++
+ PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.0.0])
+ PKG_CHECK_MODULES(JACK, [jack >= 0.80.0])
+ PKG_CHECK_MODULES(LIBLO, liblo >= 0.24, LO_FOUND="yes", LO_FOUND="no")
diff --git a/media-sound/timemachine/timemachine-0.3.3-r1.ebuild b/media-sound/timemachine/timemachine-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..189b767146a3
--- /dev/null
+++ b/media-sound/timemachine/timemachine-0.3.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="JACK client record button remembering the last 10 seconds when pressed"
+HOMEPAGE="http://plugin.org.uk/timemachine/"
+SRC_URI="http://plugin.org.uk/timemachine/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="lash"
+
+RDEPEND=">=media-sound/jack-audio-connection-kit-0.80
+ x11-libs/gtk+:2
+ >=media-libs/libsndfile-1.0.5
+ media-libs/liblo
+ lash? ( >=media-sound/lash-0.5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-underlinking.patch" )
+
+src_prepare() {
+ mv configure.{in,ac} || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable lash)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog
+}