summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-10-09 12:27:38 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-10-09 12:40:42 +0200
commitc9552fb8ed7a6fc725deb83c1092d4490710e0f7 (patch)
treeedfa61f21d548a2c1702791f9f8040c9309709e5 /media-sound
parentdev-python/pyside6-tools: add 6.5.3 (diff)
downloadgentoo-c9552fb8ed7a6fc725deb83c1092d4490710e0f7.tar.gz
gentoo-c9552fb8ed7a6fc725deb83c1092d4490710e0f7.tar.bz2
gentoo-c9552fb8ed7a6fc725deb83c1092d4490710e0f7.zip
media-sound/spotify: remove references to media-sound/spotify-tray
media-sound/spotify-tray is masked for removal because spotify now has its own tray icon and the package is no longer needed. Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/spotify/files/spotify-wrapper11
-rw-r--r--media-sound/spotify/spotify-1.2.20-r3.ebuild (renamed from media-sound/spotify/spotify-1.2.20-r2.ebuild)4
2 files changed, 1 insertions, 14 deletions
diff --git a/media-sound/spotify/files/spotify-wrapper b/media-sound/spotify/files/spotify-wrapper
index 862fa4c680d6..0d7295af5ca1 100644
--- a/media-sound/spotify/files/spotify-wrapper
+++ b/media-sound/spotify/files/spotify-wrapper
@@ -5,17 +5,6 @@ export LD_LIBRARY_PATH="/usr/$LIBDIR/apulse"
if command -v spotify-dbus.py > /dev/null; then
echo "Launching spotify with Gnome systray integration."
spotify-dbus.py "$@"
-elif [ -e "$SPOTIFY_HOME/spotify-tray" ] > /dev/null; then
- echo "Launching spotify with generic systray integration."
- minimized=
- for arg; do
- if [ "$arg" = --minimized ]; then
- minimized=$arg
- break
- fi
- done
- GDK_BACKEND="x11" "$SPOTIFY_HOME/spotify-tray" \
- --client-path="$SPOTIFY_HOME/spotify" --toggle $minimized -- "$@"
else
if pgrep -f "Spotify/[0-9].[0-9].[0-9]" > /dev/null; then
busline="org.mpris.MediaPlayer2.spotify /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.OpenUri ${1}"
diff --git a/media-sound/spotify/spotify-1.2.20-r2.ebuild b/media-sound/spotify/spotify-1.2.20-r3.ebuild
index 7d4a9417eaec..333a0fd7c799 100644
--- a/media-sound/spotify/spotify-1.2.20-r2.ebuild
+++ b/media-sound/spotify/spotify-1.2.20-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop optfeature pax-utils unpacker xdg
+inherit desktop pax-utils unpacker xdg
DESCRIPTION="Spotify is a social music platform"
HOMEPAGE="https://www.spotify.com/download/linux/"
@@ -127,6 +127,4 @@ pkg_postinst() {
ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
ewarn "To remove the cache:"
ewarn "rm -rf ~/.cache/spotify"
-
- optfeature "systray integration on non-Gnome DEs" media-sound/spotify-tray
}