summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-06-08 10:54:26 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-06-08 10:54:38 +0200
commitea299afa33bf77d4215049c720e5003df6cdd54f (patch)
treed1bea5baf274f2c7d4f39061c152ef86ce933573 /media-sound
parentapp-emulation/libguestfs: skip irrelevant Bash completion test (diff)
downloadgentoo-ea299afa33bf77d4215049c720e5003df6cdd54f.tar.gz
gentoo-ea299afa33bf77d4215049c720e5003df6cdd54f.tar.bz2
gentoo-ea299afa33bf77d4215049c720e5003df6cdd54f.zip
media-sound/awesfx: bump to 0.5.2
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/awesfx/Manifest1
-rw-r--r--media-sound/awesfx/awesfx-0.5.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/awesfx/Manifest b/media-sound/awesfx/Manifest
index 5aabbd1e7bef..cb6fcbb2074d 100644
--- a/media-sound/awesfx/Manifest
+++ b/media-sound/awesfx/Manifest
@@ -1 +1,2 @@
DIST awesfx-0.5.1e.tar.bz2 307929 BLAKE2B a3bee0750ca44ab2e732f6bdb2c119104521330226e243be1b0ab9c19e2bfd87176ad2dc039f26b9552be621a7af2ef86852e2f31f8d0b9158b093712d2447e1 SHA512 f70e631b6ab6ec6dcbde7773c1da5cba72763d2198c2ac51f4bde0fee80f057f296cabc915aed805e744f7b2323b4e2b20b6d894c79cf5682457a3fc6a9be11d
+DIST awesfx-0.5.2.tar.gz 83611 BLAKE2B 7472f478bd1b228080a669d9df47b885d9953d363a06341cc2684af1723818a8938e31622aee9dd2ca6286c59db7715224c920e79cfa318cb3347b8833f67dc6 SHA512 f59f503c54de8bcccbd8a51c1f6a7afae98bd6b5ae4ad4ec467b4f29cece569b4f8e3185adf243816f786a0c2e92fe8d098d56f02d5704979ee8290ad61f46b6
diff --git a/media-sound/awesfx/awesfx-0.5.2.ebuild b/media-sound/awesfx/awesfx-0.5.2.ebuild
new file mode 100644
index 000000000000..3912ccf215bd
--- /dev/null
+++ b/media-sound/awesfx/awesfx-0.5.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="AWE32 Sound Driver Utility Programs"
+HOMEPAGE="https://github.com/tiwai/awesfx"
+SRC_URI="https://github.com/tiwai/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="media-libs/alsa-lib"
+RDEPEND="${DEPEND}"
+
+BANK_LOC="${EPREFIX}/usr/share/sounds/sf2"
+
+DOCS=( AUTHORS ChangeLog README SBKtoSF2.txt samples/README-bank )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-sfpath=${BANK_LOC}
+}
+
+src_install() {
+ default
+
+ rm "${ED}"/usr/share/sounds/sf2/README-bank || die
+ newinitd "${FILESDIR}"/sfxload.initd sfxload
+ newconfd "${FILESDIR}"/sfxload.confd sfxload
+}
+
+pkg_postinst() {
+ elog "Copy your SoundFont files from the original CDROM"
+ elog "shipped with your soundcard to ${BANK_LOC}."
+}