summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2022-03-15 08:56:16 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2022-03-15 08:56:16 +0100
commitf600ced12252a0a544c35474c1c08b07f2e31d56 (patch)
tree16bf9ef4b817ac5bf0f0e6897cb9bac2e44cca08 /media-sound
parentdev-java/slf4j-ext: Reincarnation, bump to 1.7.36 (diff)
downloadgentoo-f600ced12252a0a544c35474c1c08b07f2e31d56.tar.gz
gentoo-f600ced12252a0a544c35474c1c08b07f2e31d56.tar.bz2
gentoo-f600ced12252a0a544c35474c1c08b07f2e31d56.zip
media-sound/mpdscribble: bump to 0.24
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mpdscribble/Manifest1
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.24.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/mpdscribble/Manifest b/media-sound/mpdscribble/Manifest
index 1cb46d9a4de0..48a093942387 100644
--- a/media-sound/mpdscribble/Manifest
+++ b/media-sound/mpdscribble/Manifest
@@ -1,2 +1,3 @@
DIST mpdscribble-0.22.tar.bz2 116981 BLAKE2B 13b15ca9e49faa3e5d254bc2864de4a0c409d8767db586def3a7bee415c67f84ddffbd7fce6093afe4aba5d5e66db8182aed52d9a141bebf4094a400f2ababe3 SHA512 bedd93392a4d5a0609dcaf7aefeeff3851f3084da8c34a4fc1f8fde51c2ba10b8370ac52cc8d55f0c9a96fffed975827a0935087c2c51880b7bfef8d79182dc8
DIST mpdscribble-0.23.tar.xz 46624 BLAKE2B 47c59a4b2936b7990bb2d8563422c553d1e08b39a09a873fae1ad0215bd1fcc0dbcaa69e62eab9332530717a200a52295018a578e3c615e83d68d84564060402 SHA512 f924076a8aa201f67ba81e72a44d3dd1c31618bd87e4f75f6b63f7b3814fa08f6ef4f7964b1d518c5f8b68a1f8ba88f867c08ed8b0387157eec8e9f97eb0b825
+DIST mpdscribble-0.24.tar.xz 69856 BLAKE2B 84143ed7f6978aff32fa759bbe90c934ba5c58df294d375921ffb1cd45de13ecd867fb832940088228fdad4c09948cd82c8dfe9b7fe77d6652743d522bfde8b7 SHA512 cca57f54f69ec1c870805cc58057e6325b6f5897370c315dcd6a64c5dd28ac07fdbddaa8b56f8c1fd88e71d27505f1a87decd68fbdff1f3fe1eaadec8ae80dae
diff --git a/media-sound/mpdscribble/mpdscribble-0.24.ebuild b/media-sound/mpdscribble/mpdscribble-0.24.ebuild
new file mode 100644
index 000000000000..9265bd6c5a2d
--- /dev/null
+++ b/media-sound/mpdscribble/mpdscribble-0.24.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="An MPD client that submits information to Audioscrobbler"
+HOMEPAGE="
+ https://www.musicpd.org/clients/mpdscribble/
+ https://github.com/MusicPlayerDaemon/mpdscribble
+"
+SRC_URI="https://www.musicpd.org/download/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/boost
+ dev-libs/libgcrypt:=
+ media-libs/libmpdclient
+ net-misc/curl
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS COPYING NEWS README.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.23-Unconditionally-generate-systemd-unit-files.patch
+ "${FILESDIR}"/${PN}-0.23-Don-t-install-AUTHORS-COPYING-NEWS-README.rst.patch
+)
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
+ keepdir /var/cache/mpdscribble
+
+ systemd_dounit "${BUILD_DIR}"/systemd/system/"${PN}".service
+ systemd_douserunit "${BUILD_DIR}"/systemd/user/"${PN}".service
+}