summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2020-02-18 19:14:58 +0100
committerJohannes Huber <johu@gentoo.org>2020-02-18 19:16:21 +0100
commitfa9a96d272ab767e4599c32e1861861b45a7ba59 (patch)
tree55ebd8067f18b73ea183d04dc758eaa2ee4e40ee /media-sound
parentapp-admin/eclean-kernel: Enable py3.8 (diff)
downloadgentoo-fa9a96d272ab767e4599c32e1861861b45a7ba59.tar.gz
gentoo-fa9a96d272ab767e4599c32e1861861b45a7ba59.tar.bz2
gentoo-fa9a96d272ab767e4599c32e1861861b45a7ba59.zip
media-sound/lollypop: Version bump 1.2.22
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-1.2.22.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index d18406ac5622..55df32845823 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1,2 +1,3 @@
DIST lollypop-1.1.4.16.tar.xz 455312 BLAKE2B 358fae45a4332c10ba59d65d09ae51f28fb7fc026e137289c47951536753796e0b7efa9f3713bccde68e6260f79b1132eb00357be8c53fba04f3c827e97851cf SHA512 08b8ec7c1fbe5f1b8f95f95677012eeb9bd83951ee320470a0da852e0a446818e48ede7de045f6d7b98dff8be139fa69d780dbf03e65904c773f8ec1493f9915
DIST lollypop-1.2.20.tar.xz 486920 BLAKE2B b4ce120935dbdd6392ff9b6ffa8acc6cceba33953d6595163cb0774adfeef9ca901f00d19101367d43d7edd3b8ebdfb15c43179de5780a0c56c825bc60ec9e72 SHA512 a5e17135a0d7ab3cc074c3fac49e76c22358d704e1b7bd5e2d554b426d9872947625c37d490f2859841b53d3c6d38e934efd8b1cf5a75b4fc76a2c5fbdf8fb82
+DIST lollypop-1.2.22.tar.xz 492964 BLAKE2B b113d5e19ec63a5535c86e2347b49c3fe4f56dabdfc4c7943ce956931580cdd92e96cb35c5c45c84d75f2d599e78c93caa195216a1a754f764254e4b73ccb531 SHA512 0161be7d6d2a10db57679c4c230ab9832ab34ce7074fc9e215a56a0dcc64fe17b3b8367c271209a75096b327dd6b793be2f54fb3904e3c98a26b1cd2aa88962b
diff --git a/media-sound/lollypop/lollypop-1.2.22.ebuild b/media-sound/lollypop/lollypop-1.2.22.ebuild
new file mode 100644
index 000000000000..0134d5693e9e
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.2.22.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite"
+inherit python-r1 gnome2-utils meson xdg-utils
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib[introspection]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection[cairo]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gnome-base/gnome-common
+ x11-libs/gtk+:3
+"
+BDEPEND="${DEPEND}
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ dev-util/intltool
+"
+RDEPEND="${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/dbus-python
+ dev-python/pillow[${PYTHON_USEDEP}]
+ >=dev-python/pylast-1.0.0[${PYTHON_USEDEP}]
+ media-libs/gst-plugins-base:1.0[introspection]
+"
+
+RESTRICT="test"
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+src_install() {
+ meson_src_install
+ python_foreach_impl python_optimize
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}