summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@ts.fujitsu.com>2017-03-12 14:26:36 +0100
committerMichał Górny <mgorny@gentoo.org>2017-07-12 07:45:53 +0200
commitad0fd3bd8b2b8de0d9980f825ad4258294d21ac5 (patch)
treef1599b79cd0e74662a066d42b14f687d141d988c /media-tv/v4l-dvb-saa716x/v4l-dvb-saa716x-0.0.1_p20170225.ebuild
parentdev-ruby/http-cookie: add ruby24 (diff)
downloadgentoo-ad0fd3bd8b2b8de0d9980f825ad4258294d21ac5.tar.gz
gentoo-ad0fd3bd8b2b8de0d9980f825ad4258294d21ac5.tar.bz2
gentoo-ad0fd3bd8b2b8de0d9980f825ad4258294d21ac5.zip
media-tv/v4l-dvb-saa716x: updated ebuild for kernel 4.6 and up, #612420
Also fix repoman issue: shorten the ebuild description Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'media-tv/v4l-dvb-saa716x/v4l-dvb-saa716x-0.0.1_p20170225.ebuild')
-rw-r--r--media-tv/v4l-dvb-saa716x/v4l-dvb-saa716x-0.0.1_p20170225.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/media-tv/v4l-dvb-saa716x/v4l-dvb-saa716x-0.0.1_p20170225.ebuild b/media-tv/v4l-dvb-saa716x/v4l-dvb-saa716x-0.0.1_p20170225.ebuild
new file mode 100644
index 000000000000..7a1ee35379db
--- /dev/null
+++ b/media-tv/v4l-dvb-saa716x/v4l-dvb-saa716x-0.0.1_p20170225.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info linux-mod
+
+DESCRIPTION="driver for saa716x based dvb cards like TT S2-6400 or Skystar 2 eXpress HD"
+HOMEPAGE="https://bitbucket.org/powARman/v4l-dvb-saa716x/overview"
+
+HG_REVISION="3b9fce66666a"
+HG_REVISION_DATE="20160322"
+
+SRC_URI="https://bitbucket.org/powARman/v4l-dvb-saa716x/get/${HG_REVISION}.tar.gz
+-> v4l-dvb-saa716x-0.0.1_p${HG_REVISION_DATE}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+firmware"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ firmware? ( sys-firmware/tt-s2-6400-firmware )"
+
+S="${WORKDIR}/powARman-v4l-dvb-saa716x-${HG_REVISION}"
+
+BUILD_TARGETS="modules"
+MODULE_NAMES="saa716x_ff(misc:${ROOT}/usr/src/linux:${S}/linux/drivers/media/common/saa716x)
+ saa716x_core(misc:${ROOT}/usr/src/linux:${S}/linux/drivers/media/common/saa716x)
+ saa716x_budget(misc:${ROOT}/usr/src/linux:${S}/linux/drivers/media/common/saa716x)
+ saa716x_hybrid(misc:${ROOT}/usr/src/linux:${S}/linux/drivers/media/common/saa716x)"
+
+CONFIG_CHECK="DVB_CORE DVB_STV6110x DVB_STV090x"
+
+src_prepare() {
+ default
+
+ eapply -p0 "${FILESDIR}/OSD_RAW_CMD_patch_2.diff"
+ eapply "${FILESDIR}/v4l-dvb-saa716x-Makefilepatch-2.diff"
+ kernel_is ge 3 19 0 && eapply "${FILESDIR}/v4l-dvb-saa716x-3.19-set_gpio.patch"
+ kernel_is ge 4 2 0 && eapply "${FILESDIR}/v4l-dvb-saa716x-4.2-fix-compile.patch"
+ kernel_is ge 4 5 2 && eapply "${FILESDIR}/v4l-dvb-saa716x-4.5.2-fix-compile.patch"
+ kernel_is ge 4 6 0 && eapply "${FILESDIR}/v4l-dvb-saa716x-4.6.0-fix-compile.patch"
+}
+
+src_compile() {
+ BUILD_PARAMS="SUBDIRS=${S}/linux/drivers/media/common/saa716x \
+ CONFIG_SAA716X_CORE=m CONFIG_DVB_SAA716X_FF=m CONFIG_DVB_SAA716X_BUDGET=m \
+ CONFIG_DVB_SAA716X_HYBRID=m"
+ addpredict "${ROOT}"/usr/src/linux/
+ linux-mod_src_compile
+}