summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott Martin <om@organizedmagnetism.com>2021-06-02 16:57:51 -0500
committerSam James <sam@gentoo.org>2021-06-02 22:45:21 +0000
commit5b84aae9c556ebe8af8343e9262fccb94c10507b (patch)
tree9eb9cd85cacc458ae02aa2467aa20b3d48455024 /media-tv
parentdev-lang/python: Stabilize 3.9.5_p2 arm, #793833 (diff)
downloadgentoo-5b84aae9c556ebe8af8343e9262fccb94c10507b.tar.gz
gentoo-5b84aae9c556ebe8af8343e9262fccb94c10507b.tar.bz2
gentoo-5b84aae9c556ebe8af8343e9262fccb94c10507b.zip
media-tv/plex-media-server version bump to 1.23.2.4625
Signed-off-by: Scott Martin <om@organizedmagnetism.com> Closes: https://github.com/gentoo/gentoo/pull/21094 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/plex-media-server/Manifest2
-rw-r--r--media-tv/plex-media-server/files/README.gentoo7
-rw-r--r--media-tv/plex-media-server/plex-media-server-1.23.2.4625.ebuild76
3 files changed, 84 insertions, 1 deletions
diff --git a/media-tv/plex-media-server/Manifest b/media-tv/plex-media-server/Manifest
index 286eb5f414f2..14a64866f0a7 100644
--- a/media-tv/plex-media-server/Manifest
+++ b/media-tv/plex-media-server/Manifest
@@ -1,2 +1,4 @@
DIST plexmediaserver_1.23.1.4602-280ab6053_amd64.deb 81613502 BLAKE2B 59f3bc54e8436bb35983cc7b77c252c88d5ccc26325203edcbaf7ef2428dbe465e0db8bb0b24472f7f7b07b25b23d23e240903243d8dcd7983edd4cda62906b3 SHA512 e269066a10794d63cf9912df3e66b92874701a8263f2806f42d0abe9484bd347284e2bacb3ba2f6825e1489be164f0b2abe6d23021737b37be918a9b356c1301
DIST plexmediaserver_1.23.1.4602-280ab6053_i386.deb 75020714 BLAKE2B 12c8057592f734969c9d4a3ea245c2b725fe16433260214c1e18d0b192151b51c61d55bde7b40015727b1775a21fe965960165b8cc6f039a138f521f95f34cb3 SHA512 afd569e0cfd665b81e422b925e623b910d29b99e77dbfe2ff2333497f63fb69adf851562c887a9bd8ff216f37b18397cad673547a41d8fdba611d9a6bd7254e2
+DIST plexmediaserver_1.23.2.4625-a83d2d0f9_amd64.deb 81773538 BLAKE2B 7b22cdd4662f37c4138bd5edc74a5471e7d31c89465ce25a428e7963fc10e5dc07c154812b51c1c17d725175f093c7e22560acde8b00ee3b5d6a724441af2729 SHA512 632497e596542fc11cd2b9ec6dd9d7403800f26473811fbd5c75d73aa1abde08b881005f1c51663afe190ce95b6d02900272f2024bbcce02f6b952efe498430d
+DIST plexmediaserver_1.23.2.4625-a83d2d0f9_i386.deb 75148422 BLAKE2B 1758529c97b3f743df44321074f95f85ce7003fd9d92e4a849776e9f24bf6034de6e90c123db9c36c8732cffbc65089f6db20fba8ffffac1b6bce238b1595b04 SHA512 0e727d96bc147d7c4457f91c8309e1937bbee49a1599ff376959fb25cdc62fa3df1ae09880cc6ada7d8dfa4cbadccce24c35ad3bd41143f086ea1a0861e010f0
diff --git a/media-tv/plex-media-server/files/README.gentoo b/media-tv/plex-media-server/files/README.gentoo
index 3ac1430ab2f7..ec4445ac397d 100644
--- a/media-tv/plex-media-server/files/README.gentoo
+++ b/media-tv/plex-media-server/files/README.gentoo
@@ -1,4 +1,9 @@
Plex Media Server is now installed. Please check the configuration file.
It can be found in /etc/plex/plexmediaserver to verify the default settings.
-To start the Plex Server, run 'rc-config start plex-media-server'
+Adjust thread counts and memory usage limits in /usr/sbin/start_pms for best
+performance. To start the Plex Server, run 'rc-config start plex-media-server'
You will then be able to access your library at http://localhost:32400/manage
+
+If installing on a remote host you will need to use a ssh tunnel eg,
+'ssh ip.address.of.server -L 8888:localhost:32400' then open the folowing in
+a local browser 'http://localhost:8888/web' to claim the remote server.
diff --git a/media-tv/plex-media-server/plex-media-server-1.23.2.4625.ebuild b/media-tv/plex-media-server/plex-media-server-1.23.2.4625.ebuild
new file mode 100644
index 000000000000..92b87a68f4e0
--- /dev/null
+++ b/media-tv/plex-media-server/plex-media-server-1.23.2.4625.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1 systemd unpacker
+
+MY_PV="${PV}-a83d2d0f9"
+MY_URI="https://downloads.plex.tv/plex-media-server-new"
+
+DESCRIPTION="Free media library that is intended for use with a plex client"
+HOMEPAGE="https://www.plex.tv/"
+SRC_URI="
+ amd64? ( ${MY_URI}/${MY_PV}/debian/plexmediaserver_${MY_PV}_amd64.deb )
+ x86? ( ${MY_URI}/${MY_PV}/debian/plexmediaserver_${MY_PV}_i386.deb )"
+S="${WORKDIR}"
+
+LICENSE="Plex"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="system-openssl"
+RESTRICT="mirror bindist"
+
+DEPEND="
+ acct-group/plex
+ acct-user/plex"
+RDEPEND="
+ ${DEPEND}
+ system-openssl? ( dev-libs/openssl:0/1.1 )"
+
+QA_PREBUILT="*"
+QA_MULTILIB_PATHS=(
+ "usr/lib/plexmediaserver/lib/.*"
+ "usr/lib/plexmediaserver/Resources/Python/lib/python2.7/.*"
+ "usr/lib/plexmediaserver/Resources/Python/lib/python2.7/lib-dynload/_hashlib.so"
+)
+
+src_install() {
+ # Remove Debian specific files
+ rm -r "usr/share/doc" || die
+
+ # Remove shipped openssl library
+ if use system-openssl; then
+ rm usr/lib/plexmediaserver/lib/libssl.so.1.1 || die
+ fi
+
+ # Add startup wrapper
+ dosbin "${FILESDIR}/start_pms"
+
+ # Copy main files over to image and preserve permissions so it is portable
+ cp -rp usr/ "${ED}" || die
+
+ # Make sure the logging directory is created
+ keepdir /var/log/pms
+ fowners plex:plex /var/log/pms
+
+ keepdir /var/lib/plexmediaserver
+ fowners plex:plex /var/lib/plexmediaserver
+
+ newinitd "${FILESDIR}/${PN}.init.d" ${PN}
+ newconfd "${FILESDIR}/${PN}.conf.d" ${PN}
+
+ systemd_dounit "${ED}"/usr/lib/plexmediaserver/lib/plexmediaserver.service
+ keepdir /var/lib/plexmediaserver
+
+ # Adds the precompiled plex libraries to the revdep-rebuild's mask list
+ # so it doesn't try to rebuild libraries that can't be rebuilt.
+ insinto /etc/revdep-rebuild
+ doins "${FILESDIR}"/80plexmediaserver
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}