summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-12 15:29:10 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-12 15:32:43 -0400
commit85e49ca2398f187b8a60295fa531a11700cd9bf8 (patch)
tree4c0e218c2bbc03687833391ac4a89d41906c7f62 /media-tv
parentmedia-gfx/darktable: improve ewarn sentence a bit, bug #589024 (diff)
downloadgentoo-85e49ca2398f187b8a60295fa531a11700cd9bf8.tar.gz
gentoo-85e49ca2398f187b8a60295fa531a11700cd9bf8.tar.bz2
gentoo-85e49ca2398f187b8a60295fa531a11700cd9bf8.zip
media-tv/dvbstream: new revision respecting LDFLAGS.
This is a new revision with an update to EAPI=6 and a little ebuild cleanup. Some missing die() statements were added, and some file copying was avoided by using the newbin/newdoc helpers. Most importantly, Michael Mair-Keimberger's fix to support LDFLAGS was incorporated. I built the package on amd64, so I've keyworded it ~amd64 as well. Gentoo-Bug: 337327 Package-Manager: portage-2.2.28
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/dvbstream/dvbstream-0.7_pre20080516-r1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/media-tv/dvbstream/dvbstream-0.7_pre20080516-r1.ebuild b/media-tv/dvbstream/dvbstream-0.7_pre20080516-r1.ebuild
new file mode 100644
index 000000000000..93eae02df694
--- /dev/null
+++ b/media-tv/dvbstream/dvbstream-0.7_pre20080516-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="RTP multicast stream server and other tools for DVB cards"
+HOMEPAGE="https://sourceforge.net/projects/dvbtools"
+MY_P="${PN}-snapshot-20080302"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl"
+DEPEND="virtual/linuxtv-dvb-headers"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-update.diff"
+ "${FILESDIR}/${PN}-0.7_pre20080302-telnet-port-switch.diff"
+)
+
+src_prepare() {
+ default
+
+ sed -i Makefile \
+ -e 's:$(CFLAGS):$(CFLAGS) $(CPPFLAGS):' \
+ -e '/CFLAGS.*=.*-g -Wall -O2/s:-g -Wall -O2::' \
+ -e '/CFLAGS.*=/s:CFLAGS:CPPFLAGS:' \
+ -e 's:-I \.\./DVB/include:-I /usr/include:' \
+ -e 's:$(CC):$(CC) $(LDFLAGS):g' \
+ || die 'failed to fix flags in the Makefile'
+
+ sed -e 's:\./svdrpsend.pl:dvbstream-send.pl:' \
+ -i TELNET/*.sh \
+ || die 'failed to rename the svdrpsend.pl command in scripts'
+
+ sed -e 's:^DUMPRTP=.*$:DUMPRTP=dumprtp:' \
+ -e 's:^TS2ES=.*$:TS2ES=ts2es:' \
+ -i *.sh \
+ || die 'failed to set DUMPRTP and TS2ES in scripts'
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin dvbstream dumprtp rtpfeed ts_filter
+ newbin TELNET/svdrpsend.pl dvbstream-send.pl
+
+ dodoc README*
+ newdoc TELNET/README README.telnet
+
+ insinto "/usr/share/doc/${PF}/tune"
+ doins TELNET/*.sh
+
+ insinto "/usr/share/doc/${PF}/multicast"
+ doins *.sh
+}