summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2021-02-09 20:56:44 +0300
committerCraig Andrews <candrews@gentoo.org>2021-02-18 09:43:25 -0500
commit8f71b1f4ec438e3d6032426a39047f58e80b43f0 (patch)
tree5c560991eafad7df870cf4055c0b8aca99e251d4 /media-tv
parentmedia-tv/kodi: added BDEPEND and fixed RDEPEND (diff)
downloadgentoo-8f71b1f4ec438e3d6032426a39047f58e80b43f0.tar.gz
gentoo-8f71b1f4ec438e3d6032426a39047f58e80b43f0.tar.bz2
gentoo-8f71b1f4ec438e3d6032426a39047f58e80b43f0.zip
media-tv/kodi: renamed USE flag for clarity
Renamed USE flag 'dvd' to 'optical' to avoid confusion, as it controls all optical disks support, including AudioCD, VideoCD, DVD-Video and others. 'optical' is enabled by default as it depends on libcdio, while libcdio dependency cannot be disabled currently by Kodi configuration. Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/kodi/kodi-9999.ebuild4
-rw-r--r--media-tv/kodi/metadata.xml2
2 files changed, 3 insertions, 3 deletions
diff --git a/media-tv/kodi/kodi-9999.ebuild b/media-tv/kodi/kodi-9999.ebuild
index 9719533e3db5..c35840d29b79 100644
--- a/media-tv/kodi/kodi-9999.ebuild
+++ b/media-tv/kodi/kodi-9999.ebuild
@@ -39,7 +39,7 @@ SLOT="0"
# use flag is called libusb so that it doesn't fool people in thinking that
# it is _required_ for USB support. Otherwise they'll disable udev and
# that's going to be worse.
-IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus dvd gbm gles lcms libressl libusb lirc mariadb mysql nfs +opengl power-control pulseaudio raspberry-pi samba +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
+IUSE="airplay alsa bluetooth bluray caps cec +css dav1d dbus gbm gles lcms libressl libusb lirc mariadb mysql nfs +opengl +optical power-control pulseaudio raspberry-pi samba +system-ffmpeg test udf udev udisks upnp upower vaapi vdpau wayland webserver +X +xslt zeroconf"
IUSE="${IUSE} cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_sse4_1 cpu_flags_x86_sse4_2 cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_arm_neon"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
@@ -282,7 +282,7 @@ src_configure() {
-DENABLE_NFS=$(usex nfs)
-DENABLE_OPENGLES=$(usex gles)
-DENABLE_OPENGL=$(usex opengl)
- -DENABLE_OPTICAL=$(usex dvd)
+ -DENABLE_OPTICAL=$(usex optical)
-DENABLE_PLIST=$(usex airplay)
-DENABLE_PULSEAUDIO=$(usex pulseaudio)
-DENABLE_SMBCLIENT=$(usex samba)
diff --git a/media-tv/kodi/metadata.xml b/media-tv/kodi/metadata.xml
index a30254b912a9..8ce883523a2b 100644
--- a/media-tv/kodi/metadata.xml
+++ b/media-tv/kodi/metadata.xml
@@ -16,7 +16,7 @@
<flag name="mariadb">Add MariaDB support</flag>
<flag name="dav1d">Enables AV1 decoding via <pkg>media-libs/dav1d</pkg></flag>
<flag name="nfs">Enable NFS client support</flag>
- <flag name="dvd">Enable optical (CD/DVD drive) support</flag>
+ <flag name="optical">Enable Audio CD playback and optical disks detection and reading</flag>
<flag name="power-control">Enable control of shutdown, reboot, suspend, and hibernate</flag>
<flag name="raspberry-pi">Enable support for the Raspberry Pi</flag>
<flag name="system-ffmpeg">Use system ffmpeg instead of the bundled one</flag>