summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:13:51 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:22 +0000
commit8fc1082ab8cfa6d4558dd08b74bf4b6d9d7aa943 (patch)
tree51871be2e6a7b7de31fa021312454803bd743a9b /media-tv
parentmedia-sound/solfege: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-8fc1082ab8cfa6d4558dd08b74bf4b6d9d7aa943.tar.gz
gentoo-8fc1082ab8cfa6d4558dd08b74bf4b6d9d7aa943.tar.bz2
gentoo-8fc1082ab8cfa6d4558dd08b74bf4b6d9d7aa943.zip
media-tv/v4l-utils: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/v4l-utils/v4l-utils-1.20.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild b/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild
index 38e272fbe767..6a579d1605e2 100644
--- a/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild
+++ b/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild
@@ -71,9 +71,9 @@ src_configure() {
if use qt5; then
append-cxxflags -std=c++11
local qt5_paths=( \
- MOC="$(pkg-config --variable=host_bins Qt5Core)/moc" \
- UIC="$(pkg-config --variable=host_bins Qt5Core)/uic" \
- RCC="$(pkg-config --variable=host_bins Qt5Core)/rcc" \
+ MOC="$($(tc-getPKG_CONFIG) --variable=host_bins Qt5Core)/moc" \
+ UIC="$($(tc-getPKG_CONFIG) --variable=host_bins Qt5Core)/uic" \
+ RCC="$($(tc-getPKG_CONFIG) --variable=host_bins Qt5Core)/rcc" \
)
if use !opengl; then
sed -e 's/Qt5OpenGL/DiSaBlEd/g' -i configure || die