summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-12-27 21:42:08 +0000
committerJames Le Cuirot <chewi@gentoo.org>2020-12-27 21:42:50 +0000
commit9a884d15380afe0a0b01a9de8c5538dc44bf8f7a (patch)
tree0f3aa4467ee476e6d3bf4637f27ced2db7971761 /media-tv
parentdev-embedded/libftdi: sync live ebuild (diff)
downloadgentoo-9a884d15380afe0a0b01a9de8c5538dc44bf8f7a.tar.gz
gentoo-9a884d15380afe0a0b01a9de8c5538dc44bf8f7a.tar.bz2
gentoo-9a884d15380afe0a0b01a9de8c5538dc44bf8f7a.zip
media-tv/v4l-utils: Ensure clang has the BPF target with pkg_pretend
The dependencies can only ensure that at least one clang on the system has the BPF target and it may not be the one that actually gets used for the build. Generally the latest version will have precedence in the PATH but this fix also checks for overrides. Bug: https://bugs.gentoo.org/692072 Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/v4l-utils/v4l-utils-1.20.0.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild b/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild
index 01f52bb05556..a7d6c2130f16 100644
--- a/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild
+++ b/media-tv/v4l-utils/v4l-utils-1.20.0.ebuild
@@ -46,6 +46,14 @@ PATCHES=(
# Not really prebuilt but BPF objects make our QA checks go crazy.
QA_PREBUILT="*/rc_keymaps/protocols/*.o"
+pkg_pretend() {
+ if use bpf; then
+ local clang=${ac_cv_prog_CLANG:-${CLANG:-clang}}
+ ${clang} -target bpf -print-supported-cpus &>/dev/null ||
+ die "${clang} does not support the BPF target. Please check LLVM_TARGETS."
+ fi
+}
+
src_prepare() {
default
eautoreconf