summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-02-11 23:09:35 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-02-11 23:09:35 +0000
commitcc7ba3931f2eb4cd30a0bfc283e41d180859422e (patch)
tree534492bdfb2dc80a88c7571d7d7f7a6e88130e83 /media-tv
parentprofiles/arch/ia64/package.use.mask: unmask media-libs/openal[sndio] (diff)
downloadgentoo-cc7ba3931f2eb4cd30a0bfc283e41d180859422e.tar.gz
gentoo-cc7ba3931f2eb4cd30a0bfc283e41d180859422e.tar.bz2
gentoo-cc7ba3931f2eb4cd30a0bfc283e41d180859422e.zip
media-tv/tvheadend: Use python-any-r1 eclass
Closes: https://bugs.gentoo.org/770112 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/tvheadend/tvheadend-4.2.8-r1.ebuild21
-rw-r--r--media-tv/tvheadend/tvheadend-9999.ebuild21
2 files changed, 30 insertions, 12 deletions
diff --git a/media-tv/tvheadend/tvheadend-4.2.8-r1.ebuild b/media-tv/tvheadend/tvheadend-4.2.8-r1.ebuild
index 17189591cf00..c0805930fb44 100644
--- a/media-tv/tvheadend/tvheadend-4.2.8-r1.ebuild
+++ b/media-tv/tvheadend/tvheadend-4.2.8-r1.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit linux-info systemd toolchain-funcs
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit linux-info python-any-r1 systemd toolchain-funcs
DESCRIPTION="Tvheadend is a TV streaming server and digital video recorder"
HOMEPAGE="https://tvheadend.org/"
@@ -16,8 +18,10 @@ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="+capmt +constcw +cwc dbus debug dvbcsa dvben50221 +dvb +ffmpeg hdhomerun +imagecache +inotify iptv libressl satip systemd +timeshift uriparser xmltv zeroconf zlib"
BDEPEND="
+ ${PYTHON_DEPS}
sys-devel/gettext
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
RDEPEND="
acct-user/tvheadend
@@ -31,15 +35,18 @@ RDEPEND="
libressl? ( dev-libs/libressl:= )
uriparser? ( dev-libs/uriparser )
zeroconf? ( net-dns/avahi )
- zlib? ( sys-libs/zlib )"
+ zlib? ( sys-libs/zlib )
+"
DEPEND="
${RDEPEND}
- dvb? ( virtual/linuxtv-dvb-headers )"
+ dvb? ( virtual/linuxtv-dvb-headers )
+"
RDEPEND+="
dvb? ( media-tv/dtv-scan-tables )
- xmltv? ( media-tv/xmltv )"
+ xmltv? ( media-tv/xmltv )
+"
REQUIRED_USE="dvbcsa? ( || ( capmt constcw cwc dvben50221 ) )"
@@ -59,6 +66,8 @@ PATCHES=(
DOCS=( README.md )
pkg_setup() {
+ python-any-r1_pkg_setup
+
use inotify &&
CONFIG_CHECK="~INOTIFY_USER" linux-info_pkg_setup
}
diff --git a/media-tv/tvheadend/tvheadend-9999.ebuild b/media-tv/tvheadend/tvheadend-9999.ebuild
index ddd46284395b..eb1fefae4619 100644
--- a/media-tv/tvheadend/tvheadend-9999.ebuild
+++ b/media-tv/tvheadend/tvheadend-9999.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 linux-info systemd toolchain-funcs
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit git-r3 linux-info python-any-r1 systemd toolchain-funcs
DESCRIPTION="Tvheadend is a TV streaming server and digital video recorder"
HOMEPAGE="https://tvheadend.org/"
@@ -16,8 +18,10 @@ KEYWORDS=""
IUSE="dbus debug +ddci dvbcsa +dvb +ffmpeg hdhomerun +imagecache +inotify iptv libressl opus satip systemd +timeshift uriparser vpx x264 x265 xmltv zeroconf zlib"
BDEPEND="
+ ${PYTHON_DEPS}
sys-devel/gettext
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
RDEPEND="
acct-user/tvheadend
@@ -30,7 +34,8 @@ RDEPEND="
libressl? ( dev-libs/libressl:= )
uriparser? ( dev-libs/uriparser )
zeroconf? ( net-dns/avahi )
- zlib? ( sys-libs/zlib )"
+ zlib? ( sys-libs/zlib )
+"
# ffmpeg sub-dependencies needed for headers only. Check under
# src/transcoding/codec/codecs/libs for include statements.
@@ -43,11 +48,13 @@ DEPEND="
vpx? ( media-libs/libvpx )
x264? ( media-libs/x264 )
x265? ( media-libs/x265 )
- )"
+ )
+"
RDEPEND+="
dvb? ( media-tv/dtv-scan-tables )
- xmltv? ( media-tv/xmltv )"
+ xmltv? ( media-tv/xmltv )
+"
REQUIRED_USE="
ddci? ( dvb )
@@ -66,6 +73,8 @@ PATCHES=(
DOCS=( README.md )
pkg_setup() {
+ python-any-r1_pkg_setup
+
use inotify &&
CONFIG_CHECK="~INOTIFY_USER" linux-info_pkg_setup
}