summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/baka-mplayer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/baka-mplayer')
-rw-r--r--media-video/baka-mplayer/Manifest2
-rw-r--r--media-video/baka-mplayer/baka-mplayer-2.0.2.ebuild39
-rw-r--r--media-video/baka-mplayer/baka-mplayer-2.0.3.ebuild39
-rw-r--r--media-video/baka-mplayer/metadata.xml6
4 files changed, 86 insertions, 0 deletions
diff --git a/media-video/baka-mplayer/Manifest b/media-video/baka-mplayer/Manifest
new file mode 100644
index 000000000000..0cd28638cf68
--- /dev/null
+++ b/media-video/baka-mplayer/Manifest
@@ -0,0 +1,2 @@
+DIST baka-mplayer-2.0.2.tar.gz 462702 SHA256 01f1cf3b369940deec5ee1ecfa1b39cac2ff7aaa17d2456976808ceea6d60a31 SHA512 3a134b60eca00ebe53223d6d2a12b7fa09902615d0a71522f2bb2bc6d818539ab93a46744de9fc554a4ee8b0918378cf28cd1f096136dffef37547d2fae67259 WHIRLPOOL dd65cd801f030895bcdc6c25301fa7813b6fb920c47af49e34d789140e16eb9dfc276d12ff6d7f27edcd2fb417fe7c638bff696317458eda084d1e01929903b1
+DIST baka-mplayer-2.0.3.tar.gz 568077 SHA256 d325d5b50d96952c1d216ffe3050bd6a009fc076fd37a4fe2d3f370658cdb5b9 SHA512 af2e79a318c8a119ef20c8721e42fa3a6c4900b5baf50613ba9de7c64cdaabbb08f0a31fc589460b544a8b67d662088cac2cdf3cc808ae128948a84882df13ab WHIRLPOOL d3f438768238787c2cf03b640641168b17e66dd570158b29076faffee25f0b0bfbe3667b6c270420bb8aef7c6325a8ba388ead67142e68f9163c9272919a439b
diff --git a/media-video/baka-mplayer/baka-mplayer-2.0.2.ebuild b/media-video/baka-mplayer/baka-mplayer-2.0.2.ebuild
new file mode 100644
index 000000000000..fbc8e1b7a56a
--- /dev/null
+++ b/media-video/baka-mplayer/baka-mplayer-2.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit qmake-utils
+
+DESCRIPTION="Cross-platform libmpv-based multimedia player with uncluttered design"
+HOMEPAGE="http://bakamplayer.u8sand.net/"
+SRC_URI="http://dev.gentoo.org/~yngwin/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-video/mpv[libmpv]
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/Baka-MPlayer-${PV}"
+
+src_prepare() {
+ # no need to install license
+ sed -e '/^INSTALLS/s:license::' -i src/Baka-MPlayer.pro || die
+ # put manual in our docdir
+ sed -e '/^manual.path/s:yer:yer-'${PV}':' -i src/Baka-MPlayer.pro || die
+}
+
+src_configure() {
+ eqmake5 INSTROOT="${D}" CONFIG+=install_translations src/Baka-MPlayer.pro
+}
diff --git a/media-video/baka-mplayer/baka-mplayer-2.0.3.ebuild b/media-video/baka-mplayer/baka-mplayer-2.0.3.ebuild
new file mode 100644
index 000000000000..ab14dbf26b34
--- /dev/null
+++ b/media-video/baka-mplayer/baka-mplayer-2.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit qmake-utils
+
+DESCRIPTION="Cross-platform libmpv-based multimedia player with uncluttered design"
+HOMEPAGE="http://bakamplayer.u8sand.net/"
+SRC_URI="https://github.com/u8sand/Baka-MPlayer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-video/mpv[libmpv]
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/Baka-MPlayer-${PV}"
+
+src_prepare() {
+ # no need to install license
+ sed -e '/^INSTALLS/s:license::' -i src/Baka-MPlayer.pro || die
+ # put manual in our docdir
+ sed -e '/^manual.path/s:yer:yer-'${PV}':' -i src/Baka-MPlayer.pro || die
+}
+
+src_configure() {
+ eqmake5 INSTROOT="${D}" CONFIG+=install_translations src/Baka-MPlayer.pro
+}
diff --git a/media-video/baka-mplayer/metadata.xml b/media-video/baka-mplayer/metadata.xml
new file mode 100644
index 000000000000..3dd50468e98c
--- /dev/null
+++ b/media-video/baka-mplayer/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <herd>video</herd>
+</pkgmetadata>