summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-05 07:02:17 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-05 07:08:49 +0100
commit76688c7c1ffd1d59c91fa5cad1995b31b48e22a1 (patch)
tree103f2d81aa7bce48b7052f6fcea601356c1f0930 /media-video/bashnapi
parentnet-fs/nfs-utils: add metadata to cross-compile patch (diff)
downloadgentoo-76688c7c1ffd1d59c91fa5cad1995b31b48e22a1.tar.gz
gentoo-76688c7c1ffd1d59c91fa5cad1995b31b48e22a1.tar.bz2
gentoo-76688c7c1ffd1d59c91fa5cad1995b31b48e22a1.zip
media-video/bashnapi: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-video/bashnapi')
-rw-r--r--media-video/bashnapi/Manifest1
-rw-r--r--media-video/bashnapi/bashnapi-2.0.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/media-video/bashnapi/Manifest b/media-video/bashnapi/Manifest
index a62bcd76beb8..01ec8af90d3e 100644
--- a/media-video/bashnapi/Manifest
+++ b/media-video/bashnapi/Manifest
@@ -1 +1,2 @@
DIST bashnapi_v1.3.5.tar.gz 98580 BLAKE2B 4a7b42f91c14c7dc24cbf14535700a778d915db0dec31206cd7bb91519f33aa4eedced56aa4efa136e3eef23f6674d1a7dafe6c63686aca4dccf076952da762d SHA512 7cf5abb009021a43261be863f320d6324b02ea25f1388c7cc99a4f695a3eb987971ada172f74d21e3a44deeec35e48c4424fa378de53749f994b6c0d0f76eec8
+DIST napi-2.0.0.tar.gz 104326 BLAKE2B f7fbea40bfbcadbefa44b31ca4689a4ce4470abf715fc7c38f2b06c911cd8a32f8dcf0ae605cdf6bb9afb00b64ae1bbb468ad02e094c3e4d272745177c5ae6e7 SHA512 fc64d8d815c2014e04115623099351226a66268c2b414fa3cee37fd73f4e6a84f41cc57e96184d9f30e72e84ba98f886be45e68b4c9d3c774c874ea40bc6c2b7
diff --git a/media-video/bashnapi/bashnapi-2.0.0.ebuild b/media-video/bashnapi/bashnapi-2.0.0.ebuild
new file mode 100644
index 000000000000..00ed00435858
--- /dev/null
+++ b/media-video/bashnapi/bashnapi-2.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_P=napi-${PV}
+DESCRIPTION="Napiprojekt.pl subtitle downloader in bash"
+HOMEPAGE="https://sourceforge.net/projects/bashnapi/"
+SRC_URI="https://download.sourceforge.net/bashnapi/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-arch/p7zip
+ net-misc/wget
+ sys-apps/debianutils
+ sys-apps/file"
+
+# tests are normally run via docker
+RESTRICT="test"
+
+pkg_postinst() {
+ # packages that can be used to detect FPS
+ local fps_pkgs=(
+ media-video/ffmpeg
+ media-video/mediainfo
+ media-video/mplayer
+ # also mplayer2
+ )
+ local p found
+
+ for p in "${fps_pkgs[@]}"; do
+ if has_version "${p}"; then
+ found=1
+ break
+ fi
+ done
+
+ if [[ ! ${found} ]]; then
+ elog "In order to support FPS detection, install one of the following packages:"
+ elog
+ for p in "${fps_pkgs[@]}"; do
+ elog " ${p}"
+ done
+ fi
+}