summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/camorama
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/camorama')
-rw-r--r--media-video/camorama/Manifest1
-rw-r--r--media-video/camorama/camorama-0.19-r2.ebuild42
-rw-r--r--media-video/camorama/files/camorama-0.19-fixes.patch107
-rw-r--r--media-video/camorama/files/camorama-0.19-gconf.patch40
-rw-r--r--media-video/camorama/files/camorama-0.19-glib-232.patch24
-rw-r--r--media-video/camorama/files/camorama-0.19-libv4l.patch198
-rw-r--r--media-video/camorama/files/camorama-0.19-no-more-videodev_h.patch14
-rw-r--r--media-video/camorama/metadata.xml8
8 files changed, 434 insertions, 0 deletions
diff --git a/media-video/camorama/Manifest b/media-video/camorama/Manifest
new file mode 100644
index 000000000000..d77774dab803
--- /dev/null
+++ b/media-video/camorama/Manifest
@@ -0,0 +1 @@
+DIST camorama-0.19.tar.bz2 277169 SHA256 948c24f96c77f550881102c2c6ca818ba00ffb7a48216ae21ae75eb55d351970 SHA512 efdbe3cdf90a4f4a39b02f141395431c24ac2a7a56ef7faa75b38ae145cdc33f3748daca6bf33a4fa21549b7fef0e7e26d135fd265906e0531e2638739492689 WHIRLPOOL 1f3cb71abac84536736c8e6a3ef141897107b3be1ca2d0ab070faa33bf7db012442e4f704a74937b730d709e56f360ced84d44a726af7e2376d1953d99e59f23
diff --git a/media-video/camorama/camorama-0.19-r2.ebuild b/media-video/camorama/camorama-0.19-r2.ebuild
new file mode 100644
index 000000000000..45d270532479
--- /dev/null
+++ b/media-video/camorama/camorama-0.19-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit eutils gnome2
+
+DESCRIPTION="A webcam application featuring various image filters"
+HOMEPAGE="http://git.gnome.org/browse/camorama/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="
+ >=gnome-base/gconf-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnome-2
+ gnome-base/libgnome-keyring
+ >=gnome-base/libgnomeui-2
+ media-libs/libv4l
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gconf.patch \
+ "${FILESDIR}"/${P}-fixes.patch \
+ "${FILESDIR}"/${P}-libv4l.patch \
+ "${FILESDIR}"/${P}-no-more-videodev_h.patch \
+ "${FILESDIR}"/${P}-glib-232.patch
+
+ gnome2_src_prepare
+}
diff --git a/media-video/camorama/files/camorama-0.19-fixes.patch b/media-video/camorama/files/camorama-0.19-fixes.patch
new file mode 100644
index 000000000000..949c19d66741
--- /dev/null
+++ b/media-video/camorama/files/camorama-0.19-fixes.patch
@@ -0,0 +1,107 @@
+http://cvs.fedoraproject.org/viewvc/rpms/camorama/devel/
+
+--- camorama-0.19/src/callbacks.c 2007-09-16 15:36:55.000000000 +0200
++++ camorama-0.19.new/src/callbacks.c 2008-06-29 22:22:44.000000000 +0200
+@@ -387,9 +387,6 @@
+ }
+ }
+
+- cam->pixmap = gdk_pixmap_new (NULL, cam->x, cam->y, cam->desk_depth);
+- gtk_widget_set_size_request (glade_xml_get_widget (cam->xml, "da"),
+- cam->x, cam->y);
+
+ /*
+ * if(cam->read == FALSE) {
+@@ -441,6 +438,11 @@
+ * * }
+ */
+ get_win_info (cam);
++
++ cam->pixmap = gdk_pixmap_new (NULL, cam->x, cam->y, cam->desk_depth);
++ gtk_widget_set_size_request (glade_xml_get_widget (cam->xml, "da"),
++ cam->x, cam->y);
++
+ frame = 0;
+ gtk_window_resize (GTK_WINDOW
+ (glade_xml_get_widget (cam->xml, "main_window")), 320,
+@@ -520,8 +522,14 @@
+ gtk_widget_show (about);
+ }
+
++void
++camorama_filter_color_filter(void* filter, guchar *image, int x, int y, int depth);
++
+ static void
+ apply_filters(cam* cam) {
++ /* v4l has reverse rgb order from what camora expect so call the color
++ filter to fix things up before running the user selected filters */
++ camorama_filter_color_filter(NULL, cam->pic_buf, cam->x, cam->y, cam->depth);
+ camorama_filter_chain_apply(cam->filter_chain, cam->pic_buf, cam->x, cam->y, cam->depth);
+ #warning "FIXME: enable the threshold channel filter"
+ // if((effect_mask & CAMORAMA_FILTER_THRESHOLD_CHANNEL) != 0)
+--- camorama-0.19/src/filter.c 2007-09-16 14:48:50.000000000 +0200
++++ camorama-0.19.new/src/filter.c 2008-06-29 22:11:42.000000000 +0200
+@@ -151,12 +151,12 @@
+ static void
+ camorama_filter_color_init(CamoramaFilterColor* self) {}
+
+-static void
++void
+ camorama_filter_color_filter(CamoramaFilterColor* filter, guchar *image, int x, int y, int depth) {
+ int i;
+ char tmp;
+ i = x * y;
+- while (--i) {
++ while (i--) {
+ tmp = image[0];
+ image[0] = image[2];
+ image[2] = tmp;
+--- camorama-0.19/src/main.c 2007-09-16 15:36:55.000000000 +0200
++++ camorama-0.19.new/src/main.c 2008-06-29 22:20:04.000000000 +0200
+@@ -224,8 +224,7 @@
+
+ /* get picture attributes */
+ get_pic_info (cam);
+-// set_pic_info(cam);
+- /* set_pic_info(cam); */
++ set_pic_info (cam);
+ cam->contrast = cam->vid_pic.contrast;
+ cam->brightness = cam->vid_pic.brightness;
+ cam->colour = cam->vid_pic.colour;
+--- camorama-0.19/src/v4l.c 2007-09-16 14:48:05.000000000 +0200
++++ camorama-0.19.new/src/v4l.c 2008-06-29 22:20:23.000000000 +0200
+@@ -158,8 +158,8 @@
+ if(cam->debug) {
+ g_message("SET PIC");
+ }
+- //cam->vid_pic.palette = VIDEO_PALETTE_RGB24;
+- //cam->vid_pic.depth = 24;
++ cam->vid_pic.palette = VIDEO_PALETTE_RGB24;
++ cam->vid_pic.depth = 24;
+ //cam->vid_pic.palette = VIDEO_PALETTE_YUV420P;
+ if(ioctl(cam->dev, VIDIOCSPICT, &cam->vid_pic) == -1) {
+ if(cam->debug) {
+@@ -232,6 +232,8 @@
+ exit(0);
+ }
+
++ cam->x = cam->vid_win.width;
++ cam->y = cam->vid_win.height;
+ }
+
+ void set_buffer(cam * cam)
+--- camorama-0.19/src/camorama-window.c~ 2007-09-16 15:36:55.000000000 +0200
++++ camorama-0.19/src/camorama-window.c 2009-06-23 20:19:16.000000000 +0200
+@@ -209,11 +209,7 @@ load_interface(cam* cam) {
+
+ logo = gtk_icon_theme_load_icon(gtk_icon_theme_get_for_screen(gtk_widget_get_screen(glade_xml_get_widget(cam->xml, "main_window"))), CAMORAMA_STOCK_WEBCAM, 24, 0, NULL);
+ gtk_window_set_default_icon(logo);
+- logo = (GdkPixbuf *) create_pixbuf (PACKAGE_DATA_DIR "/pixmaps/camorama.png");
+- if (logo == NULL) {
+- printf ("\n\nLOGO NO GO\n\n");
+- }
+-
++ logo = gtk_icon_theme_load_icon(gtk_icon_theme_get_for_screen(gtk_widget_get_screen(glade_xml_get_widget(cam->xml, "main_window"))), "camorama", 48, 0, NULL);
+ if (cam->show_adjustments == FALSE) {
+ gtk_widget_hide (glade_xml_get_widget
+ (cam->xml, "adjustments_table"));
diff --git a/media-video/camorama/files/camorama-0.19-gconf.patch b/media-video/camorama/files/camorama-0.19-gconf.patch
new file mode 100644
index 000000000000..5a1a19e9b576
--- /dev/null
+++ b/media-video/camorama/files/camorama-0.19-gconf.patch
@@ -0,0 +1,40 @@
+# Make camorama respect --disable-schemas-install configure switch
+# https://bugs.gentoo.org/show_bug.cgi?id=243274
+#
+# Makefile.am | 4 ++++
+# Makefile.in | 7 ++++---
+# 2 files changed, 8 insertions(+), 3 deletions(-)
+#
+#
+--- a/data/Makefile.am 2008-11-30 12:39:56.000000000 +0100
++++ b/data/Makefile.am 2008-11-30 12:41:33.000000000 +0100
+@@ -24,9 +24,13 @@
+ cp $(app_DATA) ~/.gnome/application-registry
+ cp $(keys_DATA) ~/.gnome/mime-info/
+
++if GCONF_SCHEMAS_INSTALL
+ install-data-local:
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA)
+ $(GCONFTOOL) --shutdown
++else
++install-data-local:
++endif
+
+ EXTRA_DIST = $(glade_DATA) $(schema_in_files) $(stuff_DATA)
+
+--- a/data/Makefile.in 2008-11-30 12:41:10.000000000 +0100
++++ b/data/Makefile.in 2008-11-30 12:42:24.000000000 +0100
+@@ -448,9 +437,10 @@
+ cp $(app_DATA) ~/.gnome/application-registry
+ cp $(keys_DATA) ~/.gnome/mime-info/
+
+-install-data-local:
+- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA)
+- $(GCONFTOOL) --shutdown
++@GCONF_SCHEMAS_INSTALL_TRUE@install-data-local:
++@GCONF_SCHEMAS_INSTALL_TRUE@ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA)
++@GCONF_SCHEMAS_INSTALL_TRUE@ $(GCONFTOOL) --shutdown
++@GCONF_SCHEMAS_INSTALL_FALSE@install-data-local:
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/media-video/camorama/files/camorama-0.19-glib-232.patch b/media-video/camorama/files/camorama-0.19-glib-232.patch
new file mode 100644
index 000000000000..d6a76b8e45c2
--- /dev/null
+++ b/media-video/camorama/files/camorama-0.19-glib-232.patch
@@ -0,0 +1,24 @@
+diff -Nu a/src/camorama-stock-items.h b/src/camorama-stock-items.h
+--- a/src/camorama-stock-items.h 2007-06-14 16:05:33.000000000 +0200
++++ b/src/camorama-stock-items.h 2012-05-02 22:40:21.000000000 +0200
+@@ -1,7 +1,7 @@
+ #ifndef CAMORAMA_STOCK_ITEMS_H
+ #define CAMORAMA_STOCK_ITEMS_H
+
+-#include <glib/gmacros.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
+diff -Nu a/src/glib-helpers.h b/src/glib-helpers.h
+--- a/src/glib-helpers.h 2007-06-14 16:05:33.000000000 +0200
++++ b/src/glib-helpers.h 2012-05-02 22:46:06.000000000 +0200
+@@ -24,7 +24,7 @@
+ #ifndef GLIB_HELPERS_H
+ #define GLIB_HELPERS_H
+
+-#include <glib/gmacros.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
diff --git a/media-video/camorama/files/camorama-0.19-libv4l.patch b/media-video/camorama/files/camorama-0.19-libv4l.patch
new file mode 100644
index 000000000000..ada58fe7dd2f
--- /dev/null
+++ b/media-video/camorama/files/camorama-0.19-libv4l.patch
@@ -0,0 +1,198 @@
+http://cvs.fedoraproject.org/viewvc/rpms/camorama/devel/
+
+--- camorama-0.19/src/Makefile.am 2007-09-16 14:48:05.000000000 +0200
++++ camorama-0.19.new/src/Makefile.am 2009-06-24 15:01:37.000000000 +0200
+@@ -36,7 +36,7 @@
+ filter.h \
+ $(BUILT_SOURCES)\
+ $(NULL)
+-camorama_LDADD = $(PACKAGE_LIBS)
++camorama_LDADD = $(PACKAGE_LIBS) -lv4l1
+
+ DISTCLEANFILES=$(BUILT_SOURCES)
+
+--- camorama-0.19/src/Makefile.in 2007-10-06 21:06:28.000000000 +0200
++++ camorama-0.19.new/src/Makefile.in 2009-06-24 15:01:50.000000000 +0200
+@@ -248,7 +248,7 @@
+ $(BUILT_SOURCES)\
+ $(NULL)
+
+-camorama_LDADD = $(PACKAGE_LIBS)
++camorama_LDADD = $(PACKAGE_LIBS) -lv4l1
+ DISTCLEANFILES = $(BUILT_SOURCES)
+ all: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) all-am
+--- camorama-0.19/src/callbacks.c 2009-06-24 15:01:55.000000000 +0200
++++ camorama-0.19.new/src/callbacks.c 2009-06-24 14:55:42.000000000 +0200
+@@ -9,6 +9,7 @@
+ #include <libgnomeui/gnome-propertybox.h>
+ #include <libgnomeui/gnome-window-icon.h>
+ #include <pthread.h>
++#include <libv4l1.h>
+
+ extern GtkWidget *main_window, *prefswindow;
+ //extern state func_state;
+@@ -390,7 +391,7 @@
+
+ /*
+ * if(cam->read == FALSE) {
+- * cam->pic = mmap(0, cam->vid_buf.size, PROT_READ | PROT_WRITE, MAP_SHARED, cam->dev, 0);
++ * cam->pic = v4l1_mmap(0, cam->vid_buf.size, PROT_READ | PROT_WRITE, MAP_SHARED, cam->dev, 0);
+ *
+ * if((unsigned char *) -1 == (unsigned char *) cam->pic) {
+ * if(cam->debug == TRUE) {
+@@ -401,7 +402,7 @@
+ * }
+ * }else{
+ * cam->pic_buf = malloc(cam->x * cam->y * cam->depth);
+- * read(cam->dev,cam->pic,(cam->x * cam->y * 3));
++ * v4l1_read(cam->dev,cam->pic,(cam->x * cam->y * 3));
+ * }
+ */
+
+@@ -427,7 +428,7 @@
+ * if(cam->read == FALSE) {
+ * * for(frame = 0; frame < cam->vid_buf.frames; frame++) {
+ * * cam->vid_map.frame = frame;
+- * * if(ioctl(cam->dev, VIDIOCMCAPTURE, &cam->vid_map) < 0) {
++ * * if(v4l1_ioctl(cam->dev, VIDIOCMCAPTURE, &cam->vid_map) < 0) {
+ * * if(cam->debug == TRUE) {
+ * * fprintf(stderr, "Unable to capture image (VIDIOCMCAPTURE) during resize.\n");
+ * * }
+@@ -547,7 +548,7 @@
+ int i, count = 0;
+ GdkGC *gc;
+
+- read (cam->dev, cam->pic, (cam->x * cam->y * 3));
++ v4l1_read (cam->dev, cam->pic, (cam->x * cam->y * 3));
+ frames2++;
+ /*
+ * update_rec.x = 0;
+@@ -588,7 +589,7 @@
+
+ i = -1;
+ while (i < 0) {
+- i = ioctl (cam->dev, VIDIOCSYNC, &frame);
++ i = v4l1_ioctl (cam->dev, VIDIOCSYNC, &frame);
+
+ if (i < 0 && errno == EINTR) {
+ if (cam->debug == TRUE) {
+@@ -630,7 +631,7 @@
+ 0, cam->x, cam->y);
+
+ cam->vid_map.frame = frame;
+- if (ioctl (cam->dev, VIDIOCMCAPTURE, &cam->vid_map) < 0) {
++ if (v4l1_ioctl (cam->dev, VIDIOCMCAPTURE, &cam->vid_map) < 0) {
+ if (cam->debug == TRUE) {
+ fprintf (stderr, "Unable to capture image (VIDIOCMCAPTURE)\n");
+ }
+@@ -677,7 +678,7 @@
+ void init_cam (GtkWidget * capture, cam * cam)
+ {
+ cam->pic =
+- mmap (0, cam->vid_buf.size, PROT_READ | PROT_WRITE,
++ v4l1_mmap (0, cam->vid_buf.size, PROT_READ | PROT_WRITE,
+ MAP_SHARED, cam->dev, 0);
+
+ if ((unsigned char *) -1 == (unsigned char *) cam->pic) {
+@@ -692,7 +693,7 @@
+ cam->vid_map.format = cam->vid_pic.palette;
+ for (frame = 0; frame < cam->vid_buf.frames; frame++) {
+ cam->vid_map.frame = frame;
+- if (ioctl (cam->dev, VIDIOCMCAPTURE, &cam->vid_map) < 0) {
++ if (v4l1_ioctl (cam->dev, VIDIOCMCAPTURE, &cam->vid_map) < 0) {
+ if (cam->debug == TRUE) {
+ fprintf (stderr,
+ "Unable to capture image (VIDIOCMCAPTURE).\n");
+--- camorama-0.19/src/main.c 2009-06-24 15:01:55.000000000 +0200
++++ camorama-0.19.new/src/main.c 2009-06-24 14:59:35.000000000 +0200
+@@ -9,6 +9,7 @@
+ #include <gdk-pixbuf-xlib/gdk-pixbuf-xlib.h>
+ #include <gdk-pixbuf-xlib/gdk-pixbuf-xlibrgb.h>
+ #include <locale.h>
++#include <libv4l1.h>
+
+ #include "camorama-display.h"
+ #include "camorama-stock-items.h"
+@@ -206,7 +207,7 @@
+ gdk_pixbuf_xlib_init (display, 0);
+ cam->desk_depth = xlib_rgb_get_depth ();
+
+- cam->dev = open (cam->video_dev, O_RDWR);
++ cam->dev = v4l1_open (cam->video_dev, O_RDWR);
+
+ camera_cap (cam);
+ get_win_info (cam);
+@@ -284,5 +285,8 @@
+
+ gtk_timeout_add (2000, (GSourceFunc) fps, cam->status);
+ gtk_main ();
++ v4l1_munmap(cam->pic, cam->vid_buf.size);
++ v4l1_close(cam->dev);
++
+ return 0;
+ }
+--- camorama-0.19/src/v4l.c 2009-06-24 15:01:55.000000000 +0200
++++ camorama-0.19.new/src/v4l.c 2009-06-24 14:54:09.000000000 +0200
+@@ -2,6 +2,7 @@
+ #include<time.h>
+ #include<errno.h>
+ #include<gnome.h>
++#include <libv4l1.h>
+ #include "support.h"
+
+ extern int frame_number;
+@@ -87,7 +88,7 @@
+ void camera_cap(cam * cam)
+ {
+ char *msg;
+- if(ioctl(cam->dev, VIDIOCGCAP, &cam->vid_cap) == -1) {
++ if(v4l1_ioctl(cam->dev, VIDIOCGCAP, &cam->vid_cap) == -1) {
+ if(cam->debug == TRUE) {
+ fprintf(stderr, "VIDIOCGCAP -- could not get camera capabilities, exiting.....\n");
+ }
+@@ -161,7 +162,7 @@
+ cam->vid_pic.palette = VIDEO_PALETTE_RGB24;
+ cam->vid_pic.depth = 24;
+ //cam->vid_pic.palette = VIDEO_PALETTE_YUV420P;
+- if(ioctl(cam->dev, VIDIOCSPICT, &cam->vid_pic) == -1) {
++ if(v4l1_ioctl(cam->dev, VIDIOCSPICT, &cam->vid_pic) == -1) {
+ if(cam->debug) {
+ g_message("VIDIOCSPICT -- could not set picture info, exiting....");
+ }
+@@ -176,7 +177,7 @@
+ //set_pic_info(cam);
+ char *msg;
+
+- if(ioctl(cam->dev, VIDIOCGPICT, &cam->vid_pic) == -1) {
++ if(v4l1_ioctl(cam->dev, VIDIOCGPICT, &cam->vid_pic) == -1) {
+ msg = g_strdup_printf(_("Could not connect to video device (%s).\nPlease check connection."), cam->video_dev);
+ error_dialog(msg);
+ if(cam->debug == TRUE) {
+@@ -201,7 +202,7 @@
+ void get_win_info(cam * cam)
+ {
+ gchar *msg;
+- if(ioctl(cam->dev, VIDIOCGWIN, &cam->vid_win) == -1) {
++ if(v4l1_ioctl(cam->dev, VIDIOCGWIN, &cam->vid_win) == -1) {
+ msg = g_strdup_printf(_("Could not connect to video device (%s).\nPlease check connection."), cam->video_dev);
+ error_dialog(msg);
+ if(cam->debug == TRUE) {
+@@ -222,7 +223,7 @@
+ void set_win_info(cam * cam)
+ {
+ gchar *msg;
+- if(ioctl(cam->dev, VIDIOCSWIN, &cam->vid_win) == -1) {
++ if(v4l1_ioctl(cam->dev, VIDIOCSWIN, &cam->vid_win) == -1) {
+ msg = g_strdup_printf(_("Could not connect to video device (%s).\nPlease check connection."), cam->video_dev);
+ error_dialog(msg);
+ if(cam->debug == TRUE) {
+@@ -239,7 +240,7 @@
+ void set_buffer(cam * cam)
+ {
+ char *msg;
+- if(ioctl(cam->dev, VIDIOCGMBUF, &cam->vid_buf) == -1) {
++ if(v4l1_ioctl(cam->dev, VIDIOCGMBUF, &cam->vid_buf) == -1) {
+ msg = g_strdup_printf(_("Could not connect to video device (%s).\nPlease check connection."), cam->video_dev);
+ error_dialog(msg);
+ if(cam->debug == TRUE) {
diff --git a/media-video/camorama/files/camorama-0.19-no-more-videodev_h.patch b/media-video/camorama/files/camorama-0.19-no-more-videodev_h.patch
new file mode 100644
index 000000000000..84c8f68ba72b
--- /dev/null
+++ b/media-video/camorama/files/camorama-0.19-no-more-videodev_h.patch
@@ -0,0 +1,14 @@
+http://pkgs.fedoraproject.org/gitweb/?p=camorama.git;a=blob_plain;f=camorama-0.19-no-more-videodev_h.patch;hb=HEAD
+
+--- src/v4l.h
++++ src/v4l.h
+@@ -12,8 +12,7 @@
+ #include <sys/mman.h>
+ #include <fcntl.h>
+ #include <gtk/gtk.h>
+-#include <linux/types.h>
+-#include <linux/videodev.h>
++#include <libv4l1.h>
+ #include <signal.h>
+ #include <png.h>
+ #include <glade/glade.h>
diff --git a/media-video/camorama/metadata.xml b/media-video/camorama/metadata.xml
new file mode 100644
index 000000000000..2c5e04917119
--- /dev/null
+++ b/media-video/camorama/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+<maintainer>
+ <email>media-video@gentoo.org</email>
+</maintainer>
+</pkgmetadata>