summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/ccextractor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/ccextractor')
-rw-r--r--media-video/ccextractor/Manifest3
-rw-r--r--media-video/ccextractor/ccextractor-0.59.ebuild30
-rw-r--r--media-video/ccextractor/ccextractor-0.68.ebuild37
-rw-r--r--media-video/ccextractor/ccextractor-0.69.ebuild36
-rw-r--r--media-video/ccextractor/files/ccextractor-0.68-libpng.patch11
-rw-r--r--media-video/ccextractor/metadata.xml11
6 files changed, 128 insertions, 0 deletions
diff --git a/media-video/ccextractor/Manifest b/media-video/ccextractor/Manifest
new file mode 100644
index 000000000000..02e77b93c0a8
--- /dev/null
+++ b/media-video/ccextractor/Manifest
@@ -0,0 +1,3 @@
+DIST ccextractor-0.59-src.zip 168198 SHA256 13ca427527661e99f156c72ebd09b5bb4eb735904a83c2b3eb3f8aec66425ecb
+DIST ccextractor.src.0.68.zip 927590 SHA256 b4d711b88995bbf4e22b70076b802b162fcaca3eff95263e01ed502edc7dbd00 SHA512 c73eb007db7058cf17a818cd5bdf20dfb6f6f3585f55d9f7f1b894aaedcc6b74ac0c2b34b517b44491cdefe2fe7b1fc0035802326b61f7f6330acdb854b8c2ad WHIRLPOOL 4d6b245212f37d79076fc6afe6bdd4bc754c6ffb5c94559aea1f1428270de395daf7720e8cf7d346681975cb68d8357ef2aaed326a59d9a37eea7d7ddc157f3b
+DIST ccextractor.src.0.69.zip 940531 SHA256 bfb6d1174e7a440a624f39ade3c9b9ccbdebb9111ec308578d68aba89a8ec50a SHA512 51c3218a9a8e88aa86acfdd0cbd51bc52a734bde77dbea32c7e2a0f63835b25e0e86ea4b228564e5e996a5a19c74d5513d057bf510c324280f0c155a96b77775 WHIRLPOOL f27c377ab7f535900f858f138867cc8d12b76b05bc2eabbd0309c4ffcd7cd19865f419d4f0fe2b8bd1b480a6594f4a8a0104212fba6923da126b56ed31425c96
diff --git a/media-video/ccextractor/ccextractor-0.59.ebuild b/media-video/ccextractor/ccextractor-0.59.ebuild
new file mode 100644
index 000000000000..bc594baafecc
--- /dev/null
+++ b/media-video/ccextractor/ccextractor-0.59.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Extract closed captioning subtitles from video to SRT"
+HOMEPAGE="http://ccextractor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ccextractor/${P}-src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ cd src
+ $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} -D_FILE_OFFSET_BITS=64 -o ccextractor *.cpp || die
+}
+
+src_install() {
+ dobin src/ccextractor
+ dodoc docs/*.TXT
+}
diff --git a/media-video/ccextractor/ccextractor-0.68.ebuild b/media-video/ccextractor/ccextractor-0.68.ebuild
new file mode 100644
index 000000000000..c5abf7af2885
--- /dev/null
+++ b/media-video/ccextractor/ccextractor-0.68.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Extract closed captioning subtitles from video to SRT"
+HOMEPAGE="http://ccextractor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ccextractor/${PN}.src.${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ media-libs/libpng
+ sys-libs/zlib"
+
+S="${WORKDIR}/${PN}.${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-libpng.patch" || die
+ rm -r src/libpng src/zlib || die
+}
+
+src_compile() {
+ cd src
+ $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} -DHAVE_LIBPNG -DGPAC_CONFIG_LINUX -D_FILE_OFFSET_BITS=64 -Igpacmp4/ -o ccextractor $(find . -name '*.cpp') $(find . -name '*.c') -lpng || die
+}
+
+src_install() {
+ dobin src/ccextractor
+ dodoc docs/*.TXT
+}
diff --git a/media-video/ccextractor/ccextractor-0.69.ebuild b/media-video/ccextractor/ccextractor-0.69.ebuild
new file mode 100644
index 000000000000..26e2145ebb9c
--- /dev/null
+++ b/media-video/ccextractor/ccextractor-0.69.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Extract closed captioning subtitles from video to SRT"
+HOMEPAGE="http://ccextractor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ccextractor/${PN}.src.${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ media-libs/libpng
+ sys-libs/zlib"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ rm -r src/libpng src/zlib || die
+}
+
+src_compile() {
+ cd src
+ $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} -DHAVE_LIBPNG -DGPAC_CONFIG_LINUX -D_FILE_OFFSET_BITS=64 -Igpacmp4/ -o ccextractor $(find . -name '*.cpp') $(find . -name '*.c') -lpng || die
+}
+
+src_install() {
+ dobin src/ccextractor
+ dodoc docs/*.TXT
+}
diff --git a/media-video/ccextractor/files/ccextractor-0.68-libpng.patch b/media-video/ccextractor/files/ccextractor-0.68-libpng.patch
new file mode 100644
index 000000000000..518d434df369
--- /dev/null
+++ b/media-video/ccextractor/files/ccextractor-0.68-libpng.patch
@@ -0,0 +1,11 @@
+--- src/608_spupng.cpp.orig 2014-03-19 10:32:47.578960867 -0600
++++ src/608_spupng.cpp 2014-03-19 10:33:00.692179157 -0600
+@@ -490,7 +490,7 @@
+ {
+ unsigned int i;
+
+- if (setjmp (png_ptr->jmpbuf))
++ if (setjmp(png_jmpbuf(png_ptr)))
+ return 0;
+
+ png_init_io (png_ptr, fppng); \ No newline at end of file
diff --git a/media-video/ccextractor/metadata.xml b/media-video/ccextractor/metadata.xml
new file mode 100644
index 000000000000..76d8e402b9f1
--- /dev/null
+++ b/media-video/ccextractor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <longdescription lang="en">
+A tool that analyzes video files and produces independent subtitle files from the closed captions data. Exports to SRT subtitle format.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ccextractor</remote-id>
+ </upstream>
+</pkgmetadata>