summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/dvd-slideshow
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/dvd-slideshow')
-rw-r--r--media-video/dvd-slideshow/Manifest3
-rw-r--r--media-video/dvd-slideshow/dvd-slideshow-0.8.4.2.ebuild56
-rw-r--r--media-video/dvd-slideshow/metadata.xml14
3 files changed, 73 insertions, 0 deletions
diff --git a/media-video/dvd-slideshow/Manifest b/media-video/dvd-slideshow/Manifest
new file mode 100644
index 000000000000..c6dc96b75849
--- /dev/null
+++ b/media-video/dvd-slideshow/Manifest
@@ -0,0 +1,3 @@
+DIST dvd-slideshow-0.8.4-2.tar.gz 162905 SHA256 0587cbe4b39b415aec232ada3213b4352c3b9eecec82a64594f1deb8b14a809d
+DIST dvd-slideshow-examples-0.8.4-1.tar.gz 1565431 SHA256 2bb1c227136783c9eb7a43ee7fad4b8b0871e70a4269ed5b7604b13ff88ebed7
+DIST dvd-slideshow-themes-0.8.4-1.tar.gz 1225865 SHA256 3a929836c9a4afbb3b134718ea548d0f562f48c52d0026ff7bc1b99bebc4d5a1
diff --git a/media-video/dvd-slideshow/dvd-slideshow-0.8.4.2.ebuild b/media-video/dvd-slideshow/dvd-slideshow-0.8.4.2.ebuild
new file mode 100644
index 000000000000..6e1c98bf4b70
--- /dev/null
+++ b/media-video/dvd-slideshow/dvd-slideshow-0.8.4.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit versionator
+
+MY_P=${PN}-$(replace_version_separator 3 '-')
+
+DESCRIPTION="DVD Slideshow - Turn your pictures into a dvd with menus!"
+HOMEPAGE="http://dvd-slideshow.sourceforge.net/wiki/Main_Page"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
+ examples? ( mirror://sourceforge/${PN}/${PN}-examples-0.8.4-1.tar.gz )
+ themes? ( mirror://sourceforge/${PN}/${PN}-themes-0.8.4-1.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples mp3 themes vorbis"
+
+RDEPEND="media-sound/sox
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ media-video/mjpegtools
+ >media-video/dvdauthor-0.6.11
+ virtual/cdrtools
+ virtual/ffmpeg
+ app-cdr/dvd+rw-tools
+ mp3? ( media-sound/lame )
+ vorbis? ( media-libs/libvorbis )
+ sys-devel/bc
+ media-gfx/jhead"
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dobin dir2slideshow dvd-menu dvd-slideshow gallery1-to-slideshow \
+ jigl2slideshow
+
+ dodoc doc/changelog.txt dvd-slideshowrc TODO.txt
+ dohtml doc/*.html
+ doman man/*.1
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${WORKDIR}"/dvd-slideshow-examples-0.8.4-1/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ if use themes; then
+ rm "${WORKDIR}"/dvd-slideshow-themes-0.8.4-1/themes.readme.txt
+ insinto /usr/share/themes/${PF}
+ doins -r "${WORKDIR}"/dvd-slideshow-themes-0.8.4-1/*
+ fi
+}
diff --git a/media-video/dvd-slideshow/metadata.xml b/media-video/dvd-slideshow/metadata.xml
new file mode 100644
index 000000000000..1b05378ec9bd
--- /dev/null
+++ b/media-video/dvd-slideshow/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="themes">Install theme pack</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">dvd-slideshow</remote-id>
+ </upstream>
+</pkgmetadata>