summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-11 20:21:53 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-11 20:45:13 +0100
commit8a45c7ec2a83b2cee1d048b7cdb12a79d1fd5ef4 (patch)
treea2bc2064fa256abbad08503260bc5adc57b5538f /media-video/dvdauthor/dvdauthor-0.7.1-r1.ebuild
parentmedia-video/chaplin: Depend on virtual/imagemagick-tools (diff)
downloadgentoo-8a45c7ec2a83b2cee1d048b7cdb12a79d1fd5ef4.tar.gz
gentoo-8a45c7ec2a83b2cee1d048b7cdb12a79d1fd5ef4.tar.bz2
gentoo-8a45c7ec2a83b2cee1d048b7cdb12a79d1fd5ef4.zip
media-video/dvdauthor: Depend on virtual/imagemagick-tools
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3907
Diffstat (limited to 'media-video/dvdauthor/dvdauthor-0.7.1-r1.ebuild')
-rw-r--r--media-video/dvdauthor/dvdauthor-0.7.1-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-video/dvdauthor/dvdauthor-0.7.1-r1.ebuild b/media-video/dvdauthor/dvdauthor-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..940cdaaed8a6
--- /dev/null
+++ b/media-video/dvdauthor/dvdauthor-0.7.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tools for generating DVD files to be played on standalone DVD players"
+HOMEPAGE="http://dvdauthor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="graphicsmagick +imagemagick"
+REQUIRED_USE="^^ ( graphicsmagick imagemagick )"
+
+RDEPEND=">=dev-libs/fribidi-0.19.2
+ dev-libs/libxml2
+ >=media-libs/freetype-2
+ media-libs/libdvdread
+ media-libs/libpng:0=
+ graphicsmagick? ( media-gfx/graphicsmagick:= )
+ imagemagick? ( media-gfx/imagemagick:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( AUTHORS ChangeLog README TODO )
+
+PATCHES=(
+ "${FILESDIR}/${P}-glibc220.patch"
+)
+
+src_prepare() {
+ default
+ if use graphicsmagick ; then
+ sed -i -e 's:ExportImagePixels:dIsAbLeAuToMaGiC&:' configure \
+ || die
+ fi
+}
+
+src_configure() {
+ use graphicsmagick && \
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags GraphicsMagick)" #459976
+ append-cppflags "$($(tc-getPKG_CONFIG) --cflags fribidi)" #417041
+ econf
+}