summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-06-17 19:34:36 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-17 19:34:57 +0200
commit202e177b4796ebc90b6392e24178812dfd7cfe7c (patch)
treeff8710f8918ce73e6664073382e9dd1b2ad18d46 /media-video/ffmpeg
parentmedia-video/ffmpeg: set symbol/object thingy (diff)
downloadgentoo-202e177b4796ebc90b6392e24178812dfd7cfe7c.tar.gz
gentoo-202e177b4796ebc90b6392e24178812dfd7cfe7c.tar.bz2
gentoo-202e177b4796ebc90b6392e24178812dfd7cfe7c.zip
media-video/ffmpeg: fix building without SSSE3
Closes: https://bugs.gentoo.org/728566 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-video/ffmpeg')
-rw-r--r--media-video/ffmpeg/ffmpeg-4.3.ebuild1
-rw-r--r--media-video/ffmpeg/files/ffmpeg-4.3-fix-build-without-SSSE3.patch22
2 files changed, 23 insertions, 0 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.3.ebuild b/media-video/ffmpeg/ffmpeg-4.3.ebuild
index 3536d79ae995..6a6b7f4fb6cd 100644
--- a/media-video/ffmpeg/ffmpeg-4.3.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.3.ebuild
@@ -325,6 +325,7 @@ S=${WORKDIR}/${P/_/-}
PATCHES=(
"${FILESDIR}"/chromium-r1.patch
+ "${FILESDIR}"/${PN}-4.3-fix-build-without-SSSE3.patch
)
MULTILIB_WRAPPED_HEADERS=(
diff --git a/media-video/ffmpeg/files/ffmpeg-4.3-fix-build-without-SSSE3.patch b/media-video/ffmpeg/files/ffmpeg-4.3-fix-build-without-SSSE3.patch
new file mode 100644
index 000000000000..c3e6733160f6
--- /dev/null
+++ b/media-video/ffmpeg/files/ffmpeg-4.3-fix-build-without-SSSE3.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/728566
+http://ffmpeg.org/pipermail/ffmpeg-devel/2020-February/257474.html
+
+--- a/libswscale/x86/yuv2rgb.c
++++ b/libswscale/x86/yuv2rgb.c
+@@ -83,6 +83,7 @@ av_cold SwsFunc ff_yuv2rgb_init_x86(SwsContext *c)
+ #if HAVE_X86ASM
+ int cpu_flags = av_get_cpu_flags();
+
++#if HAVE_SSSE3
+ if (EXTERNAL_SSSE3(cpu_flags)) {
+ switch (c->dstFormat) {
+ case AV_PIX_FMT_RGB32:
+@@ -111,6 +112,7 @@ av_cold SwsFunc ff_yuv2rgb_init_x86(SwsContext *c)
+ return yuv420_rgb15_ssse3;
+ }
+ }
++#endif
+
+ if (EXTERNAL_MMXEXT(cpu_flags)) {
+ switch (c->dstFormat) {
+