summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-08-20 14:46:11 +0200
committerJeroen Roovers <jer@gentoo.org>2016-08-20 14:46:55 +0200
commitd8743c624137dc9ca657152eeefd676f751ab52b (patch)
tree026a2fd219311a3eb74dc125a51d66a5a7749f04 /media-video/frameworks
parentnet-misc/aria2: Bump to 1.26.0 (diff)
downloadgentoo-d8743c624137dc9ca657152eeefd676f751ab52b.tar.gz
gentoo-d8743c624137dc9ca657152eeefd676f751ab52b.tar.bz2
gentoo-d8743c624137dc9ca657152eeefd676f751ab52b.zip
media-video/frameworks: Fix linking issue (bug #516280). Fix glade file location. Fix compiler warning.
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-video/frameworks')
-rw-r--r--media-video/frameworks/files/frameworks-0.3.7-ceilf.patch10
-rw-r--r--media-video/frameworks/files/frameworks-0.3.7-strcmp-and-datadir.patch24
-rw-r--r--media-video/frameworks/frameworks-0.3.7-r1.ebuild37
3 files changed, 71 insertions, 0 deletions
diff --git a/media-video/frameworks/files/frameworks-0.3.7-ceilf.patch b/media-video/frameworks/files/frameworks-0.3.7-ceilf.patch
new file mode 100644
index 000000000000..6ccc271b5abf
--- /dev/null
+++ b/media-video/frameworks/files/frameworks-0.3.7-ceilf.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -12,6 +12,7 @@
+ AC_PROG_INSTALL
+
+ # Checks for libraries
++AC_SEARCH_LIBS(ceil, m)
+ pkg_modules="gtk+-2.0 gthread-2.0 libglade-2.0"
+ PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
+ AC_SUBST(PACKAGE_CFLAGS)
diff --git a/media-video/frameworks/files/frameworks-0.3.7-strcmp-and-datadir.patch b/media-video/frameworks/files/frameworks-0.3.7-strcmp-and-datadir.patch
new file mode 100644
index 000000000000..1550a211bda8
--- /dev/null
+++ b/media-video/frameworks/files/frameworks-0.3.7-strcmp-and-datadir.patch
@@ -0,0 +1,24 @@
+--- a/src/interface.c
++++ b/src/interface.c
+@@ -258,8 +258,8 @@
+
+ /* find our glade interface file */
+ datadir = g_string_new(DATADIR);
+- if (datadir->str != "" || datadir->str != NULL)
+- datadir = g_string_append(datadir, "/");
++ if (strcmp(datadir->str, "") || datadir->str != NULL)
++ datadir = g_string_append(datadir, "/frameworks/");
+ filename = g_string_new("frameworks.glade");
+
+ if (g_file_test(filename->str, G_FILE_TEST_EXISTS) == TRUE) {
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -8,7 +8,7 @@
+ EXTRA_DIST = template.glade template.gladep
+
+ bin_PROGRAMS = frameworks
+-data_DATA = frameworks.glade
++pkgdata_DATA = frameworks.glade
+
+ frameworks_SOURCES = frameworks.c frameworks.h common.h videodev.h \
+ camera.c camera.h interface.c interface.h callbacks.c callbacks.h \
diff --git a/media-video/frameworks/frameworks-0.3.7-r1.ebuild b/media-video/frameworks/frameworks-0.3.7-r1.ebuild
new file mode 100644
index 000000000000..f113a25c6d7b
--- /dev/null
+++ b/media-video/frameworks/frameworks-0.3.7-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="A small v4l frame capture utility especially suited for stop motion animation"
+SRC_URI="http://frameworks.polycrystal.org/release/${P}.tar.gz"
+HOMEPAGE="http://frameworks.polycrystal.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~x86 ~amd64"
+
+RDEPEND="
+ >=gnome-base/libglade-2
+ x11-libs/gtk+:2
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=(
+ AUTHORS ChangeLog NEWS README TODO
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.7-ceilf.patch
+ "${FILESDIR}"/${PN}-0.3.7-strcmp-and-datadir.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}