summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/gnome-mplayer/gnome-mplayer-1.0.9.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/gnome-mplayer/gnome-mplayer-1.0.9.ebuild')
-rw-r--r--media-video/gnome-mplayer/gnome-mplayer-1.0.9.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/media-video/gnome-mplayer/gnome-mplayer-1.0.9.ebuild b/media-video/gnome-mplayer/gnome-mplayer-1.0.9.ebuild
new file mode 100644
index 000000000000..7efca1c3c6fb
--- /dev/null
+++ b/media-video/gnome-mplayer/gnome-mplayer-1.0.9.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit fdo-mime gnome2-utils
+
+DESCRIPTION="A GTK+ interface to MPlayer"
+HOMEPAGE="http://code.google.com/p/gnome-mplayer/"
+SRC_URI="http://${PN}.googlecode.com/svn/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ~ppc64 x86 ~x86-fbsd"
+IUSE="alsa +dbus +dconf gda gnome ipod libnotify musicbrainz pulseaudio"
+
+COMMON_DEPEND=">=dev-libs/glib-2.30
+ >=media-libs/gmtk-${PV}[dconf=]
+ >=x11-libs/gtk+-3.2:3
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( >=dev-libs/dbus-glib-0.100 )
+ gda? ( gnome-extra/libgda:5 )
+ gnome? ( gnome-base/nautilus )
+ ipod? ( >=media-libs/libgpod-0.7 )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ musicbrainz? (
+ media-libs/musicbrainz:3
+ net-misc/curl
+ )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.14 )"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gnome-icon-theme-symbolic
+ || ( >=media-video/mplayer-1.0_rc4_p20100101[libass] media-video/mplayer2[libass] )"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="ChangeLog README DOCS/*.txt DOCS/tech/*.txt"
+
+src_configure() {
+ # TODO: temporarily --disable-nemo only because it's untested and new feature in 1.0.9
+ econf \
+ --enable-gtk3 \
+ $(use_enable gnome nautilus) \
+ --disable-nemo \
+ --with-gio \
+ $(use_with dbus) \
+ $(use_with gda libgda) \
+ $(use_with alsa) \
+ $(use_with pulseaudio) \
+ $(use_with libnotify) \
+ $(use_with ipod libgpod) \
+ $(use_with musicbrainz libmusicbrainz3)
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/share/doc/${PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}