summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/kdenlive
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/kdenlive')
-rw-r--r--media-video/kdenlive/Manifest2
-rw-r--r--media-video/kdenlive/kdenlive-0.9.10.ebuild40
-rw-r--r--media-video/kdenlive/kdenlive-0.9.8.ebuild40
-rw-r--r--media-video/kdenlive/metadata.xml12
4 files changed, 94 insertions, 0 deletions
diff --git a/media-video/kdenlive/Manifest b/media-video/kdenlive/Manifest
new file mode 100644
index 000000000000..e449e660f107
--- /dev/null
+++ b/media-video/kdenlive/Manifest
@@ -0,0 +1,2 @@
+DIST kdenlive-0.9.10.tar.bz2 4666332 SHA256 f68fdb39173e69ce422fdd57bbc4ced47711317e538b0101eee6a1bc9cedb763 SHA512 47314e4a095a74fb6e0d9aec8450d857a3624c0127372c88c94a73ae504f565b77c8197970dc61f9a2478664069e6bf822495b50c92491a4aae5d43c9afc4e2a WHIRLPOOL fd6c2b23ad2d2dc157decaaa4df072366617bcd9e37cbaa03633a6279695d033c3e2365c82b7f0cf0e064978177052cd5b74481bc51ce1842abaf39bca776063
+DIST kdenlive-0.9.8.tar.bz2 3342895 SHA256 870d68a19ac6012e09d3eedfd9b63983a79b5bcc9eabd465720466ed3fcd4128 SHA512 910405e0d1c03d4547cdd3bb2d36da0eeed5b20615c39ccd5740807bbf5e5cfcfa5474341db256812b619e2342827c3e997f15dddfef36bc8637ce0113b7ae0b WHIRLPOOL 3330a0c9b4769411f6bdd03ca2b2405aa348eb13d72d033d77d8685b93f6df6297c9e6a5772c9105488c07b9a56d75261ee42113c522ce46f3c9f1179d4784e1
diff --git a/media-video/kdenlive/kdenlive-0.9.10.ebuild b/media-video/kdenlive/kdenlive-0.9.10.ebuild
new file mode 100644
index 000000000000..3bc619b027e0
--- /dev/null
+++ b/media-video/kdenlive/kdenlive-0.9.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KDE_MINIMAL="4.13.1"
+OPENGL_REQUIRED="always"
+inherit kde4-base
+
+DESCRIPTION="A non-linear video editing suite for KDE"
+HOMEPAGE="http://www.kdenlive.org/"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux"
+IUSE="debug nepomuk v4l"
+
+RDEPEND="
+ dev-libs/qjson
+ $(add_kdebase_dep kdelibs 'nepomuk?')
+ >=media-libs/mlt-0.9.0[ffmpeg,sdl,xml,melt,qt4,kdenlive]
+ virtual/ffmpeg[encode,sdl,X]
+ v4l? ( media-libs/libv4l )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+DOCS=(AUTHORS ChangeLog README)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with nepomuk)
+ $(cmake-utils_use_with v4l LibV4L2)
+ )
+ kde4-base_src_configure
+}
diff --git a/media-video/kdenlive/kdenlive-0.9.8.ebuild b/media-video/kdenlive/kdenlive-0.9.8.ebuild
new file mode 100644
index 000000000000..9731fda86896
--- /dev/null
+++ b/media-video/kdenlive/kdenlive-0.9.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KDE_MINIMAL="4.13.1"
+OPENGL_REQUIRED="always"
+inherit kde4-base
+
+DESCRIPTION="A non-linear video editing suite for KDE"
+HOMEPAGE="http://www.kdenlive.org/"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 ~ppc x86 ~x86-linux"
+IUSE="debug nepomuk v4l"
+
+RDEPEND="
+ dev-libs/qjson
+ $(add_kdebase_dep kdelibs 'nepomuk?')
+ >=media-libs/mlt-0.9.0[ffmpeg,sdl,xml,melt,qt4,kdenlive]
+ virtual/ffmpeg[encode,sdl,X]
+ v4l? ( media-libs/libv4l )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+DOCS=(AUTHORS ChangeLog README)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with nepomuk)
+ $(cmake-utils_use_with v4l LibV4L2)
+ )
+ kde4-base_src_configure
+}
diff --git a/media-video/kdenlive/metadata.xml b/media-video/kdenlive/metadata.xml
new file mode 100644
index 000000000000..e7640d8aa310
--- /dev/null
+++ b/media-video/kdenlive/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <herd>kde</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="nepomuk">Enable Nepomuk based semantic desktop support (deprecated)</flag>
+ </use>
+</pkgmetadata>