summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/kmplayer/kmplayer-0.11.3d-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/kmplayer/kmplayer-0.11.3d-r3.ebuild')
-rw-r--r--media-video/kmplayer/kmplayer-0.11.3d-r3.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/media-video/kmplayer/kmplayer-0.11.3d-r3.ebuild b/media-video/kmplayer/kmplayer-0.11.3d-r3.ebuild
new file mode 100644
index 000000000000..5b2dac1172a2
--- /dev/null
+++ b/media-video/kmplayer/kmplayer-0.11.3d-r3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et fr ga gl hr hu it
+ja km ku lt lv mai nb nds nl nn pl pt pt_BR ro ru sk sr sr@latin sv th tr ug uk
+zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="Video player plugin for Konqueror and basic MPlayer/Xine/ffmpeg/ffserver/VDR frontend"
+HOMEPAGE="https://projects.kde.org/projects/extragear/multimedia/kmplayer"
+SRC_URI="http://kmplayer.kde.org/pkgs/${P}.tar.bz2"
+
+LICENSE="GPL-2 FDL-1.2 LGPL-2.1"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="cairo debug expat npp"
+
+DEPEND="
+ media-libs/phonon[qt4]
+ x11-libs/libX11
+ expat? ( >=dev-libs/expat-2.0.1 )
+ cairo? (
+ x11-libs/cairo
+ x11-libs/pango
+ )
+ npp? (
+ dev-libs/dbus-glib
+ $(add_kdeapps_dep kreadconfig)
+ >=x11-libs/gtk+-2.10.14:2
+ www-plugins/adobe-flash
+ )
+"
+RDEPEND="${DEPEND}
+ media-video/mplayer
+"
+
+src_prepare() {
+ use npp && epatch "${FILESDIR}/${PN}-flash.patch"
+ sed -e '/add_subdirectory(icons)/d' \
+ -i CMakeLists.txt || die
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use cairo KMPLAYER_BUILT_WITH_CAIRO)
+ $(cmake-utils_use expat KMPLAYER_BUILT_WITH_EXPAT)
+ $(cmake-utils_use npp KMPLAYER_BUILT_WITH_NPP)
+ )
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+
+ if use npp; then
+ kwriteconfig --file "${ED}/usr/share/config/kmplayerrc" --group "application/x-shockwave-flash" --key player npp
+ kwriteconfig --file "${ED}/usr/share/config/kmplayerrc" --group "application/x-shockwave-flash" --key plugin /usr/lib/nsbrowser/plugins/libflashplayer.so
+ fi
+}