summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/lsdvd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/lsdvd/files')
-rw-r--r--media-video/lsdvd/files/lsdvd-0.16-chapter-count.patch25
-rw-r--r--media-video/lsdvd/files/lsdvd-0.16-newline.patch22
-rw-r--r--media-video/lsdvd/files/lsdvd-0.16-title.patch27
-rw-r--r--media-video/lsdvd/files/lsdvd-0.16-types.patch27
-rw-r--r--media-video/lsdvd/files/lsdvd-0.16-usec.patch21
-rw-r--r--media-video/lsdvd/files/lsdvd-0.17-autotools.patch12
6 files changed, 134 insertions, 0 deletions
diff --git a/media-video/lsdvd/files/lsdvd-0.16-chapter-count.patch b/media-video/lsdvd/files/lsdvd-0.16-chapter-count.patch
new file mode 100644
index 000000000000..f51bd03762fc
--- /dev/null
+++ b/media-video/lsdvd/files/lsdvd-0.16-chapter-count.patch
@@ -0,0 +1,25 @@
+Using tt_srpt->title[].nr_of_ptts from the VMG IFO as a reference to the
+chapter count is often wrong, and noted as such in the source code. Use
+the program chain instead.
+
+--- lsdvd-0.16/lsdvd.c.orig 2014-08-22 21:47:06.009490680 -0600
++++ lsdvd-0.16/lsdvd.c 2014-08-22 21:47:30.947257942 -0600
+@@ -347,6 +347,7 @@
+ }
+
+ dvd_info.titles[j].chapter_count_reported = ifo_zero->tt_srpt->title[j].nr_of_ptts;
++ dvd_info.titles[j].chapter_count = pgc->nr_of_programs;
+ dvd_info.titles[j].cell_count = pgc->nr_of_cells;
+ dvd_info.titles[j].audiostream_count = vtsi_mat->nr_of_vts_audio_streams;
+ dvd_info.titles[j].subtitle_count = vtsi_mat->nr_of_vts_subp_streams;
+--- lsdvd-0.16/ohuman.c.orig 2014-08-22 21:47:00.993538145 -0600
++++ lsdvd-0.16/ohuman.c 2014-08-22 21:47:45.533121749 -0600
+@@ -20,7 +20,7 @@
+ // (int)(dvd_info->titles[j].general.length / 60) % 60,
+ // (float)((int)(dvd_info->titles[j].general.length * 1000) % 6000) / 1000); //,
+ // dvd_info->titles[j].general.length);
+- printf("Chapters: %02d, Cells: %02d, ", dvd_info->titles[j].chapter_count_reported, dvd_info->titles[j].cell_count);
++ printf("Chapters: %02d, Cells: %02d, ", dvd_info->titles[j].chapter_count, dvd_info->titles[j].cell_count);
+ printf("Audio streams: %02d, Subpictures: %02d", dvd_info->titles[j].audiostream_count, dvd_info->titles[j].subtitle_count);
+ printf("\n");
+
diff --git a/media-video/lsdvd/files/lsdvd-0.16-newline.patch b/media-video/lsdvd/files/lsdvd-0.16-newline.patch
new file mode 100644
index 000000000000..4f0ec1a74cd4
--- /dev/null
+++ b/media-video/lsdvd/files/lsdvd-0.16-newline.patch
@@ -0,0 +1,22 @@
+Removes extra newline from output like this:
+
+Title: 01, Length: 02:18:41.834 Chapters: 06, Cells: 06, Audio streams: 01, Subpictures: 03
+
+Title: 02, Length: 00:46:16.000 Chapters: 03, Cells: 03, Audio streams: 01, Subpictures: 03
+
+Title: 03, Length: 00:46:11.834 Chapters: 03, Cells: 03, Audio streams: 01, Subpictures: 03
+--- lsdvd-0.16/ohuman.c.orig 2014-08-22 21:47:00.993538145 -0600
++++ lsdvd-0.16/ohuman.c 2014-08-22 21:52:11.964633226 -0600
+@@ -111,11 +111,10 @@
+ printf("\n");
+ }
+ }
+- printf("\n");
+ }
+ }
+
+ if (! opt_t) {
+- printf("Longest track: %02d\n\n", dvd_info->longest_track);
++ printf("Longest track: %02d\n", dvd_info->longest_track);
+ }
+ }
diff --git a/media-video/lsdvd/files/lsdvd-0.16-title.patch b/media-video/lsdvd/files/lsdvd-0.16-title.patch
new file mode 100644
index 000000000000..44511a126e64
--- /dev/null
+++ b/media-video/lsdvd/files/lsdvd-0.16-title.patch
@@ -0,0 +1,27 @@
+See, http://bugs.gentoo.org/show_bug.cgi?id=233113
+
+lsdvd always reads the infos for all titles (even if only a single title was
+selected with "-t") and bails out if there is an error.
+
+Now, if for example title 5 is unreadable but you're interested in title 1, you
+should be able to get the info by using "-t 1", but that doesn't work, as lsdvd
+errors out before even starting the output because it can't read title 5.
+
+To solve this my patch makes lsdvd ignore read errors in titles it wouldn't
+display anyway.
+
+Patch by Martin Thierer
+
+diff -uw lsdvd-0.16.orig/lsdvd.c lsdvd-0.16/lsdvd.c
+--- lsdvd-0.16.orig/lsdvd.c 2006-03-02 14:48:11.000000000 +0100
++++ lsdvd-0.16/lsdvd.c 2008-07-27 20:11:55.000000000 +0200
+@@ -292,7 +292,7 @@
+
+ for (i=1; i <= ifo_zero->vts_atrt->nr_of_vtss; i++) {
+ ifo[i] = ifoOpen(dvd, i);
+- if ( !ifo[i] ) {
++ if ( !ifo[i] && opt_t == i ) {
+ fprintf( stderr, "Can't open ifo %d!\n", i);
+ return 4;
+ }
+
diff --git a/media-video/lsdvd/files/lsdvd-0.16-types.patch b/media-video/lsdvd/files/lsdvd-0.16-types.patch
new file mode 100644
index 000000000000..b20f8ea2cb4b
--- /dev/null
+++ b/media-video/lsdvd/files/lsdvd-0.16-types.patch
@@ -0,0 +1,27 @@
+Index: lsdvd-0.16/configure.in
+===================================================================
+--- lsdvd-0.16.orig/configure.in
++++ lsdvd-0.16/configure.in
+@@ -10,8 +10,8 @@ fi
+
+ AC_CHECK_LIB(dvdread, DVDOpen, , AC_MSG_ERROR([libdvdread not found!]))
+ AC_MSG_CHECKING([for dvdread/ifo_read.h])
+-AC_TRY_COMPILE([#include <dvdread/ifo_read.h>
+- #include <stdint.h>], ,
++AC_TRY_COMPILE([#include <stdint.h>
++ #include <dvdread/ifo_read.h>], ,
+ AC_MSG_RESULT([yes]),
+ AC_MSG_RESULT([no])
+ AC_MSG_ERROR([Header files for dvdread not found]))
+Index: lsdvd-0.16/lsdvd.c
+===================================================================
+--- lsdvd-0.16.orig/lsdvd.c
++++ lsdvd-0.16/lsdvd.c
+@@ -13,6 +13,7 @@
+ * 2003-04-19 Cleanups get_title_name, added dvdtime2msec, added helper macros,
+ * output info structures in form of a Perl module, by Henk Vergonet.
+ */
++#include <stdint.h>
+ #include <dvdread/ifo_read.h>
+ #include <string.h>
+ #include <sys/stat.h>
diff --git a/media-video/lsdvd/files/lsdvd-0.16-usec.patch b/media-video/lsdvd/files/lsdvd-0.16-usec.patch
new file mode 100644
index 000000000000..bfaa16e9615d
--- /dev/null
+++ b/media-video/lsdvd/files/lsdvd-0.16-usec.patch
@@ -0,0 +1,21 @@
+diff -uw lsdvd-0.16.orig/lsdvd.c lsdvd-0.16/lsdvd.c
+--- lsdvd-0.16.orig/lsdvd.c 2006-03-02 14:48:11.000000000 +0100
++++ lsdvd-0.16/lsdvd.c 2008-05-18 13:58:15.000000000 +0200
+@@ -92,7 +92,7 @@
+ ms += (((dt->second & 0xf0) >> 3) * 5 + (dt->second & 0x0f)) * 1000;
+
+ if(fps > 0)
+- ms += ((dt->frame_u & 0x30) >> 3) * 5 + (dt->frame_u & 0x0f) * 1000.0 / fps;
++ ms += (((dt->frame_u & 0x30) >> 3) * 5 + (dt->frame_u & 0x0f)) * 1000.0 / fps;
+
+ return ms;
+ }
+@@ -107,7 +107,7 @@
+ {
+ double fps = frames_per_s[(dt->frame_u & 0xc0) >> 6];
+
+- pt->usec = pt->usec + ((dt->frame_u & 0x30) >> 3) * 5 + (dt->frame_u & 0x0f) * 1000.0 / fps;
++ pt->usec = pt->usec + (((dt->frame_u & 0x30) >> 3) * 5 + (dt->frame_u & 0x0f)) * 1000.0 / fps;
+ pt->second = pt->second + ((dt->second & 0xf0) >> 3) * 5 + (dt->second & 0x0f);
+ pt->minute = pt->minute + ((dt->minute & 0xf0) >> 3) * 5 + (dt->minute & 0x0f);
+ pt->hour = pt->hour + ((dt->hour & 0xf0) >> 3) * 5 + (dt->hour & 0x0f);
diff --git a/media-video/lsdvd/files/lsdvd-0.17-autotools.patch b/media-video/lsdvd/files/lsdvd-0.17-autotools.patch
new file mode 100644
index 000000000000..c2f7e9456ed9
--- /dev/null
+++ b/media-video/lsdvd/files/lsdvd-0.17-autotools.patch
@@ -0,0 +1,12 @@
+--- configure.ac.orig 2014-10-04 00:36:04.484376722 -0600
++++ configure.ac 2014-10-04 00:36:25.080207028 -0600
+@@ -1,9 +1,6 @@
+ AC_INIT([lsdvd], [0.17])
+ AM_INIT_AUTOMAKE([foreign])
+ AC_PROG_CC
+-if eval "test x$GCC = xyes"; then # Enable warnings when using GCC
+- CFLAGS="$CFLAGS -W -Wall -Wcast-align -Wcast-qual -Wpointer-arith -Wreturn-type -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wformat -Werror=format-security"
+-fi
+ AC_SYS_LARGEFILE
+ PKG_CHECK_MODULES([DVDREAD], [dvdread >= 4.1.3])
+ AC_ARG_ENABLE([debug], \ No newline at end of file