summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/makemkv/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/makemkv/files')
-rw-r--r--media-video/makemkv/files/makemkv-makefile.patch18
-rw-r--r--media-video/makemkv/files/makemkv-path.patch13
2 files changed, 31 insertions, 0 deletions
diff --git a/media-video/makemkv/files/makemkv-makefile.patch b/media-video/makemkv/files/makemkv-makefile.patch
new file mode 100644
index 000000000000..224273a5286e
--- /dev/null
+++ b/media-video/makemkv/files/makemkv-makefile.patch
@@ -0,0 +1,18 @@
+--- makemkv-oss-1.9.3/Makefile.in.orig 2015-06-02 13:34:00.000000000 +0200
++++ makemkv-oss-1.9.3/Makefile.in 2015-06-04 12:32:29.752291023 +0200
+@@ -47,7 +47,7 @@
+ endif
+
+ out/%: out/%.full
+- $(OBJCOPY) --strip-all --strip-debug --strip-unneeded --discard-all $< $@
++ $(OBJCOPY) --discard-all $< $@
+
+ out/libdriveio.so.0.full:
+ mkdir -p out
+@@ -91,5 +91,5 @@
+
+ tmp/image_data.o : makemkvgui/bin/image_data.bin
+ mkdir -p tmp
+- $(LD) -r -b binary -o $@ $<
++ $(LD) -r -b binary -z noexecstack -o $@ $<
+
diff --git a/media-video/makemkv/files/makemkv-path.patch b/media-video/makemkv/files/makemkv-path.patch
new file mode 100644
index 000000000000..88f44a9d4ceb
--- /dev/null
+++ b/media-video/makemkv/files/makemkv-path.patch
@@ -0,0 +1,13 @@
+--- makemkv-oss-1.8.10/makemkvgui/src/api_linux.cpp.orig 2014-04-13 14:01:36.000000000 +0100
++++ makemkv-oss-1.8.10/makemkvgui/src/api_linux.cpp 2014-05-08 00:09:52.863784998 +0100
+@@ -36,9 +36,7 @@
+ }
+
+ static const char* const app_locations[]={
+- "/bin",
+- "/usr/bin",
+- "/usr/local/bin",
++ "/opt/bin",
+ NULL };
+
+ const char* const* ApGetAppLocations()