summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/mkclean
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/mkclean')
-rw-r--r--media-video/mkclean/Manifest2
-rw-r--r--media-video/mkclean/metadata.xml8
-rw-r--r--media-video/mkclean/mkclean-0.8.6-r1.ebuild40
-rw-r--r--media-video/mkclean/mkclean-0.8.7.ebuild35
4 files changed, 85 insertions, 0 deletions
diff --git a/media-video/mkclean/Manifest b/media-video/mkclean/Manifest
new file mode 100644
index 000000000000..a8c9e29b5dfa
--- /dev/null
+++ b/media-video/mkclean/Manifest
@@ -0,0 +1,2 @@
+DIST mkclean-0.8.6.tar.bz2 730851 SHA256 6e81a7522ef47ddfefb4ae1f5d9bee217190741b6660f5240dba85bc4faf4a44
+DIST mkclean-0.8.7.tar.bz2 737877 SHA256 88713065a172d1ab7fd34c8854a42f6bf8d0e794957265340328a2f692ad46d9 SHA512 74c7a9d5f6998b0b8b6b8880064b794e72d2f4733a31cede4be3b88092254ed03545a7d4637ca1e9cab17615584594b96f8b2c072921e3640abeec2de052eb1f WHIRLPOOL 9c16947d916df05d47e57799e2f24f92bb01f37f5c88148b2d07a26069cbfc65bd8945af81e52a10e9bd8da18484776f6c39c9bea85b97f5120f2fbe461509c6
diff --git a/media-video/mkclean/metadata.xml b/media-video/mkclean/metadata.xml
new file mode 100644
index 000000000000..29823979ed85
--- /dev/null
+++ b/media-video/mkclean/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <longdescription lang="en">
+ mkclean is a command line tool to clean and optimize Matroska (.mkv / .mka / .mks / .mk3d) and WebM (.webm / .weba) files that have already been muxed. It reorders the elements with the Cues at the front, so your Matroska files are ready to be streamed efficiently over the web. It also removes elements not found in the Matroska specs and the extra Meta Seek list of Clusters that some program add to their file. It can also optionally remux the Cluster blocks to start each boundary with a keyframe and the matching audio/subtitle blocks for that keyframe.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-video/mkclean/mkclean-0.8.6-r1.ebuild b/media-video/mkclean/mkclean-0.8.6-r1.ebuild
new file mode 100644
index 000000000000..6774cfdf91ba
--- /dev/null
+++ b/media-video/mkclean/mkclean-0.8.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="mkclean is a command line tool to clean and optimize Matroska files"
+HOMEPAGE="http://www.matroska.org/downloads/mkclean.html"
+SRC_URI="http://downloads.sourceforge.net/project/matroska/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ./configure # non-standard configure
+
+ # fixing generated makefiles
+ sed -i -e 's|^\(LFLAGS.*+=.*\$(LIBS)\)|\1 \$(LDFLAGS)|g' \
+ -e 's|^\(STRIP.*=\)|\1 echo|g' $(find -name "*.mak")
+}
+
+src_compile() {
+ emake -f GNUmakefile -j1
+ emake -C mkclean -f mkWDclean.mak -j1
+ emake -C mkclean/regression -f mkcleanreg.mak -j1
+}
+
+src_install() {
+ dobin release/*/mk*clean*
+ newdoc ChangeLog.txt ChangeLog
+ newdoc ReadMe.txt README
+}
diff --git a/media-video/mkclean/mkclean-0.8.7.ebuild b/media-video/mkclean/mkclean-0.8.7.ebuild
new file mode 100644
index 000000000000..42f5aa8e3981
--- /dev/null
+++ b/media-video/mkclean/mkclean-0.8.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="mkclean is a command line tool to clean and optimize Matroska files"
+HOMEPAGE="http://www.matroska.org/downloads/mkclean.html"
+SRC_URI="http://downloads.sourceforge.net/project/matroska/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_configure() {
+ # non-standard configure
+ ./configure || die
+
+ # fixing generated makefiles
+ sed -i -e 's|^\(LFLAGS.*+=.*\$(LIBS)\)|\1 \$(LDFLAGS)|g' \
+ -e 's|^\(STRIP.*=\)|\1 echo|g' $(find -name "*.mak") || die
+}
+
+src_compile() {
+ emake -f GNUmakefile -j1
+ emake -C mkclean -f mkWDclean.mak -j1
+ emake -C mkclean/regression -f mkcleanreg.mak -j1
+}
+
+src_install() {
+ dobin release/*/mk*clean*
+ newdoc ChangeLog.txt ChangeLog
+ newdoc ReadMe.txt README
+}