summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/mplay-sh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/mplay-sh')
-rw-r--r--media-video/mplay-sh/Manifest1
-rw-r--r--media-video/mplay-sh/metadata.xml10
-rw-r--r--media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild46
3 files changed, 57 insertions, 0 deletions
diff --git a/media-video/mplay-sh/Manifest b/media-video/mplay-sh/Manifest
new file mode 100644
index 000000000000..ebde216cb759
--- /dev/null
+++ b/media-video/mplay-sh/Manifest
@@ -0,0 +1 @@
+DIST mplay-0.5.3.tgz 26829 SHA256 2dee614796b97a1790ab58f0ee5f248d663376b2d2478061387535ddb6b5cc8e
diff --git a/media-video/mplay-sh/metadata.xml b/media-video/mplay-sh/metadata.xml
new file mode 100644
index 000000000000..5f9f14619db8
--- /dev/null
+++ b/media-video/mplay-sh/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild b/media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..8a53b8a311ca
--- /dev/null
+++ b/media-video/mplay-sh/mplay-sh-0.5.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P="mplay-${PV}"
+
+DESCRIPTION="mplayer wrapper script as backend for vdr-mplayer"
+HOMEPAGE="http://www.vdr-portal.de/board/thread.php?threadid=62306"
+SRC_URI="mirror://gentoo/${MY_P}.tgz
+ http://dev.gentoo.org/~zzam/distfiles/${MY_P}.tgz"
+
+KEYWORDS="x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="media-tv/gentoo-vdr-scripts"
+RDEPEND=">=media-video/mplayer-0.90_rc4"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i mplay.sh \
+ -e 's#$CONFDIR/silence.wav#/usr/share/vdr/mplay-sh/silence.wav#'
+ sed -i conf.examples/mplayrc \
+ -e 's#^MPLAY_PLAY.*#MPLAY_PLAY="/var/vdr/tmp/mplay.play"#'
+}
+
+src_install() {
+ exeinto /usr/share/vdr/mplayer/bin
+ doexe mplay.sh
+
+ insinto /etc/vdr/plugins/mplay
+ doins conf.examples/*.conf conf.examples/mplayrc
+
+ insinto /usr/share/vdr/mplay-sh
+ doins conf.examples/silence.wav
+
+ dodoc README* HISTORY
+ keepdir /var/vdr/tmp
+ chown vdr:vdr -R "${D}/var/vdr"
+}