summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2015-12-22 22:33:40 +0300
committerIlya Tumaykin <itumaykin@gmail.com>2015-12-28 15:47:25 +0300
commit14dec956799c2054559612e963fe0abdcd7448ad (patch)
tree2a7d28c25803b885dfbf2c64f55c4e4c14ca051e /media-video/mpv/mpv-9999.ebuild
parentmedia-video/mpv: revbump 0.11.0 to receive recent live ebuild changes (diff)
downloadgentoo-14dec956799c2054559612e963fe0abdcd7448ad.tar.gz
gentoo-14dec956799c2054559612e963fe0abdcd7448ad.tar.bz2
gentoo-14dec956799c2054559612e963fe0abdcd7448ad.zip
media-video/mpv: update vaapi USE dependencies and configure options
VAAPI in mpv is now available for Wayland and for EGL and GLX on X11 as opposed to GLX only before. A newer libva version is required, though. Package-Manager: portage-2.2.24
Diffstat (limited to 'media-video/mpv/mpv-9999.ebuild')
-rw-r--r--media-video/mpv/mpv-9999.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 3c748518e9dd..38b675a2e365 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -45,7 +45,7 @@ REQUIRED_USE="
pvr? ( v4l )
uchardet? ( iconv )
v4l? ( || ( alsa oss ) )
- vaapi? ( X )
+ vaapi? ( || ( X wayland ) )
vdpau? ( X )
wayland? ( egl )
xinerama? ( X )
@@ -92,6 +92,7 @@ COMMON_DEPEND="
samba? ( net-fs/samba )
sdl? ( media-libs/libsdl2[sound,threads,video,X?,wayland?] )
v4l? ( media-libs/libv4l )
+ vaapi? ( >=x11-libs/libva-1.4.0[X?,wayland?] )
wayland? (
>=dev-libs/wayland-1.6.0
>=x11-libs/libxkbcommon-0.3.0
@@ -104,7 +105,6 @@ COMMON_DEPEND="
x11-libs/libXdamage
virtual/opengl
)
- vaapi? ( >=x11-libs/libva-1.2.0[X] )
vdpau? ( >=x11-libs/libvdpau-0.2 )
xinerama? ( x11-libs/libXinerama )
xscreensaver? ( x11-libs/libXScrnSaver )
@@ -227,7 +227,9 @@ src_configure() {
$(use_enable wayland gl-wayland)
$(use_enable vdpau)
$(usex vdpau "$(use_enable opengl vdpau-gl-x11)" '--disable-vdpau-gl-x11')
- $(use_enable vaapi)
+ $(use_enable vaapi) # See below for vaapi-x-egl
+ $(usex vaapi "$(use_enable X vaapi-x11)" '--disable-vaapi-x11')
+ $(usex vaapi "$(use_enable wayland vaapi-wayland)" '--disable-vaapi-wayland')
$(usex vaapi "$(use_enable opengl vaapi-glx)" '--disable-vaapi-glx')
$(use_enable libcaca caca)
$(use_enable drm)
@@ -246,6 +248,13 @@ src_configure() {
$(use_enable pvr)
$(use_enable dvb dvbin)
)
+
+ if use vaapi && use X && use egl; then
+ mywafargs+=(--enable-vaapi-x-egl)
+ else
+ mywafargs+=(--disable-vaapi-x-egl)
+ fi
+
waf-utils_src_configure "${mywafargs[@]}"
}