summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-02-12 13:11:22 +0300
committerIlya Tumaykin <itumaykin@gmail.com>2016-02-12 13:30:07 +0300
commit65e3818f6012af6672f7fa4e9dea54dec1fef3fb (patch)
treed477eaba0115b86ebc24001ea0f787aeba1f1486 /media-video/mpv/mpv-9999.ebuild
parentmedia-video/mpv: enable xv USE by default in 9999 (diff)
downloadgentoo-65e3818f6012af6672f7fa4e9dea54dec1fef3fb.tar.gz
gentoo-65e3818f6012af6672f7fa4e9dea54dec1fef3fb.tar.bz2
gentoo-65e3818f6012af6672f7fa4e9dea54dec1fef3fb.zip
media-video/mpv: untie opengl USE from X USE in 9999
opengl USE can now do something else, but enabling GLX. opengl USE now also controls OpenGL support in libmpv. Package-Manager: portage-2.2.27
Diffstat (limited to 'media-video/mpv/mpv-9999.ebuild')
-rw-r--r--media-video/mpv/mpv-9999.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 02ec44a96e3c..cfbfe7bd6642 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -28,7 +28,6 @@ DOCS+=( README.md )
# See Copyright in source tarball and bug #506946. Waf is BSD, libmpv is ISC.
LICENSE="GPL-2+ BSD ISC"
SLOT="0"
-# Here 'opengl' stands for GLX, 'egl' stands for any EGL-based output
IUSE="+alsa archive bluray cdda +cli doc drm dvb +dvd +egl +enca encode gbm
+iconv jack jpeg lcms +libass libav libcaca libguess libmpv lua luajit
openal +opengl oss pulseaudio raspberry-pi rubberband samba sdl selinux
@@ -43,7 +42,6 @@ REQUIRED_USE="
lcms? ( || ( opengl egl ) )
libguess? ( iconv )
luajit? ( lua )
- opengl? ( X )
uchardet? ( iconv )
v4l? ( || ( alsa oss ) )
vaapi? ( || ( gbm X wayland ) )
@@ -89,6 +87,7 @@ COMMON_DEPEND="
luajit? ( dev-lang/luajit:2 )
)
openal? ( >=media-libs/openal-1.13 )
+ opengl? ( virtual/opengl )
pulseaudio? ( media-sound/pulseaudio )
rubberband? ( >=media-libs/rubberband-1.8.0 )
samba? ( net-fs/samba )
@@ -103,10 +102,7 @@ COMMON_DEPEND="
x11-libs/libX11
x11-libs/libXext
>=x11-libs/libXrandr-1.2.0
- opengl? (
- x11-libs/libXdamage
- virtual/opengl
- )
+ opengl? ( x11-libs/libXdamage )
vdpau? ( >=x11-libs/libvdpau-0.2 )
xinerama? ( x11-libs/libXinerama )
xscreensaver? ( x11-libs/libXScrnSaver )
@@ -230,20 +226,21 @@ src_configure() {
$(use_enable xv)
$(use_enable xinerama)
$(use_enable X xrandr)
- $(use_enable opengl gl-x11)
+ $(usex opengl "$(use_enable X gl-x11)" '--disable-gl-x11')
$(usex egl "$(use_enable X egl-x11)" '--disable-egl-x11')
$(usex egl "$(use_enable gbm egl-drm)" '--disable-egl-drm')
$(use_enable wayland gl-wayland)
$(use_enable vdpau)
$(usex vdpau "$(use_enable opengl vdpau-gl-x11)" '--disable-vdpau-gl-x11')
- $(use_enable vaapi) # See below for vaapi-x-egl
+ $(use_enable vaapi) # See below for vaapi-glx, vaapi-x-egl
$(usex vaapi "$(use_enable X vaapi-x11)" '--disable-vaapi-x11')
$(usex vaapi "$(use_enable wayland vaapi-wayland)" '--disable-vaapi-wayland')
$(usex vaapi "$(use_enable gbm vaapi-drm)" '--disable-vaapi-drm')
- $(usex vaapi "$(use_enable opengl vaapi-glx)" '--disable-vaapi-glx')
$(use_enable libcaca caca)
$(use_enable jpeg)
+ --disable-android
$(use_enable raspberry-pi rpi)
+ $(use_enable opengl desktop-gl)
# HWaccels
$(use_enable vaapi vaapi-hwaccel)
@@ -257,10 +254,11 @@ src_configure() {
$(use_enable dvb dvbin)
)
- if use vaapi && use X && use egl; then
- mywafargs+=(--enable-vaapi-x-egl)
- else
- mywafargs+=(--disable-vaapi-x-egl)
+ if use vaapi && use X; then
+ mywafargs+=(
+ $(use_enable opengl vaapi-glx)
+ $(use_enable egl vaapi-x-egl)
+ )
fi
# Create reproducible non-live builds