summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2015-12-22 20:11:26 +0300
committerIlya Tumaykin <itumaykin@gmail.com>2015-12-28 15:47:13 +0300
commit6965c84f286cf0fb6a67765a00bdc6ae20cf0b19 (patch)
tree9c909cc872f9b625e4ed51216141d8f7923454d6 /media-video/mpv
parentmedia-video/mpv: explicitly disable unsupported options (diff)
downloadgentoo-6965c84f286cf0fb6a67765a00bdc6ae20cf0b19.tar.gz
gentoo-6965c84f286cf0fb6a67765a00bdc6ae20cf0b19.tar.bz2
gentoo-6965c84f286cf0fb6a67765a00bdc6ae20cf0b19.zip
media-video/mpv: avoid uchardet automagic dep wrt bug 565646
Add missing uchardet USE flag to avoid automagic dependency on uchardet wrt bug 565646. Gentoo-Bug: 565646 Package-Manager: portage-2.2.24
Diffstat (limited to 'media-video/mpv')
-rw-r--r--media-video/mpv/metadata.xml1
-rw-r--r--media-video/mpv/mpv-9999.ebuild7
2 files changed, 6 insertions, 2 deletions
diff --git a/media-video/mpv/metadata.xml b/media-video/mpv/metadata.xml
index 6c14783bb916..2f9462633a27 100644
--- a/media-video/mpv/metadata.xml
+++ b/media-video/mpv/metadata.xml
@@ -37,6 +37,7 @@
<flag name="raspberry-pi">Enable support for the Raspberry Pi</flag>
<flag name="rubberband">Enable high quality pitch correction via <pkg>media-libs/rubberband</pkg></flag>
<flag name="sdl">Enable <pkg>media-libs/libsdl2</pkg> based video and audio outputs</flag>
+ <flag name="uchardet">Enable subtitles charset discovery via <pkg>dev-libs/uchardet</pkg></flag>
<flag name="vf-dlopen">Install additional video filters for using with -vf dlopen</flag>
</use>
<upstream>
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 637d7f6fd7e6..bee13f2886a0 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -30,8 +30,8 @@ LICENSE="GPL-2+ BSD ISC"
SLOT="0"
IUSE="+alsa archive bluray cdda +cli doc drm dvb +dvd egl +enca encode +iconv
jack jpeg lcms +libass libav libcaca libguess libmpv lua luajit openal +opengl
-oss pulseaudio pvr raspberry-pi rubberband samba sdl selinux test v4l vaapi
-vdpau vf-dlopen wayland +X xinerama +xscreensaver xv"
+oss pulseaudio pvr raspberry-pi rubberband samba sdl selinux test uchardet v4l
+vaapi vdpau vf-dlopen wayland +X xinerama +xscreensaver xv"
REQUIRED_USE="
|| ( cli libmpv )
@@ -42,6 +42,7 @@ REQUIRED_USE="
luajit? ( lua )
opengl? ( || ( wayland X ) )
pvr? ( v4l )
+ uchardet? ( iconv )
vaapi? ( X )
vdpau? ( X )
wayland? ( opengl )
@@ -84,6 +85,7 @@ COMMON_DEPEND="
rubberband? ( >=media-libs/rubberband-1.8.0 )
samba? ( net-fs/samba )
sdl? ( media-libs/libsdl2[sound,threads,video,X?,wayland?] )
+ uchardet? ( dev-libs/uchardet )
v4l? ( media-libs/libv4l )
wayland? (
>=dev-libs/wayland-1.6.0
@@ -184,6 +186,7 @@ src_configure() {
$(use_enable cdda)
$(use_enable enca)
$(use_enable libguess)
+ $(use_enable uchardet)
$(use_enable rubberband)
$(use_enable lcms lcms2)
--disable-vapoursynth # Only available in overlays