summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2015-12-28 05:43:54 +0300
committerIlya Tumaykin <itumaykin@gmail.com>2015-12-28 15:46:54 +0300
commit947977c5906e6ae09ff03a13c219db776835a724 (patch)
tree7484677adeede3a01254161dc12afadc75226c4c /media-video/mpv
parentmedia-video/mpv: rename WAF_V to WAF_PV to be in sync with Portage (diff)
downloadgentoo-947977c5906e6ae09ff03a13c219db776835a724.tar.gz
gentoo-947977c5906e6ae09ff03a13c219db776835a724.tar.bz2
gentoo-947977c5906e6ae09ff03a13c219db776835a724.zip
media-video/mpv: make waf sources be appended to SRC_URI
This helps to avoid confusion that waf sources are the only ones being fetched. Suggested by mgorny in PR #511. Also use a shorter fetch URL for waf sources. Package-Manager: portage-2.2.24
Diffstat (limited to 'media-video/mpv')
-rw-r--r--media-video/mpv/mpv-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 9ca03d5e40b6..bde9b93b5101 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -12,16 +12,16 @@ WAF_PV='1.8.12'
DESCRIPTION="Media player based on MPlayer and mplayer2"
HOMEPAGE="https://mpv.io/"
-SRC_URI="https://waf.io/pub/release/waf-${WAF_PV}"
if [[ ${PV} != *9999* ]]; then
- SRC_URI+=" https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
DOCS=( RELEASE_NOTES )
else
EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
inherit git-r3
fi
+SRC_URI+=" https://waf.io/waf-${WAF_PV}"
DOCS+=( README.md etc/example.conf etc/input.conf )
# See Copyright in source tarball and bug #506946. Waf is BSD, libmpv is ISC.