summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2015-12-22 19:44:10 +0300
committerIlya Tumaykin <itumaykin@gmail.com>2015-12-28 15:47:08 +0300
commitea4b57125eb3387d83678bde5f95fbb85993eb8b (patch)
treed5e67f5574c93d407c60868fa339ae8d903ae700 /media-video/mpv
parentmedia-video/mpv: simplify mesa dependency (diff)
downloadgentoo-ea4b57125eb3387d83678bde5f95fbb85993eb8b.tar.gz
gentoo-ea4b57125eb3387d83678bde5f95fbb85993eb8b.tar.bz2
gentoo-ea4b57125eb3387d83678bde5f95fbb85993eb8b.zip
media-video/mpv: enable test support, masked on ~alpha for now
mpv has a small, but working test suite. It requires dev-util/cmocka, which is missing ~alpha keyword atm. Thus a package USE mask is needed. See bug 569558 for dev-util/cmocka KEYWORDREQ. Package-Manager: portage-2.2.24
Diffstat (limited to 'media-video/mpv')
-rw-r--r--media-video/mpv/mpv-9999.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 2b35da380784..2c4646311ef0 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -29,8 +29,8 @@ DOCS+=( README.md etc/example.conf etc/input.conf )
LICENSE="GPL-2+ BSD ISC"
SLOT="0"
IUSE="+alsa archive bluray cdda +cli doc drm dvb +dvd egl +enca encode +iconv
-jack jpeg lcms +libass libav libcaca libguess libmpv lua luajit openal
-+opengl oss pulseaudio pvr raspberry-pi rubberband samba sdl selinux v4l vaapi
+jack jpeg lcms +libass libav libcaca libguess libmpv lua luajit openal +opengl
+oss pulseaudio pvr raspberry-pi rubberband samba sdl selinux test v4l vaapi
vdpau vf-dlopen wayland +X xinerama +xscreensaver xv"
REQUIRED_USE="
@@ -111,6 +111,7 @@ DEPEND="${COMMON_DEPEND}
dev-python/docutils
virtual/pkgconfig
doc? ( dev-python/rst2pdf )
+ test? ( >=dev-util/cmocka-1.0.0 )
"
RDEPEND="${COMMON_DEPEND}
selinux? ( sec-policy/selinux-mplayer )
@@ -163,11 +164,11 @@ src_configure() {
--disable-build-date # keep build reproducible
--disable-optimize # do not add '-O2' to CFLAGS
--disable-debug-build # do not add '-g' to CFLAGS
- --disable-test # avoid dev-util/cmocka automagic
$(use_enable doc pdf-build)
$(use_enable vf-dlopen vf-dlopen-filters)
$(use_enable cli zsh-comp)
+ $(use_enable test)
# optional features
$(use_enable iconv)
@@ -257,3 +258,12 @@ pkg_postrm() {
fdo-mime_desktop_database_update
gnome2_icon_cache_update
}
+
+src_test() {
+ cd "${S}"/build/test || die
+ for test in *; do
+ if [[ -x ${test} ]]; then
+ ./"${test}" || die "Test suite failed"
+ fi
+ done
+}