summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2021-04-28 10:06:02 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2021-05-07 22:58:08 +0200
commitd15e2b644efa1addd6de1e1c25452e325cbd84ea (patch)
tree0466c60976fe9f095cd3b731dcca2d1e4fb96c93 /media-video/obs-studio/obs-studio-9999.ebuild
parentdev-util/shellcheck: bump up to 0.7.2 (diff)
downloadgentoo-d15e2b644efa1addd6de1e1c25452e325cbd84ea.tar.gz
gentoo-d15e2b644efa1addd6de1e1c25452e325cbd84ea.tar.bz2
gentoo-d15e2b644efa1addd6de1e1c25452e325cbd84ea.zip
media-video/obs-studio: raise python support to 3.8 and 3.9
With a patch. Closes: https://bugs.gentoo.org/754006 Closes: https://bugs.gentoo.org/784989 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/20574 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video/obs-studio/obs-studio-9999.ebuild')
-rw-r--r--media-video/obs-studio/obs-studio-9999.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/media-video/obs-studio/obs-studio-9999.ebuild b/media-video/obs-studio/obs-studio-9999.ebuild
index e9173352238b..c6e7b77ff6b7 100644
--- a/media-video/obs-studio/obs-studio-9999.ebuild
+++ b/media-video/obs-studio/obs-studio-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
LUA_COMPAT=( luajit )
-# Does not work with 3.8+ https://bugs.gentoo.org/754006
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7..9} )
inherit cmake lua-single python-single-r1 xdg-utils
@@ -78,6 +77,8 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-26.1.2-python-3.8.patch" ) # https://github.com/obsproject/obs-studio/pull/3335
+
pkg_setup() {
use lua && lua-single_pkg_setup
use python && python-single-r1_pkg_setup
@@ -148,6 +149,16 @@ pkg_postinst() {
fi
}
+pkg_postinst() {
+ if use python; then
+ ewarn "This ebuild applies a patch that is not yet accepted upstream,"
+ ewarn "and while it fixes Python support at least to some extent, it"
+ ewarn "may cause other issues."
+ ewarn ""
+ ewarn "Please report any such issues to the Gentoo maintainer."
+ fi
+}
+
pkg_postrm() {
xdg_icon_cache_update
}