summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-07-13 22:50:37 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-07-13 22:51:17 +0300
commite25cd60ac4a446d637b0889170c1d9c0b2d2e9f7 (patch)
tree3e2f7431f564888e343b89f833a0f804d16ab177 /media-video/obs-v4l2sink/obs-v4l2sink-0.1.0_p20181012-r2.ebuild
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-e25cd60ac4a446d637b0889170c1d9c0b2d2e9f7.tar.gz
gentoo-e25cd60ac4a446d637b0889170c1d9c0b2d2e9f7.tar.bz2
gentoo-e25cd60ac4a446d637b0889170c1d9c0b2d2e9f7.zip
media-video/obs-v4l2sink: Fix plugin install directory. Bug 723210.
Tested, works. Closes: https://bugs.gentoo.org/723210 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'media-video/obs-v4l2sink/obs-v4l2sink-0.1.0_p20181012-r2.ebuild')
-rw-r--r--media-video/obs-v4l2sink/obs-v4l2sink-0.1.0_p20181012-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-video/obs-v4l2sink/obs-v4l2sink-0.1.0_p20181012-r2.ebuild b/media-video/obs-v4l2sink/obs-v4l2sink-0.1.0_p20181012-r2.ebuild
new file mode 100644
index 000000000000..4b4f0cc3d8fb
--- /dev/null
+++ b/media-video/obs-v4l2sink/obs-v4l2sink-0.1.0_p20181012-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_REMOVE_MODULES_LIST="FindLibObs"
+inherit cmake
+
+DESCRIPTION="obs studio output plugin for Video4Linux2 device"
+HOMEPAGE="https://github.com/CatxFish/obs-v4l2sink"
+COMMIT="1ec3c8ada0e1040d867ce567f177be55cd278378"
+SRC_URI="https://github.com/CatxFish/obs-v4l2sink/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-video/obs-studio-25.0.8-r1
+ dev-qt/qtwidgets:5
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+PDEPEND="media-video/v4l2loopback"
+
+PATCHES=(
+ "${FILESDIR}/${P}-installdirs.patch"
+)
+
+src_prepare() {
+ sed -i -e '/include(external\/FindLibObs.cmake)/d' -e 's#../UI#UI#' CMakeLists.txt
+ cmake_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DLIBOBS_INCLUDE_DIR="/usr/include/obs/"
+ )
+ cmake_src_configure
+}