summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/ogmrip
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/ogmrip')
-rw-r--r--media-video/ogmrip/Manifest1
-rw-r--r--media-video/ogmrip/metadata.xml19
-rw-r--r--media-video/ogmrip/ogmrip-1.0.1.ebuild83
3 files changed, 103 insertions, 0 deletions
diff --git a/media-video/ogmrip/Manifest b/media-video/ogmrip/Manifest
new file mode 100644
index 000000000000..482eaf4a6bdd
--- /dev/null
+++ b/media-video/ogmrip/Manifest
@@ -0,0 +1 @@
+DIST ogmrip-1.0.1.tar.gz 3276396 SHA256 1c7bb9a346f94a0b6ba783d71df7d21ce021b2f179f5c1a2ebf870366d53ed56 SHA512 22261b1a5086fc05139e8b9924b75d9a5a5e85b18e245e32545687e72273b485fe1c5041b89db653c6e2e9714518e17ea955435a20ac26fcc875fa8d1a90994c WHIRLPOOL 7b0f34763c4cbd5d0295a08fceaca1b230d817b4dbff490c4fbc9593ab9ec3aaa1c7f2287f37fbc07d874eeff136021bf7fdb5fd8204601487890e9a23a1a251
diff --git a/media-video/ogmrip/metadata.xml b/media-video/ogmrip/metadata.xml
new file mode 100644
index 000000000000..8ec700d9cc50
--- /dev/null
+++ b/media-video/ogmrip/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>billl@users.sf.net</email>
+ <name>Olivier Rolland</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <use>
+ <flag name="ogm">Support for OGM container format</flag>
+ <flag name="srt">Support for SRT subtitle format</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">ogmrip</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/ogmrip/ogmrip-1.0.1.ebuild b/media-video/ogmrip/ogmrip-1.0.1.ebuild
new file mode 100644
index 000000000000..2b6e751afa25
--- /dev/null
+++ b/media-video/ogmrip/ogmrip-1.0.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG=no
+
+inherit gnome2
+
+DESCRIPTION="Graphical frontend and libraries for ripping DVDs and encoding to AVI/OGM/MKV/MP4"
+HOMEPAGE="http://ogmrip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ogmrip/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="aac dbus debug dts gtk libnotify matroska mp3 mp4 nls ogm spell srt static-libs theora vorbis x264 xvid"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.16:2
+ >=app-i18n/enca-1.9
+ dev-libs/libxml2
+ media-libs/libdvdread
+ >=media-video/mplayer-1.0_rc2[dvd,encode,xvid?,dts?,x264?]
+ aac? ( >=media-libs/faac-1.24 )
+ gtk? (
+ >=x11-libs/gtk+-2.12:2
+ gnome-base/libglade
+ gnome-base/gconf
+ dbus? ( dev-libs/dbus-glib )
+ libnotify? ( >=x11-libs/libnotify-0.4.3 )
+ media-video/mplayer[jpeg]
+ )
+ matroska? ( media-video/mkvtoolnix )
+ mp3? ( media-sound/lame )
+ mp4? ( >=media-video/gpac-0.4.2 )
+ ogm? ( media-sound/ogmtools )
+ spell? ( >=app-text/enchant-1.1.0 )
+ srt? ( ||
+ (
+ ( >=app-text/tesseract-2 media-libs/tiff )
+ >=app-text/gocr-0.39
+ >=app-text/ocrad-0.15
+ )
+ media-libs/libpng )
+ theora? ( media-libs/libtheora )
+ vorbis? ( media-sound/vorbis-tools )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gvfs
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc-am
+ nls? ( sys-devel/gettext
+ dev-util/intltool )
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable debug maintainer-mode) \
+ $(use_enable gtk gtk-support) \
+ $(use_enable dbus dbus-support) \
+ $(use_enable spell enchant-support) \
+ $(use_enable ogm ogm-support) \
+ $(use_enable matroska mkv-support) \
+ $(use_enable mp4 mp4-support) \
+ $(use_enable xvid xvid-support) \
+ $(use_enable x264 x264-support) \
+ $(use_enable theora theora-support) \
+ $(use_enable vorbis vorbis-support) \
+ $(use_enable mp3 mp3-support) \
+ $(use_enable aac aac-support) \
+ $(use_enable srt srt-support) \
+ $(use_enable static-libs static) \
+ $(use_enable libnotify libnotify-support) \
+ $(use_enable nls) \
+ --with-html-dir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_install #528670
+}