summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/pgcedit/pgcedit-0.8.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/pgcedit/pgcedit-0.8.6.ebuild')
-rw-r--r--media-video/pgcedit/pgcedit-0.8.6.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/media-video/pgcedit/pgcedit-0.8.6.ebuild b/media-video/pgcedit/pgcedit-0.8.6.ebuild
new file mode 100644
index 000000000000..0593f08eae4f
--- /dev/null
+++ b/media-video/pgcedit/pgcedit-0.8.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils versionator
+
+MY_PN="PgcEdit"
+MY_P="${MY_PN}_source_$(get_after_major_version)"
+MY_PDOC="${MY_PN}_Manual_html"
+
+DESCRIPTION="DVD IFO and Menu editor"
+HOMEPAGE="http://download.videohelp.com/r0lZ/pgcedit/"
+SRC_URI="
+ http://download.videohelp.com/r0lZ/${PN}/versions/${MY_P}.zip
+ http://download.videohelp.com/r0lZ/${PN}/versions/${MY_PDOC}.zip
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="video"
+
+RDEPEND="
+ app-cdr/cdrtools
+ >=dev-lang/tcl-8.4:0
+ >=dev-lang/tk-8.4:0
+ video? ( app-emulation/wine )"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-config-paths.patch
+ sed -i "s:@DOCDIR@:/usr/share/doc/${PF}/html:" lib/main.tcl || die
+ # These are only used in Windows.
+ rm bin/{mkisofs,pskill}.exe || die
+ use video || rm bin/PgcEditPreview.exe
+}
+
+src_install() {
+ newbin ${MY_PN}_main.tcl ${PN}
+
+ keepdir /usr/share/${PN}/plugins
+ insinto /usr/share/${PN}
+ doins -r bin lib
+ dohtml -r doc/*
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} ${MY_PN} ${PN} "AudioVideo;Video;"
+
+ dodoc HISTORY.txt TODO.txt
+}