summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-12 18:41:18 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-12 18:45:37 +0100
commit592f0f431e3ecf55036d0347620e6989cba2a592 (patch)
tree48a4eb6ef325600bdd22db0b256814a0230e2c9e /media-video/plasma-mediacenter
parentmedia-video/kmplayer: Port to ecm.eclass and kde.org.eclass (diff)
downloadgentoo-592f0f431e3ecf55036d0347620e6989cba2a592.tar.gz
gentoo-592f0f431e3ecf55036d0347620e6989cba2a592.tar.bz2
gentoo-592f0f431e3ecf55036d0347620e6989cba2a592.zip
media-video/plasma-mediacenter: Port to ecm.eclass and kde.org.eclass
Add HOMEPAGE. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video/plasma-mediacenter')
-rw-r--r--media-video/plasma-mediacenter/plasma-mediacenter-5.7.5.ebuild50
1 files changed, 28 insertions, 22 deletions
diff --git a/media-video/plasma-mediacenter/plasma-mediacenter-5.7.5.ebuild b/media-video/plasma-mediacenter/plasma-mediacenter-5.7.5.ebuild
index f2d6d2da99ec..08802ebedeae 100644
--- a/media-video/plasma-mediacenter/plasma-mediacenter-5.7.5.ebuild
+++ b/media-video/plasma-mediacenter/plasma-mediacenter-5.7.5.ebuild
@@ -1,40 +1,46 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-KDE_TEST="forceoptional"
-inherit kde5
+ECM_TEST="forceoptional"
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
DESCRIPTION="Unified media experience for any device capable of running KDE Plasma"
+HOMEPAGE="https://community.kde.org/Plasma/Plasma_Media_Center"
SRC_URI="mirror://kde/stable/plasma-mediacenter/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
KEYWORDS="amd64 ~arm x86"
IUSE="semantic-desktop"
DEPEND="
- $(add_frameworks_dep kactivities)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kdeclarative)
- $(add_frameworks_dep kguiaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep kservice)
- $(add_frameworks_dep plasma)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtdeclarative)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtnetwork)
- $(add_qt_dep qtxml)
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
media-libs/taglib
semantic-desktop? (
- $(add_frameworks_dep baloo)
- $(add_frameworks_dep kfilemetadata)
+ >=kde-frameworks/baloo-${KFMIN}:5
+ >=kde-frameworks/kfilemetadata-${KFMIN}:5
)
"
RDEPEND="${DEPEND}
- $(add_plasma_dep plasma-workspace)
- $(add_qt_dep qtmultimedia 'qml')
+ >=dev-qt/qtmultimedia-${QTMIN}:5[qml]
+ >=kde-plasma/plasma-workspace-5.15.5:5
!media-video/plasma-mediacenter:0
"
@@ -43,5 +49,5 @@ src_configure() {
$(cmake_use_find_package semantic-desktop KF5Baloo)
)
- kde5_src_configure
+ ecm_src_configure
}