summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2016-03-08 22:44:58 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2016-03-08 22:45:21 +0100
commit2ed594f4e7d2ce4948089dd581f65bf57f69b7da (patch)
treef8f0f1d0bebaeac5d6a4972aabe832a517b43f03 /media-video/raspberrypi-omxplayer/files
parentdev-go/go-gitlab-client: Initial version (diff)
downloadgentoo-2ed594f4e7d2ce4948089dd581f65bf57f69b7da.tar.gz
gentoo-2ed594f4e7d2ce4948089dd581f65bf57f69b7da.tar.bz2
gentoo-2ed594f4e7d2ce4948089dd581f65bf57f69b7da.zip
renamed media-video/omxplayer to media-video/raspberrypi-omxplayer
Diffstat (limited to 'media-video/raspberrypi-omxplayer/files')
-rw-r--r--media-video/raspberrypi-omxplayer/files/fonts-path.patch15
-rw-r--r--media-video/raspberrypi-omxplayer/files/omxplayer-9999-Makefile.patch26
2 files changed, 41 insertions, 0 deletions
diff --git a/media-video/raspberrypi-omxplayer/files/fonts-path.patch b/media-video/raspberrypi-omxplayer/files/fonts-path.patch
new file mode 100644
index 000000000000..6683145f6833
--- /dev/null
+++ b/media-video/raspberrypi-omxplayer/files/fonts-path.patch
@@ -0,0 +1,15 @@
+diff --git a/omxplayer.cpp b/omxplayer.cpp
+index 0626e2e..8450bf2 100644
+--- a/omxplayer.cpp
++++ b/omxplayer.cpp
+@@ -83,8 +83,8 @@ bool m_osd = true;
+ bool m_no_keys = false;
+ std::string m_external_subtitles_path;
+ bool m_has_external_subtitles = false;
+-std::string m_font_path = "/usr/share/fonts/truetype/freefont/FreeSans.ttf";
+-std::string m_italic_font_path = "/usr/share/fonts/truetype/freefont/FreeSansOblique.ttf";
++std::string m_font_path = "/usr/share/fonts/freefont/FreeSans.ttf";
++std::string m_italic_font_path = "/usr/share/fonts/freefont/FreeSansOblique.ttf";
+ std::string m_dbus_name = "org.mpris.MediaPlayer2.omxplayer";
+ bool m_asked_for_font = false;
+ bool m_asked_for_italic_font = false;
diff --git a/media-video/raspberrypi-omxplayer/files/omxplayer-9999-Makefile.patch b/media-video/raspberrypi-omxplayer/files/omxplayer-9999-Makefile.patch
new file mode 100644
index 000000000000..c6f945209b95
--- /dev/null
+++ b/media-video/raspberrypi-omxplayer/files/omxplayer-9999-Makefile.patch
@@ -0,0 +1,26 @@
+--- omxplayer-9999/Makefile
++++ omxplayer-9999/Makefile
+@@ -2,9 +2,11 @@
+
+ CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
+
+-LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lWFC -lGLESv2 -lEGL -lbcm_host -lopenmaxil -lfreetype -lz
++PKGS=freetype2 dbus-1 libavcodec libavutil libavformat libswresample libswscale libpcre
++
++LIBS+=-lrt -lpthread $(shell pkg-config --libs $(PKGS)) -L/opt/vc/lib
+
+-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include
++INCLUDES+=$(shell pkg-config --cflags $(PKGS)) -I/opt/vc/include -I. -Ilinux
+
+ DIST ?= omxplayer-dist
+
+@@ -51,8 +47,7 @@
+ bash gen_version.sh > version.h
+
+ omxplayer.bin: version $(OBJS)
+- $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) -lvchiq_arm -lvcos -ldbus-1 -lrt -lpthread -lavutil -lavcodec -lavformat -lswscale -lswresample -lpcre
+- $(STRIP) omxplayer.bin
++ $(CXX) $(LDFLAGS) -o omxplayer.bin $(OBJS) $(LIBS)
+
+ help.h: README.md Makefile
+ awk '/SYNOPSIS/{p=1;print;next} p&&/KEY BINDINGS/{p=0};p' $< \