summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/recordmydesktop/recordmydesktop-0.3.8.1-r4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/recordmydesktop/recordmydesktop-0.3.8.1-r4.ebuild')
-rw-r--r--media-video/recordmydesktop/recordmydesktop-0.3.8.1-r4.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/media-video/recordmydesktop/recordmydesktop-0.3.8.1-r4.ebuild b/media-video/recordmydesktop/recordmydesktop-0.3.8.1-r4.ebuild
new file mode 100644
index 000000000000..54c31b7da8f5
--- /dev/null
+++ b/media-video/recordmydesktop/recordmydesktop-0.3.8.1-r4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils autotools
+
+DESCRIPTION="A desktop session recorder producing Ogg video/audio files"
+HOMEPAGE="http://recordmydesktop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/recordmydesktop/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="alsa jack"
+
+RDEPEND="sys-libs/zlib
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXdamage
+ media-libs/libvorbis
+ media-libs/libogg
+ media-libs/libtheora[encode]
+ x11-libs/libICE
+ x11-libs/libSM
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_prepare() {
+ if has_version ">=x11-proto/xextproto-7.1.1"; then
+ sed -i \
+ -e 's:shmstr.h:shmproto.h:g' \
+ src/rmd_{getzpixmap.c,update_image.c} || die
+ fi
+
+ # fix weird Framerates with new libtheora
+ epatch "${FILESDIR}/${PV}-fix_new_theora.patch"
+
+ # fix check for jack support
+ epatch "${FILESDIR}/${PV}-fix-libjack-check.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-dependency-tracking \
+ $(use_enable !alsa oss) \
+ $(use_enable jack)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README || die
+}