summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-10-25 09:37:51 -0400
committerCraig Andrews <candrews@gentoo.org>2018-10-25 09:37:51 -0400
commitcdd0e4da50f82b1badca13b52feb19e4b80b9468 (patch)
tree000de5e394aa3dcac879129e44de01a69178467c /media-video/rtmpdump/rtmpdump-9999.ebuild
parentdev-util/rustfmt: bump to v0.9.0 (diff)
downloadgentoo-cdd0e4da50f82b1badca13b52feb19e4b80b9468.tar.gz
gentoo-cdd0e4da50f82b1badca13b52feb19e4b80b9468.tar.bz2
gentoo-cdd0e4da50f82b1badca13b52feb19e4b80b9468.zip
media-video/rtmpdump: OpenSSL 1.1 fix, swf verification type 2
Closes: https://bugs.gentoo.org/669574 Signed-off-by: Craig Andrews <candrews@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'media-video/rtmpdump/rtmpdump-9999.ebuild')
-rw-r--r--media-video/rtmpdump/rtmpdump-9999.ebuild34
1 files changed, 29 insertions, 5 deletions
diff --git a/media-video/rtmpdump/rtmpdump-9999.ebuild b/media-video/rtmpdump/rtmpdump-9999.ebuild
index 83fe157d7a38..8bfb1dd533de 100644
--- a/media-video/rtmpdump/rtmpdump-9999.ebuild
+++ b/media-video/rtmpdump/rtmpdump-9999.ebuild
@@ -1,18 +1,16 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-inherit git-r3 multilib toolchain-funcs multilib-minimal flag-o-matic
+inherit multilib toolchain-funcs multilib-minimal flag-o-matic
DESCRIPTION="RTMP client intended to stream audio or video flash content"
HOMEPAGE="https://rtmpdump.mplayerhq.hu/"
-EGIT_REPO_URI="https://git.ffmpeg.org/rtmpdump.git"
# the library is LGPL-2.1, the command is GPL-2
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS=""
IUSE="gnutls ssl libressl"
DEPEND="ssl? (
@@ -25,6 +23,22 @@ DEPEND="ssl? (
)"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-openssl-1.1.patch"
+ "${FILESDIR}/${PN}-swf_vertification_type_2.patch"
+ "${FILESDIR}/${PN}-swf_vertification_type_2_part_2.patch"
+)
+
+if [[ ${PV} == *9999 ]] ; then
+ KEYWORDS=""
+ SRC_URI=""
+ EGIT_REPO_URI="https://git.ffmpeg.org/rtmpdump.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+ SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+fi
+
pkg_setup() {
if ! use ssl && use gnutls ; then
ewarn "USE='gnutls' is ignored without USE='ssl'."
@@ -32,6 +46,16 @@ pkg_setup() {
fi
}
+src_unpack() {
+ if [[ ${PV} == *9999 ]] ; then
+ git-r3_src_unpack
+ else
+ mkdir -p "${S}" || die "Can't create source directory"
+ cd "${S}" || die
+ unpack ${A}
+ fi
+}
+
src_prepare() {
# fix #571106 by restoring pre-GCC5 inline semantics
append-cflags -std=gnu89
@@ -42,7 +66,7 @@ src_prepare() {
-e 's:OPT:OPTS:' \
-e 's:CFLAGS=.*:& $(OPT):' librtmp/Makefile \
|| die "failed to fix Makefile"
- eapply_user
+ default
multilib_copy_sources
}