summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/sswf/sswf-1.8.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/sswf/sswf-1.8.2-r1.ebuild')
-rw-r--r--media-video/sswf/sswf-1.8.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-video/sswf/sswf-1.8.2-r1.ebuild b/media-video/sswf/sswf-1.8.2-r1.ebuild
new file mode 100644
index 000000000000..3fc76f882ec4
--- /dev/null
+++ b/media-video/sswf/sswf-1.8.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A C++ Library and a script language tool to create Flash (SWF) movies up to version 8"
+HOMEPAGE="http://www.m2osw.com/sswf.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2
+ mirror://sourceforge/${PN}/${P}-doc.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc examples"
+
+RDEPEND="virtual/jpeg
+ media-libs/freetype"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --disable-dependency-tracking --disable-docs \
+ $(use_enable debug) $(use_enable debug yydebug)
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed."
+
+ dodoc README.txt doc/{ASC-TODO,AUTHORS,CHANGES,LINKS,NOTES,TODO}.txt
+ rm -f "${D}"/usr/share/${PN}/*.txt
+
+ use examples || rm -rf "${D}"/usr/share/${PN}/samples
+
+ doman doc/man/man1/*.1
+
+ if use doc; then
+ doman doc/man/man3/action_script_v3.3
+ doman doc/man/man3/libsswf*.3
+ doman doc/man/man3/sswf*.3
+ dohtml -r doc/html/*
+ fi
+}