summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/streamdvd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/streamdvd')
-rw-r--r--media-video/streamdvd/Manifest1
-rw-r--r--media-video/streamdvd/files/streamdvd-0.4-gcc41.patch13
-rw-r--r--media-video/streamdvd/files/streamdvd-0.4-gcc43.patch44
-rw-r--r--media-video/streamdvd/files/streamdvd-0.4-gcc44.patch24
-rw-r--r--media-video/streamdvd/files/streamdvd-0.4-libdvdread.patch36
-rw-r--r--media-video/streamdvd/files/streamdvd-0.4-makefile.patch27
-rw-r--r--media-video/streamdvd/files/streamdvd-0.4.patch22
-rw-r--r--media-video/streamdvd/metadata.xml15
-rw-r--r--media-video/streamdvd/streamdvd-0.4-r1.ebuild59
9 files changed, 241 insertions, 0 deletions
diff --git a/media-video/streamdvd/Manifest b/media-video/streamdvd/Manifest
new file mode 100644
index 000000000000..c0e5f2400fd9
--- /dev/null
+++ b/media-video/streamdvd/Manifest
@@ -0,0 +1 @@
+DIST streamdvd-0.4.tar.gz 152669 RMD160 9688026223cd8d0760a67030cb1eeec103c26d2c SHA1 384c8ec3cc9325e0a876b8b6a7e394dd1d2d5f56 SHA256 0eac9d0d5a901076ee8e832403f3cf7e0ce3a011d7930787a3aebea8acbaf2ec
diff --git a/media-video/streamdvd/files/streamdvd-0.4-gcc41.patch b/media-video/streamdvd/files/streamdvd-0.4-gcc41.patch
new file mode 100644
index 000000000000..2dbbd7117f3d
--- /dev/null
+++ b/media-video/streamdvd/files/streamdvd-0.4-gcc41.patch
@@ -0,0 +1,13 @@
+Index: StreamDVD-0.4/mplex/zalphastrm.hpp
+===================================================================
+--- StreamDVD-0.4.orig/mplex/zalphastrm.hpp
++++ StreamDVD-0.4/mplex/zalphastrm.hpp
+@@ -45,7 +45,7 @@ protected:
+ virtual bool AUBufferNeedsRefill();
+ virtual void NextDTSPTS( clockticks &DTS, clockticks &PTS);
+ virtual void ScanFirstSeqHeader();
+- bool ZAlphaStream::RunOutComplete();
++ bool RunOutComplete();
+
+ private:
+ float z_min;
diff --git a/media-video/streamdvd/files/streamdvd-0.4-gcc43.patch b/media-video/streamdvd/files/streamdvd-0.4-gcc43.patch
new file mode 100644
index 000000000000..89e33f58db4b
--- /dev/null
+++ b/media-video/streamdvd/files/streamdvd-0.4-gcc43.patch
@@ -0,0 +1,44 @@
+diff -aur mplex.old/inputstrm.cpp mplex/inputstrm.cpp
+--- mplex.old/inputstrm.cpp 2004-03-08 23:10:53.000000000 +0100
++++ mplex/inputstrm.cpp 2008-07-07 23:28:19.000000000 +0200
+@@ -23,6 +23,7 @@
+
+ #include "config.h"
+ #include <assert.h>
++#include <climits>
+
+ #include "mjpeg_types.h"
+ #include "fastintfns.h"
+diff -aur mplex.old/multiplexor.cpp mplex/multiplexor.cpp
+--- mplex.old/multiplexor.cpp 2004-03-08 23:10:53.000000000 +0100
++++ mplex/multiplexor.cpp 2008-07-07 23:28:19.000000000 +0200
+@@ -22,6 +22,7 @@
+ #include "config.h"
+ #include <math.h>
+ #include <stdlib.h>
++#include <cstring>
+
+ #include "mjpeg_types.h"
+ #include "mjpeg_logging.h"
+diff -aur mplex.old/padstrm.cpp mplex/padstrm.cpp
+--- mplex.old/padstrm.cpp 2004-03-08 23:10:53.000000000 +0100
++++ mplex/padstrm.cpp 2008-07-07 23:28:19.000000000 +0200
+@@ -25,6 +25,7 @@
+ #endif
+
+ #include "padstrm.hpp"
++#include <cstring>
+
+
+
+diff -aur mplex.old/zalphastrm_in.cpp mplex/zalphastrm_in.cpp
+--- mplex.old/zalphastrm_in.cpp 2004-03-08 23:10:53.000000000 +0100
++++ mplex/zalphastrm_in.cpp 2008-07-07 23:28:19.000000000 +0200
+@@ -23,6 +23,7 @@
+ #include "config.h"
+ #include <math.h>
+ #include <stdlib.h>
++#include <cstring>
+
+ #include "zalphastrm.hpp"
+ #include "interact.hpp"
diff --git a/media-video/streamdvd/files/streamdvd-0.4-gcc44.patch b/media-video/streamdvd/files/streamdvd-0.4-gcc44.patch
new file mode 100644
index 000000000000..2ca12ff29f69
--- /dev/null
+++ b/media-video/streamdvd/files/streamdvd-0.4-gcc44.patch
@@ -0,0 +1,24 @@
+diff -ur StreamDVD-0.4.orig/mplex/lpcmstrm_in.cpp StreamDVD-0.4/mplex/lpcmstrm_in.cpp
+--- StreamDVD-0.4.orig/mplex/lpcmstrm_in.cpp 2004-03-09 00:10:53.000000000 +0200
++++ StreamDVD-0.4/mplex/lpcmstrm_in.cpp 2009-08-05 22:05:48.000000000 +0300
+@@ -52,7 +52,7 @@
+
+ bool LPCMStream::Probe(IBitStream &bs )
+ {
+- char *last_dot = strrchr( bs.StreamName(), '.' );
++ const char *last_dot = strrchr( bs.StreamName(), '.' );
+ return
+ last_dot != NULL
+ && strcmp( last_dot+1, "lpcm") == 0;
+diff -ur StreamDVD-0.4.orig/mplex/yuv4mpeg_ratio.c StreamDVD-0.4/mplex/yuv4mpeg_ratio.c
+--- StreamDVD-0.4.orig/mplex/yuv4mpeg_ratio.c 2004-03-09 00:10:53.000000000 +0200
++++ StreamDVD-0.4/mplex/yuv4mpeg_ratio.c 2009-08-05 22:07:49.000000000 +0300
+@@ -104,7 +104,7 @@
+
+ int y4m_parse_ratio(y4m_ratio_t *r, const char *s)
+ {
+- char *t = strchr(s, ':');
++ const char *t = strchr(s, ':');
+ if (t == NULL) return Y4M_ERR_RANGE;
+ r->n = atoi(s);
+ r->d = atoi(t+1);
diff --git a/media-video/streamdvd/files/streamdvd-0.4-libdvdread.patch b/media-video/streamdvd/files/streamdvd-0.4-libdvdread.patch
new file mode 100644
index 000000000000..b8f59ee54dba
--- /dev/null
+++ b/media-video/streamdvd/files/streamdvd-0.4-libdvdread.patch
@@ -0,0 +1,36 @@
+diff -N -r -u StreamDVD-0.4/contrib/lsdvd/lsdvd.c new/contrib/lsdvd/lsdvd.c
+--- StreamDVD-0.4/contrib/lsdvd/lsdvd.c 2004-03-08 23:10:53.000000000 +0100
++++ new/contrib/lsdvd/lsdvd.c 2006-03-31 12:57:43.000000000 +0200
+@@ -14,6 +14,8 @@
+ * output info structures in form of a Perl module, by Henk Vergonet.
+ * 2004-02-25 now prints the stream-id's for audio and subpicture streams, by Reinhardt Wolf
+ */
++#define __STDC_LIMIT_MACROS
++#include <stdint.h>
+ #include <dvdread/ifo_read.h>
+ #include <string.h>
+ #include <sys/stat.h>
+diff -N -r -u StreamDVD-0.4/contrib/StreamAnalyze/streamanalyze.c new/contrib/StreamAnalyze/streamanalyze.c
+--- StreamDVD-0.4/contrib/StreamAnalyze/streamanalyze.c 2004-03-08 23:10:53.000000000 +0100
++++ new/contrib/StreamAnalyze/streamanalyze.c 2006-03-31 12:57:27.000000000 +0200
+@@ -19,6 +19,8 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <getopt.h>
++#define __STDC_LIMIT_MACROS
++#include <stdint.h>
+ #include <dvdread/ifo_read.h>
+ #include <dvdread/ifo_types.h>
+ #include <dvdread/dvd_reader.h>
+diff -N -r -u StreamDVD-0.4/streamdvd.c new/streamdvd.c
+--- StreamDVD-0.4/streamdvd.c 2004-03-08 23:10:53.000000000 +0100
++++ new/streamdvd.c 2006-03-31 12:50:45.000000000 +0200
+@@ -19,6 +19,8 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <getopt.h>
++#define __STDC_LIMIT_MACROS
++#include <stdint.h>
+ #include <dvdread/ifo_read.h>
+ #include <dvdread/ifo_types.h>
+ #include <dvdread/dvd_reader.h>
diff --git a/media-video/streamdvd/files/streamdvd-0.4-makefile.patch b/media-video/streamdvd/files/streamdvd-0.4-makefile.patch
new file mode 100644
index 000000000000..84608d80a689
--- /dev/null
+++ b/media-video/streamdvd/files/streamdvd-0.4-makefile.patch
@@ -0,0 +1,27 @@
+Index: StreamDVD-0.4/Makefile
+===================================================================
+--- StreamDVD-0.4.orig/Makefile
++++ StreamDVD-0.4/Makefile
+@@ -1,16 +1,16 @@
+ INSTALLDIR = /usr/local/bin/
+
+ all:
+- g++ -g -Wall -ldvdread -lm -o streamdvd -I. -Implex streamdvd.c requant.c mplex/*.c mplex/*.cpp
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o streamdvd -I. -Implex streamdvd.c requant.c mplex/*.c mplex/*.cpp -ldvdread -lm
+
+ addon:
+- gcc -g -Wall -ldvdread -o streamanalyze contrib/StreamAnalyze/streamanalyze.c
+- gcc -g -Wall -ldvdread -DVERSION=\"0.9\" -o lsdvd contrib/lsdvd/lsdvd.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o streamanalyze contrib/StreamAnalyze/streamanalyze.c -ldvdread
++ $(CC) $(CFLAGS) $(LDFLAGS) -DVERSION=\"0.9\" -o lsdvd contrib/lsdvd/lsdvd.c -ldvdread
+
+ gui:
+- g++ -g -Wall -ldvdread -lm -o streamdvd -I. -Implex streamdvd.c requant.c mplex/*.c mplex/*.cpp
+- gcc -g -Wall -ldvdread -o streamanalyze contrib/StreamAnalyze/streamanalyze.c
+- gcc -g -Wall -ldvdread -DVERSION=\"0.9\" -o lsdvd contrib/lsdvd/lsdvd.c
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o streamdvd -I. -Implex streamdvd.c requant.c mplex/*.c mplex/*.cpp -ldvdread -lm
++ $(CC) $(CFLAGS) $(LDFLAGS) -o streamanalyze contrib/StreamAnalyze/streamanalyze.c -ldvdread
++ $(CC) $(CFLAGS) $(LDFLAGS) -DVERSION=\"0.9\" -o lsdvd contrib/lsdvd/lsdvd.c -ldvdread
+
+ clean:
+ rm -f streamdvd streamanalyze lsdvd
diff --git a/media-video/streamdvd/files/streamdvd-0.4.patch b/media-video/streamdvd/files/streamdvd-0.4.patch
new file mode 100644
index 000000000000..d078aa7059a3
--- /dev/null
+++ b/media-video/streamdvd/files/streamdvd-0.4.patch
@@ -0,0 +1,22 @@
+--- Gui/StreamDVD/Gui.pm.orig 2004-03-08 23:10:53.000000000 +0100
++++ Gui/StreamDVD/Gui.pm 2004-05-30 13:24:38.342490078 +0200
+@@ -18,7 +18,7 @@
+ use Tk::BrowseEntry;
+ use Tk::LabFrame;
+ use Tk::Photo;
+-use Tk::JPEG::Lite;
++use Tk::JPEG;
+ use StreamDVD::Defs;
+ use StreamDVD::Calc;
+ use strict;
+--- Gui/StreamDVD/Config.pm.orig 2004-03-08 23:10:53.000000000 +0100
++++ Gui/StreamDVD/Config.pm 2004-05-30 13:24:28.314195864 +0200
+@@ -284,7 +284,7 @@
+ $self->{MOUNT} = "/dvd";
+ $self->{TEMPDIR} = "/tmp";
+ $self->{DATADIR} = $ENV{HOME};
+- $self->{LSDVD} = "lsdvd";
++ $self->{LSDVD} = "lsdvd-streamdvd";
+ $self->{STREAMANALYZE} = "streamanalyze";
+ $self->{STREAMDVD} = "streamdvd";
+ $self->{DVDAUTHOR} = "dvdauthor";
diff --git a/media-video/streamdvd/metadata.xml b/media-video/streamdvd/metadata.xml
new file mode 100644
index 000000000000..338a4e316169
--- /dev/null
+++ b/media-video/streamdvd/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+<maintainer>
+ <email>media-video@gentoo.org</email>
+</maintainer>
+<longdescription>
+StreamDVD is a fast tool to backup Video DVDs 'on the fly', there will
+be no ripping, demultiplexing, recoding, remultiplexing .... You can
+select the wanted title, chapters, video, audio and subpicture streams
+and also a resize factor and StreamDVD will write a 'ready to author'
+vob file to stdout.
+</longdescription>
+</pkgmetadata>
diff --git a/media-video/streamdvd/streamdvd-0.4-r1.ebuild b/media-video/streamdvd/streamdvd-0.4-r1.ebuild
new file mode 100644
index 000000000000..fc21a72d908c
--- /dev/null
+++ b/media-video/streamdvd/streamdvd-0.4-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="fast tool to backup Video DVDs 'on the fly'"
+HOMEPAGE="http://www.badabum.de/streamdvd.html"
+SRC_URI="http://www.badabum.de/down/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+IUSE="X"
+
+DEPEND="media-libs/libdvdread
+ media-video/lsdvd
+ X? ( dev-perl/perl-tk
+ dev-perl/Tk-JPEG-Lite
+ virtual/cdrtools
+ >=media-video/dvdauthor-0.6.5
+ >=app-cdr/dvd+rw-tools-5.13.4.7.4 )"
+
+S=${WORKDIR}/StreamDVD-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use X && epatch "${FILESDIR}"/${P}.patch
+
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+ epatch "${FILESDIR}"/${P}-libdvdread.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" all addon || die # compile also optional packages
+}
+
+src_install() {
+ dobin streamdvd streamanalyze
+ newbin lsdvd lsdvd-streamdvd # patched lsdvd, rename to avoid conflict with media-video/lsdvd
+ dodoc README
+ newdoc contrib/lsdvd/AUTHORS AUTHORS.lsdvd
+ newdoc contrib/lsdvd/README README.lsdvd
+ newdoc contrib/StreamAnalyze/README README.streamanalyze
+ if use X
+ then
+ eval `perl '-V:installvendorlib'`
+ insinto "$installvendorlib/StreamDVD"
+ doins Gui/StreamDVD/*.pm
+ dobin Gui/StreamDVD.pl
+ dosym StreamDVD.pl /usr/bin/streamdvd_gui # convinience symlink
+ newdoc Gui/README README.gui
+ fi
+}