summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-05-11 11:29:52 +0300
committerIan Delaney <idella4@gentoo.org>2016-05-12 19:39:36 +0800
commitca7d356c7031c1237d45308c161e79c8a1c20380 (patch)
tree0712cfd5805386a42d13735181660c9c778ce55f /media-video/subliminal/subliminal-2.0_rc1.ebuild
parentprofiles: mask ~media-video/subliminal-2.0_rc1 wrt bug 582500 (diff)
downloadgentoo-ca7d356c7031c1237d45308c161e79c8a1c20380.tar.gz
gentoo-ca7d356c7031c1237d45308c161e79c8a1c20380.tar.bz2
gentoo-ca7d356c7031c1237d45308c161e79c8a1c20380.zip
media-video/subliminal: verbump to 2.0_rc1
Currently masked due to unsatisfied >=dev-python/rarfile-2.7 dependency. See Gentoo bug 582500. Yes, I've tested with =dev-python/rarfile-2.6 and it doesn't work. Package-Manager: portage-2.2.28 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'media-video/subliminal/subliminal-2.0_rc1.ebuild')
-rw-r--r--media-video/subliminal/subliminal-2.0_rc1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/media-video/subliminal/subliminal-2.0_rc1.ebuild b/media-video/subliminal/subliminal-2.0_rc1.ebuild
new file mode 100644
index 000000000000..2a2aeebd60fe
--- /dev/null
+++ b/media-video/subliminal/subliminal-2.0_rc1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+MY_PV="${PV/_/-}"
+
+DESCRIPTION="Python library to search and download subtitles"
+HOMEPAGE="https://github.com/Diaoul/subliminal https://pypi.python.org/pypi/subliminal"
+SRC_URI="https://github.com/Diaoul/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/guessit-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/babelfish-0.5.2[${PYTHON_USEDEP}]
+ >=dev-python/enzyme-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup-4.2.0:4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/click-4.0[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pysrt-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/appdirs-1.3[${PYTHON_USEDEP}]
+ >=dev-python/rarfile-2.7[compressed,${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/vcrpy-1.6.1[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ )
+"
+
+# Tests require network and severely broken too.
+RESTRICT=test
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+python_prepare_all() {
+ # Disable code checkers as they require unavailable dependencies.
+ sed -i -e 's/--\(pep8\|flakes\)//g' pytest.ini || die
+ sed -i -e "s/'pytest-\(pep8\|flakes\)',//g" setup.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}