summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/super_demux
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/super_demux')
-rw-r--r--media-video/super_demux/Manifest1
-rw-r--r--media-video/super_demux/files/super_demux-0.3.diff12
-rw-r--r--media-video/super_demux/metadata.xml8
-rw-r--r--media-video/super_demux/super_demux-0.3.ebuild31
4 files changed, 52 insertions, 0 deletions
diff --git a/media-video/super_demux/Manifest b/media-video/super_demux/Manifest
new file mode 100644
index 000000000000..d3166e2d6a8c
--- /dev/null
+++ b/media-video/super_demux/Manifest
@@ -0,0 +1 @@
+DIST super_demux-0.3.tgz 10884 RMD160 5a1f46cd9d51057cfb3909934b59d87e9b5c79de SHA1 e32cfed9507889ff369f0687f048d62613c29329 SHA256 189a4a2415afcaa2cdd0b188d537c1d2cc32e29e6d95da10dac4f1f339c1db76
diff --git a/media-video/super_demux/files/super_demux-0.3.diff b/media-video/super_demux/files/super_demux-0.3.diff
new file mode 100644
index 000000000000..80555cecdc71
--- /dev/null
+++ b/media-video/super_demux/files/super_demux-0.3.diff
@@ -0,0 +1,12 @@
+diff -Naur super_demux-0.3.orig/Makefile super_demux-0.3/Makefile
+--- super_demux-0.3.orig/Makefile 2004-12-15 22:01:31.000000000 +0100
++++ super_demux-0.3/Makefile 2007-10-06 16:58:19.000000000 +0200
+@@ -13,7 +13,7 @@
+ all:
+ $(CC) $(CFLAGS) -c $(SRC1)
+
+- $(CC) -o super_demux $(OBJECT1) $(LIBRARY)
++ $(CC) $(LDFLAGS) -o super_demux $(OBJECT1) $(LIBRARY)
+
+ # DEPENDENCIES
+ super_demux.o : super_demux.c
diff --git a/media-video/super_demux/metadata.xml b/media-video/super_demux/metadata.xml
new file mode 100644
index 000000000000..edccfe5754d2
--- /dev/null
+++ b/media-video/super_demux/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+<maintainer>
+<email>media-video@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/media-video/super_demux/super_demux-0.3.ebuild b/media-video/super_demux/super_demux-0.3.ebuild
new file mode 100644
index 000000000000..e3746bf6f8c9
--- /dev/null
+++ b/media-video/super_demux/super_demux-0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs flag-o-matic
+
+IUSE=""
+
+DESCRIPTION="DVB transport stream TS to ES demultiplexer"
+HOMEPAGE="http://panteltje.com/panteltje/dvd/"
+SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}.diff"
+}
+
+src_compile() {
+ append-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin super_demux
+ dodoc CHANGES README
+}