summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-02-21 11:07:56 -0600
committerBen Kohler <bkohler@gentoo.org>2021-02-21 11:08:33 -0600
commitd945afbc4a2d04922704b4baab337657e3f85032 (patch)
tree78b26d6bf5d250a56576066dc0c560cfcb6e7c7d /media-video/ushare
parentdev-python/pandas-datareader: Remove old 0.8.1 (diff)
downloadgentoo-d945afbc4a2d04922704b4baab337657e3f85032.tar.gz
gentoo-d945afbc4a2d04922704b4baab337657e3f85032.tar.bz2
gentoo-d945afbc4a2d04922704b4baab337657e3f85032.zip
media-video/ushare: new snapshot for dlna fix
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'media-video/ushare')
-rw-r--r--media-video/ushare/Manifest1
-rw-r--r--media-video/ushare/ushare-1.1a_p20210221.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/media-video/ushare/Manifest b/media-video/ushare/Manifest
index 1039352320ae..71c135b1869e 100644
--- a/media-video/ushare/Manifest
+++ b/media-video/ushare/Manifest
@@ -1 +1,2 @@
DIST ushare-1.1a_p20200824.tar.gz 72751 BLAKE2B 3f9116eab500ad9eb959ded9b1e406100cfbbc32c27b1cc599ef301f8d72e9acb1e053722b8724fc3d350fffda6e5b932eb78cd5fc3f2b5dbe67431f5f5de5b4 SHA512 530fe718e2d52acc27af670d7e44703b34fea33d15fcda3bd1fd4c5702794647576df8a329a11439f0eeca52e75390548a5417776add7b5ab3f09bb0eb85ac11
+DIST ushare-1.1a_p20210221.tar.gz 72759 BLAKE2B e5dd79cba08c3c7554fd19eb98ecf9920dc1939e5dfe34a803669628b2d4031ebb6e2f037550e5129a8cc6f0c84a9a8e234c3c9823108f374375405ea16b5263 SHA512 c3038d7e7da13a6adbf52a20ffa0b33ca92a7b03d39c0fa6f9bea98484cb062f0509d655f853f7eafe3dab54b2bd97e3c8a4f571686bfdf13dccaa012b0c8202
diff --git a/media-video/ushare/ushare-1.1a_p20210221.ebuild b/media-video/ushare/ushare-1.1a_p20210221.ebuild
new file mode 100644
index 000000000000..3abf6ffb0082
--- /dev/null
+++ b/media-video/ushare/ushare-1.1a_p20210221.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit readme.gentoo-r1 toolchain-funcs systemd
+
+COMMIT="79b0d6e41fd9af73c2ef7ee6b110f9b367295a76"
+
+DESCRIPTION="uShare is a UPnP (TM) A/V & DLNA Media Server"
+HOMEPAGE="https://github.com/ddugovic/uShare/"
+SRC_URI="https://github.com/ddugovic/uShare/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+DEPEND=">=net-libs/libupnp-1.14"
+RDEPEND="acct-user/ushare
+ ${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/01_all_ushare_build_system.patch
+ "${FILESDIR}"/02_all_ushare_build_warnings.patch
+ "${FILESDIR}"/03_all_ushare_mp4_video_mime.patch
+ "${FILESDIR}"/07_all_drop_optimizations.patch
+)
+DOCS="NEWS README.md TODO THANKS AUTHORS"
+DOC_CONTENTS="Please edit /etc/ushare.conf to set the shared directories
+ and other important settings. Check system log if ushare is
+ not booting."
+
+S="${WORKDIR}/uShare-${COMMIT}"
+
+src_configure() {
+ local myconf
+ myconf="--prefix=/usr --sysconfdir=/etc --disable-strip --disable-dlna"
+ # nls can only be disabled, on by default.
+ use nls || myconf="${myconf} --disable-nls"
+
+ # I can't use econf
+ # --host is not implemented in ./configure file
+ tc-export CC CXX
+
+ ./configure ${myconf} || die "./configure failed"
+}
+
+src_install() {
+ default
+ doman src/ushare.1
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}.init.d.ng ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ enewuser ushare
+ readme.gentoo_print_elog
+ elog
+ elog "The config file has been moved to /etc/ushare.conf"
+ elog "Please migrate your settings from /etc/conf.d/ushare"
+ elog "to /etc/ushare.conf in order to use the ushare init script"
+ elog "and systemd unit service."
+ elog
+}