summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/vcdimager
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/vcdimager')
-rw-r--r--media-video/vcdimager/Manifest1
-rw-r--r--media-video/vcdimager/metadata.xml8
-rw-r--r--media-video/vcdimager/vcdimager-0.7.24.ebuild53
3 files changed, 62 insertions, 0 deletions
diff --git a/media-video/vcdimager/Manifest b/media-video/vcdimager/Manifest
new file mode 100644
index 000000000000..a253ba0b6a35
--- /dev/null
+++ b/media-video/vcdimager/Manifest
@@ -0,0 +1 @@
+DIST vcdimager-0.7.24.tar.gz 1066815 SHA256 075d7a67353ff3004745da781435698b6bc4a053838d0d4a3ce0516d7d974694 SHA512 162f361d3c871c85887f0b25e70c207c511dcf597f337633be3ce925e8c589a8ba26275b8378d1002b8c5eb56995eda017f5f1cf52e52a38e9ff900acba7a214 WHIRLPOOL b94f3937415ec1b178484adfc653b1846e9f52ed95fd0677fa5f7b077b345f4cbd3b11526bb9b9011b76f74a916644e9d60dec3ce37571ed97523db04cb5ec42
diff --git a/media-video/vcdimager/metadata.xml b/media-video/vcdimager/metadata.xml
new file mode 100644
index 000000000000..0d9b0dcb7f33
--- /dev/null
+++ b/media-video/vcdimager/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-video/vcdimager/vcdimager-0.7.24.ebuild b/media-video/vcdimager/vcdimager-0.7.24.ebuild
new file mode 100644
index 000000000000..6049afa7ccf7
--- /dev/null
+++ b/media-video/vcdimager/vcdimager-0.7.24.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib-minimal
+
+DESCRIPTION="GNU VCDimager"
+HOMEPAGE="http://www.vcdimager.org/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+xml static-libs"
+
+RDEPEND=">=dev-libs/libcdio-0.90-r1[-minimal,${MULTILIB_USEDEP}]
+ dev-libs/popt
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS BUGS ChangeLog FAQ HACKING NEWS README THANKS TODO"
+
+src_prepare() {
+ # Avoid building useless programs. Bug #226249
+ sed -i \
+ -e 's/check_PROGRAMS =/check_PROGRAMS +=/' \
+ -e 's/noinst_PROGRAMS =/check_PROGRAMS =/' \
+ test/Makefile.in || die
+ sed -i \
+ -e 's/noinst_PROGRAMS =/check_PROGRAMS =/' \
+ example/Makefile.in || die
+}
+
+multilib_src_configure() {
+ # We disable the xmltest because the configure script includes differently
+ # than the actual XML-frontend C files.
+ local myconf
+ if use xml && multilib_is_native_abi ; then
+ myconf="--with-xml-prefix=${EPREFIX}/usr --disable-xmltest"
+ else
+ myconf="--without-xml-frontend"
+ fi
+ multilib_is_native_abi || myconf="${myconf} --without-cli-frontend"
+ ECONF_SOURCE="${S}" \
+ econf $(use_enable static-libs static) ${myconf}
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ einstalldocs
+}