summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-04-09 21:58:43 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-10 09:13:49 +0200
commit6530beb3ab90ebca0a9a5cc65b20e305b6c151b2 (patch)
tree3e0a197b40ce7b2a37a35663b04036c2bdd7d2eb /media-video/vcdimager
parentdev-util/radare2: drop old (diff)
downloadgentoo-6530beb3ab90ebca0a9a5cc65b20e305b6c151b2.tar.gz
gentoo-6530beb3ab90ebca0a9a5cc65b20e305b6c151b2.tar.bz2
gentoo-6530beb3ab90ebca0a9a5cc65b20e305b6c151b2.zip
media-video/vcdimager: Fix building for non-native ABIs.
Closes: https://bugs.gentoo.org/652832
Diffstat (limited to 'media-video/vcdimager')
-rw-r--r--media-video/vcdimager/files/vcdimager-2.0.1-pkg-config.patch11
-rw-r--r--media-video/vcdimager/vcdimager-2.0.1.ebuild12
2 files changed, 19 insertions, 4 deletions
diff --git a/media-video/vcdimager/files/vcdimager-2.0.1-pkg-config.patch b/media-video/vcdimager/files/vcdimager-2.0.1-pkg-config.patch
new file mode 100644
index 000000000000..9d603b918697
--- /dev/null
+++ b/media-video/vcdimager/files/vcdimager-2.0.1-pkg-config.patch
@@ -0,0 +1,11 @@
+--- /configure.ac
++++ /configure.ac
+@@ -171,6 +171,8 @@
+ dnl For vcdimager and vcdxbuild to be able to set creation time of VCD
+ AC_CHECK_FUNCS(getdate strptime, , )
+
++PKG_PROG_PKG_CONFIG
++
+ if test "x$enable_cli_fe" = "xyes" -o "x$enable_xml_fe" = "xyes"; then
+ PKG_CHECK_MODULES(LIBPOPT, popt, [], [enable_cli_fe=no; enable_xml_fe=no])
+ fi
diff --git a/media-video/vcdimager/vcdimager-2.0.1.ebuild b/media-video/vcdimager/vcdimager-2.0.1.ebuild
index 618eb4d7ef3c..0eed4a6d6233 100644
--- a/media-video/vcdimager/vcdimager-2.0.1.ebuild
+++ b/media-video/vcdimager/vcdimager-2.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit multilib-minimal
+inherit autotools multilib-minimal
DESCRIPTION="GNU VCDimager"
HOMEPAGE="https://www.gnu.org/software/vcdimager/"
@@ -20,11 +20,13 @@ RDEPEND="
xml? ( dev-libs/libxml2:2 )
"
DEPEND="${RDEPEND}
- virtual/pkgconfig
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
"
DOCS=( AUTHORS BUGS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+PATCHES=("${FILESDIR}/${P}-pkg-config.patch")
+
src_prepare() {
default
@@ -32,10 +34,12 @@ src_prepare() {
sed -i \
-e 's/check_PROGRAMS =/check_PROGRAMS +=/' \
-e 's/noinst_PROGRAMS =/check_PROGRAMS =/' \
- test/Makefile.in || die
+ test/Makefile.am || die
sed -i \
-e 's/noinst_PROGRAMS =/check_PROGRAMS =/' \
- example/Makefile.in || die
+ example/Makefile.am || die
+
+ eautoreconf
}
multilib_src_configure() {