summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild')
-rw-r--r--media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild b/media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild
new file mode 100644
index 000000000000..82e2c57e141d
--- /dev/null
+++ b/media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+MY_P="${PN}-${PV#*_pre}"
+
+S=${WORKDIR}/vdrsync-${MY_SNAPSHOT}
+
+DESCRIPTION="converting vdr-recordings to mpeg2, dvd or other similar formats"
+HOMEPAGE="http://vdrsync.vdr-portal.de/"
+SRC_URI="http://vdrsync.vdr-portal.de/releases/${MY_P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~amd64"
+IUSE="dvdr"
+
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5.8.0
+ media-fonts/corefonts
+ dvdr? (
+ >=media-libs/gd-2.0.15
+ >=dev-perl/GD-2.0.7
+ >=dev-perl/GDTextUtil-0.86
+ >=media-video/dvdauthor-0.6.8
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ sed -e "s:/usr/X11R6/lib/X11/fonts/truetype/arial.ttf:/usr/share/fonts/corefonts/arial.ttf:g" \
+ -i dvd-menu.pl
+
+ epatch "${FILESDIR}/${P}-path.diff"
+}
+# vdrsync/dvd-menu use hardcoded tmp-directory for large (up to and
+# greater than 1G). Uncomment and change the next two lines to your
+# needs if you need another tmp-Dir
+#sed -e 's:"/tmp/":"/temp/":g' /usr/bin/dvd-menu.pl
+#sed -e 's:"/tmp/":"/temp/":g' /usr/bin/vdrsync.pl
+
+src_install() {
+ dobin check-vdrsync.pl vdrsync.pl vdrsync_buffer.pl
+ use dvdr && dobin dvd-menu.pl
+ dodoc CHANGES
+}